aboutsummaryrefslogtreecommitdiff
path: root/devel/gnu-libtool
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2003-06-26 22:58:32 +0000
committerAde Lovett <ade@FreeBSD.org>2003-06-26 22:58:32 +0000
commitb2fd75e43812932b61dab72c80fedba5f9715b82 (patch)
treec06ec55813ad4aa528be251b248e0309e8332282 /devel/gnu-libtool
parent061c49565fbb5c5cfff7bc561b07c79fbade8f24 (diff)
downloadports-b2fd75e43812932b61dab72c80fedba5f9715b82.tar.gz
ports-b2fd75e43812932b61dab72c80fedba5f9715b82.zip
Notes
Diffstat (limited to 'devel/gnu-libtool')
-rw-r--r--devel/gnu-libtool/Makefile51
-rw-r--r--devel/gnu-libtool/distinfo2
-rw-r--r--devel/gnu-libtool/files/patch-aa24
-rw-r--r--devel/gnu-libtool/files/patch-ab53
-rw-r--r--devel/gnu-libtool/files/patch-ac157
-rw-r--r--devel/gnu-libtool/files/patch-ad241
-rw-r--r--devel/gnu-libtool/files/patch-ae15
-rw-r--r--devel/gnu-libtool/files/patch-af29
-rw-r--r--devel/gnu-libtool/files/patch-ag14
-rw-r--r--devel/gnu-libtool/files/patch-libtoolize.in9
-rw-r--r--devel/gnu-libtool/pkg-descr.libltdl9
-rw-r--r--devel/gnu-libtool/pkg-plist57
-rw-r--r--devel/gnu-libtool/pkg-plist.libltdl5
13 files changed, 202 insertions, 464 deletions
diff --git a/devel/gnu-libtool/Makefile b/devel/gnu-libtool/Makefile
index fe6e1d76b734..573ac0226009 100644
--- a/devel/gnu-libtool/Makefile
+++ b/devel/gnu-libtool/Makefile
@@ -5,26 +5,53 @@
# $FreeBSD$
#
-PORTNAME= libtool
-PORTVERSION= 1.3.4
-PORTREVISION= 4
+PORTNAME?= libtool
+PORTVERSION= 1.4.3
+PORTREVISION?= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
+DISTNAME= libtool-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= Generic shared library support script
-
-# This port has not been upgraded to 1.4 because it is used by about 30% of
-# the ports collection, and more testing is needed. If someone can supply a
-# working patch then it will be upgraded.
+COMMENT?= Generic shared library support script
+LATEST_LINK?= libtool14
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS?= --disable-ltdl-install
+CONFIGURE_ARGS+= --program-suffix=14
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= PREFIX=${PREFIX}
+CONFIGURE_ENV= PREFIX=${PREFIX} PACKAGE=libtool14
+USE_REINPLACE= yes
+
+.if defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
+pre-everything:
+ @${ECHO} ===========================================================
+ @${ECHO} "You have 'USE_LIBTOOL' or 'USE_LIBTOOL_VER' variables"
+ @${ECHO} "defined either in environment or in make(1) arguments."
+ @${ECHO} "Please undefine them and try again."
+ @${ECHO} ===========================================================
+ @${FALSE}
+.endif # defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
+
+post-extract:
+ @${MV} -f ${WRKSRC}/libtool.m4 ${WRKSRC}/libtool14.m4
+ @${MV} -f ${WRKSRC}/ltdl.m4 ${WRKSRC}/ltdl14.m4
+ @${REINPLACE_CMD} -e 's|libtool.m4|libtool14.m4|g' \
+ -e 's|ltdl.m4|ltdl14.m4|g' ${WRKSRC}/Makefile.in
+ @${MV} -f ${WRKSRC}/doc/libtool.info ${WRKSRC}/doc/libtool14.info
+ @${MV} -f ${WRKSRC}/doc/libtool.texi ${WRKSRC}/doc/libtool14.texi
-.ifdef USE_LIBTOOL
-.error You have `USE_LIBTOOL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.if ${PORTNAME} == "libtool"
+post-install:
+ @-${RM} -fr ${PREFIX}/libexec/libtool14
+ ${MKDIR} ${PREFIX}/libexec/libtool14
+.for i in libtool libtoolize
+ ${LN} -sf ${PREFIX}/bin/${i}14 ${PREFIX}/libexec/libtool14/${i}
+.endfor
+.for i in config.guess config.sub
+ ${MV} ${PREFIX}/share/libtool14/${i}14 ${PREFIX}/share/libtool14/${i}
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/devel/gnu-libtool/distinfo b/devel/gnu-libtool/distinfo
index c39e3aaff92d..7cace71782d6 100644
--- a/devel/gnu-libtool/distinfo
+++ b/devel/gnu-libtool/distinfo
@@ -1 +1 @@
-MD5 (libtool-1.3.4.tar.gz) = 0c3844fedd382e5796865ca58842713e
+MD5 (libtool-1.4.3.tar.gz) = d11a3c835449d7fa50a025dc9c01ad81
diff --git a/devel/gnu-libtool/files/patch-aa b/devel/gnu-libtool/files/patch-aa
index 91ff871e5ae3..8ba2b3510563 100644
--- a/devel/gnu-libtool/files/patch-aa
+++ b/devel/gnu-libtool/files/patch-aa
@@ -1,11 +1,15 @@
---- doc/libtool.texi.orig Tue Jun 29 15:48:12 1999
-+++ doc/libtool.texi Tue Aug 31 23:41:25 1999
-@@ -11,7 +11,7 @@
- @set MAILLIST the libtool mailing list @email{libtool@@gnu.org}
- @set objdir .libs
+--- doc/libtool14.info.orig Wed Oct 23 02:26:36 2002
++++ doc/libtool14.info Mon Feb 17 01:46:42 2003
+@@ -3,5 +3,5 @@
--@dircategory GNU programming tools
-+@dircategory Programming & development tools
- @direntry
- * Libtool: (libtool). Generic shared library support script.
- @end direntry
+-INFO-DIR-SECTION GNU programming tools
++INFO-DIR-SECTION Programming & development tools
+ START-INFO-DIR-ENTRY
+-* Libtool: (libtool). Generic shared library support script.
++* Libtool: (libtool14). Generic shared library support script.
+ END-INFO-DIR-ENTRY
+@@ -10,3 +10,3 @@
+ START-INFO-DIR-ENTRY
+-* libtoolize: (libtool)Invoking libtoolize. Adding libtool support.
++* libtoolize: (libtool14)Invoking libtoolize. Adding libtool support.
+ END-INFO-DIR-ENTRY
diff --git a/devel/gnu-libtool/files/patch-ab b/devel/gnu-libtool/files/patch-ab
index f96b92eac308..384c86a0bd18 100644
--- a/devel/gnu-libtool/files/patch-ab
+++ b/devel/gnu-libtool/files/patch-ab
@@ -1,11 +1,50 @@
---- doc/Makefile.in.orig Fri Jul 2 09:24:54 1999
-+++ doc/Makefile.in Tue Aug 31 23:41:57 1999
-@@ -70,7 +70,7 @@
- LIBTOOL = @LIBTOOL@
- LIBTOOL_FLAGS = @LIBTOOL_FLAGS@
+--- doc/Makefile.in.orig Wed Oct 23 02:51:04 2002
++++ doc/Makefile.in Mon Feb 17 02:01:16 2003
+@@ -72,3 +72,3 @@
LN_S = @LN_S@
-MAKEINFO = @MAKEINFO@
+MAKEINFO = @MAKEINFO@ --no-split
NM = @NM@
- OBJDUMP = @OBJDUMP@
- PACKAGE = @PACKAGE@
+@@ -85,4 +85,4 @@
+ AUTOMAKE_OPTIONS = gnits
+-info_TEXINFOS = libtool.texi
+-libtool_TEXINFOS = PLATFORMS fdl.texi
++info_TEXINFOS = libtool14.texi
++libtool14_TEXINFOS = PLATFORMS fdl.texi
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+@@ -90,6 +90,6 @@
+ TEXI2DVI = texi2dvi
+-INFO_DEPS = libtool.info
+-DVIS = libtool.dvi
+-TEXINFOS = libtool.texi
+-DIST_COMMON = $(libtool_TEXINFOS) Makefile.am Makefile.in mdate-sh \
++INFO_DEPS = libtool14.info
++DVIS = libtool14.dvi
++TEXINFOS = libtool14.texi
++DIST_COMMON = $(libtool14_TEXINFOS) Makefile.am Makefile.in mdate-sh \
+ stamp-vti texinfo.tex version.texi
+@@ -115,4 +115,4 @@
+
+-$(srcdir)/stamp-vti: libtool.texi $(top_srcdir)/configure.in
+- @echo "@set UPDATED `$(SHELL) $(srcdir)/mdate-sh $(srcdir)/libtool.texi`" > vti.tmp
++$(srcdir)/stamp-vti: libtool14.texi $(top_srcdir)/configure.in
++ @echo "@set UPDATED `$(SHELL) $(srcdir)/mdate-sh $(srcdir)/libtool14.texi`" > vti.tmp
+ @echo "@set EDITION $(VERSION)" >> vti.tmp
+@@ -135,4 +135,4 @@
+
+-libtool.info: libtool.texi version.texi $(libtool_TEXINFOS)
+-libtool.dvi: libtool.texi version.texi $(libtool_TEXINFOS)
++libtool14.info: libtool14.texi version.texi $(libtool14_TEXINFOS)
++libtool14.dvi: libtool14.texi version.texi $(libtool14_TEXINFOS)
+
+@@ -235,6 +235,6 @@
+ mostlyclean-aminfo:
+- -rm -f libtool.aux libtool.cp libtool.cps libtool.dvi libtool.fn \
+- libtool.fns libtool.ky libtool.kys libtool.ps libtool.log \
+- libtool.pg libtool.toc libtool.tp libtool.tps libtool.vr \
+- libtool.vrs libtool.op libtool.tr libtool.cv libtool.cn
++ -rm -f libtool14.aux libtool14.cp libtool14.cps libtool14.dvi libtool14.fn \
++ libtool14.fns libtool14.ky libtool14.kys libtool14.ps libtool14.log \
++ libtool14.pg libtool14.toc libtool14.tp libtool14.tps libtool14.vr \
++ libtool14.vrs libtool14.op libtool14.tr libtool14.cv libtool14.cn
+
diff --git a/devel/gnu-libtool/files/patch-ac b/devel/gnu-libtool/files/patch-ac
deleted file mode 100644
index 3a1894e10003..000000000000
--- a/devel/gnu-libtool/files/patch-ac
+++ /dev/null
@@ -1,157 +0,0 @@
-
-$FreeBSD$
-
---- ltconfig.orig Tue Dec 7 23:50:48 1999
-+++ ltconfig Sat Jun 8 11:48:12 2002
-@@ -169,7 +169,7 @@
- # Constants:
- PROGRAM=ltconfig
- PACKAGE=libtool
--VERSION=1.3.4
-+VERSION=1.3.4-freebsd-ports
- TIMESTAMP=" (1.385.2.196 1999/12/07 21:47:57)"
- ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
- ac_link='${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
-@@ -185,6 +185,8 @@
- # which needs '.lib').
- enable_static=yes
- enable_fast_install=yes
-+install_ltlibs=yes
-+release_suffix=yes
- enable_dlopen=unknown
- enable_win32_dll=no
- ltmain=
-@@ -242,10 +244,14 @@
-
- Generate a system-specific libtool script.
-
-+ --build no-op to keep compatability with configure scripts generated for 1.4
- --debug enable verbose shell tracing
- --disable-shared do not build shared libraries
- --disable-static do not build static libraries
- --disable-fast-install do not optimize for fast installation
-+ --disable-ltlibs don't install the .la archives
-+ --release-ignore don't use -release specification
-+ --release-suffix use -release suffix for all files
- --enable-dlopen enable dlopen support
- --enable-win32-dll enable building dlls on win32 hosts
- --help display this help and exit
-@@ -268,6 +274,8 @@
- exit 0
- ;;
-
-+ --build=*) ;;
-+
- --debug)
- echo "$progname: enabling shell trace mode"
- set -x
-@@ -279,6 +287,12 @@
-
- --disable-fast-install) enable_fast_install=no ;;
-
-+ --disable-ltlibs) install_ltlibs=no ;;
-+
-+ --release-ignore) release_suffix=no ;;
-+
-+ --release-suffix) release_suffix=all ;;
-+
- --enable-dlopen) enable_dlopen=yes ;;
-
- --enable-win32-dll) enable_win32_dll=yes ;;
-@@ -971,11 +985,11 @@
- $rm conftest.dat
- if ln -s X conftest.dat 2>/dev/null; then
- $rm conftest.dat
-- LN_S="ln -s"
-+ LN_S="ln -sf"
- else
- LN_S=ln
- fi
-- if test "$LN_S" = "ln -s"; then
-+ if test "$LN_S" = "ln -sf"; then
- echo "$ac_t"yes 1>&6
- else
- echo "$ac_t"no 1>&6
-@@ -1226,8 +1240,8 @@
-
- *)
- if $LD --help 2>&1 | egrep ': supported targets:.* elf' > /dev/null; then
-- archive_cmds='$CC -shared $libobjs $deplibs $linkopts ${wl}-soname $wl$soname -o $lib'
-- archive_expsym_cmds='$CC -shared $libobjs $deplibs $linkopts ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
-+ archive_cmds='$CC -shared $compile_rpath $libobjs $deplibs $linkopts ${wl}-soname $wl$soname -o $lib'
-+ archive_expsym_cmds='$CC -shared $compile_rpath $libobjs $deplibs $linkopts ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
- else
- ld_shlibs=no
- fi
-@@ -1353,14 +1367,6 @@
- hardcode_shlibpath_var=no
- ;;
-
-- # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
-- freebsd*)
-- archive_cmds='$CC -shared -o $lib $libobjs $deplibs $linkopts'
-- hardcode_libdir_flag_spec='-R$libdir'
-- hardcode_direct=yes
-- hardcode_shlibpath_var=no
-- ;;
--
- hpux9* | hpux10* | hpux11*)
- case "$host_os" in
- hpux9*) archive_cmds='$rm $objdir/$soname~$LD -b +b $install_libdir -o $objdir/$soname $libobjs $deplibs $linkopts~test $objdir/$soname = $lib || mv $objdir/$soname $lib' ;;
-@@ -1775,7 +1781,7 @@
- version_type=none
- dynamic_linker="$host_os ld.so"
- sys_lib_dlsearch_path_spec="/lib /usr/lib"
--sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
-+sys_lib_search_path_spec="/lib /usr/lib"
- file_magic_cmd=
- file_magic_test_file=
- deplibs_check_method='unknown'
-@@ -1873,19 +1879,22 @@
- version_type=freebsd-$objformat
- case "$version_type" in
- freebsd-elf*)
-- deplibs_check_method='file_magic ELF [0-9][0-9]*-bit [LM]SB shared object'
-- file_magic_cmd=/usr/bin/file
-- file_magic_test_file=`echo /usr/lib/libc.so*`
-- library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so $libname.so'
-- need_version=no
-- need_lib_prefix=no
-+ deplibs_check_method='file_magic (ELF [0-9][0-9]*-bit [LM]SB shared object|current ar archive)'
- ;;
- freebsd-*)
-- deplibs_check_method=unknown
-- library_names_spec='${libname}${release}.so$versuffix $libname.so$versuffix'
-- need_version=yes
-+ deplibs_check_method='file_magic FreeBSD.* shared library'
- ;;
- esac
-+ file_magic_cmd=/usr/bin/file
-+ file_magic_test_file=`echo /usr/lib/libc.so.*`
-+ if test "$release_suffix" = all; then
-+ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so'
-+ else
-+ library_names_spec='${libname}${release}.so$versuffix ${libname}.so'
-+ fi
-+ need_version=no
-+ need_lib_prefix=no
-+ finish_cmds='/usr/bin/env OBJFORMAT="'"$objformat"'" /sbin/ldconfig -m $libdir'
- shlibpath_var=LD_LIBRARY_PATH
- case "$host_os" in
- freebsd2* | freebsd3.[01]* | freebsdelf3.[01]*)
-@@ -2776,6 +2785,15 @@
-
- # Shell to use when invoking shell scripts.
- SHELL=$LTSHELL
-+
-+# Whether to waste disk space.
-+install_ltlibs=$install_ltlibs
-+
-+# What to do with -release.
-+# yes - only for shared archive
-+# no - ingnore
-+# all - for all archives
-+release_suffix=$release_suffix
-
- # Whether or not to build shared libraries.
- build_libtool_libs=$enable_shared
diff --git a/devel/gnu-libtool/files/patch-ad b/devel/gnu-libtool/files/patch-ad
index 3ec71700ffbb..c04c4dd4a24c 100644
--- a/devel/gnu-libtool/files/patch-ad
+++ b/devel/gnu-libtool/files/patch-ad
@@ -1,226 +1,32 @@
$FreeBSD$
---- ltmain.sh.orig Tue Dec 7 23:50:49 1999
-+++ ltmain.sh Thu May 2 10:24:05 2002
-@@ -23,6 +23,9 @@
- # configuration script generated by Autoconf, you may include it under
- # the same distribution terms that you use for the rest of that program.
+--- ltmain.sh.orig Mon Sep 10 22:33:26 2001
++++ ltmain.sh Wed Jan 23 16:39:22 2002
+@@ -1062,6 +1062,12 @@
-+EXPR_COMPAT=1
-+export EXPR_COMPAT
-+
- # Check that we have a working $echo.
- if test "X$1" = X--no-reexec; then
- # Discard the --no-reexec flag, and continue.
-@@ -54,7 +57,7 @@
- # Constants.
- PROGRAM=ltmain.sh
- PACKAGE=libtool
--VERSION=1.3.4
-+VERSION=1.3.4-freebsd-ports
- TIMESTAMP=" (1.385.2.196 1999/12/07 21:47:57)"
-
- default_mode=
-@@ -952,7 +955,11 @@
- continue
- ;;
- release)
-- release="-$arg"
-+ if test "$release_suffix" = all; then
-+ release="$arg"
-+ elif test "$release_suffix" = yes; then
-+ release="-$arg"
-+ fi
- prev=
- continue
- ;;
-@@ -1005,6 +1012,7 @@
- ;;
-
- -avoid-version)
-+ build_old_libs=no
- avoid_version=yes
- continue
- ;;
-@@ -1091,6 +1099,10 @@
- deplibs="$deplibs $arg"
- ;;
-
-+ -?thread)
-+ deplibs="$deplibs $arg"
-+ ;;
-+
-module)
module=yes
++ case $host in
++ *-*-freebsd*)
++ # Do not build the useless static library
++ build_old_libs=no
++ ;;
++ esac
continue
-@@ -1168,7 +1180,7 @@
-
- *.o | *.obj | *.a | *.lib)
- # A standard object.
-- objs="$objs $arg"
-+ libobjs="$libobjs $arg"
;;
- *.lo)
-@@ -1603,12 +1615,6 @@
- exit 1
- fi
-
-- # How the heck are we supposed to write a wrapper for a shared library?
-- if test -n "$link_against_libtool_libs"; then
-- $echo "$modename: error: cannot link shared libraries into libtool libraries" 1>&2
-- exit 1
-- fi
--
- if test -n "$dlfiles$dlprefiles" || test "$dlself" != no; then
- $echo "$modename: warning: \`-dlopen' is ignored for libtool libraries" 1>&2
- fi
-@@ -1795,6 +1801,9 @@
- *-*-cygwin* | *-*-mingw* | *-*-os2* | *-*-beos*)
- # these systems don't actually have a c library (as such)!
+@@ -2444,6 +2450,9 @@
+ *-*-openbsd*)
+ # Do not include libc due to us having libc/libc_r.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
- # Add libc to deplibs on all other systems.
- deplibs="$deplibs -lc"
-@@ -1802,6 +1811,94 @@
- esac
- fi
-
-+ if test -n "$rpath$xrpath"; then
-+ # If the user specified any rpath flags, then add them.
-+ for libdir in $rpath $xrpath; do
-+ # This is the magic to use -rpath.
-+ case "$compile_rpath " in
-+ *" $libdir "*) ;;
-+ *) compile_rpath="$compile_rpath $libdir" ;;
-+ esac
-+ case "$finalize_rpath " in
-+ *" $libdir "*) ;;
-+ *) finalize_rpath="$finalize_rpath $libdir" ;;
-+ esac
-+ done
-+ fi
-+
-+ # Now hardcode the library paths
-+ rpath=
-+ hardcode_libdirs=
-+ for libdir in $compile_rpath; do
-+ if test -n "$hardcode_libdir_flag_spec"; then
-+ if test -n "$hardcode_libdir_separator"; then
-+ if test -z "$hardcode_libdirs"; then
-+ hardcode_libdirs="$libdir"
-+ else
-+ # Just accumulate the unique libdirs.
-+ case "$hardcode_libdir_separator$hardcode_libdirs$hardcode_libdir_separator" in
-+ *"$hardcode_libdir_separator$libdir$hardcode_libdir_separator"*)
-+ ;;
-+ *)
-+ hardcode_libdirs="$hardcode_libdirs$hardcode_libdir_separator$libdir"
-+ ;;
-+ esac
-+ fi
-+ else
-+ eval flag=\"$hardcode_libdir_flag_spec\"
-+ rpath="$rpath $flag"
-+ fi
-+ elif test -n "$runpath_var"; then
-+ case "$perm_rpath " in
-+ *" $libdir "*) ;;
-+ *) perm_rpath="$perm_rpath $libdir" ;;
-+ esac
-+ fi
-+ done
-+ # Substitute the hardcoded libdirs into the rpath.
-+ if test -n "$hardcode_libdir_separator" &&
-+ test -n "$hardcode_libdirs"; then
-+ libdir="$hardcode_libdirs"
-+ eval rpath=\" $hardcode_libdir_flag_spec\"
-+ fi
-+ compile_rpath="$rpath"
-+
-+ rpath=
-+ hardcode_libdirs=
-+ for libdir in $finalize_rpath; do
-+ if test -n "$hardcode_libdir_flag_spec"; then
-+ if test -n "$hardcode_libdir_separator"; then
-+ if test -z "$hardcode_libdirs"; then
-+ hardcode_libdirs="$libdir"
-+ else
-+ # Just accumulate the unique libdirs.
-+ case "$hardcode_libdir_separator$hardcode_libdirs$hardcode_libdir_separator" in
-+ *"$hardcode_libdir_separator$libdir$hardcode_libdir_separator"*)
-+ ;;
-+ *)
-+ hardcode_libdirs="$hardcode_libdirs$hardcode_libdir_separator$libdir"
-+ ;;
-+ esac
-+ fi
-+ else
-+ eval flag=\"$hardcode_libdir_flag_spec\"
-+ rpath="$rpath $flag"
-+ fi
-+ elif test -n "$runpath_var"; then
-+ case "$finalize_perm_rpath " in
-+ *" $libdir "*) ;;
-+ *) finalize_perm_rpath="$finalize_perm_rpath $libdir" ;;
-+ esac
-+ fi
-+ done
-+ # Substitute the hardcoded libdirs into the rpath.
-+ if test -n "$hardcode_libdir_separator" &&
-+ test -n "$hardcode_libdirs"; then
-+ libdir="$hardcode_libdirs"
-+ eval rpath=\" $hardcode_libdir_flag_spec\"
-+ fi
-+ finalize_rpath="$rpath"
-+
- # Create the output directory, or remove our outputs if we need to.
- if test -d $output_objdir; then
- $show "${rm}r $output_objdir/$outputname $output_objdir/$libname.* $output_objdir/${libname}${release}.*"
-@@ -1817,7 +1914,11 @@
-
- # Now set the variables for building old libraries.
- if test "$build_old_libs" = yes && test "$build_libtool_libs" != convenience ; then
-- oldlibs="$oldlibs $output_objdir/$libname.$libext"
-+ if test "$release_suffix" = all; then
-+ oldlibs="$oldlibs $output_objdir/$libname$release.$libext"
-+ else
-+ oldlibs="$oldlibs $output_objdir/$libname.$libext"
-+ fi
-
- # Transform .lo files to .o files.
- oldobjs="$objs "`$echo "X$libobjs" | $SP2NL | $Xsed -e '/\.'${libext}'$/d' -e "$lo2o" | $NL2SP`
-@@ -2011,7 +2112,11 @@
- echo "*** \`nm' from GNU binutils and a full rebuild may help."
- fi
- if test "$build_old_libs" = no; then
-- oldlibs="$output_objdir/$libname.$libext"
-+ if test "$release_suffix" = all; then
-+ oldlibs="$output_objdir/$libname$release.$libext"
-+ else
-+ oldlibs="$output_objdir/$libname.$libext"
-+ fi
- build_libtool_libs=module
- build_old_libs=yes
- else
-@@ -3059,7 +3164,11 @@
- case "$output" in
- *.la)
- old_library=
-- test "$build_old_libs" = yes && old_library="$libname.$libext"
-+ if test "$release_suffix" = all; then
-+ test "$build_old_libs" = yes && old_library="$libname$release.$libext"
-+ else
-+ test "$build_old_libs" = yes && old_library="$libname.$libext"
-+ fi
- $show "creating $output"
-
- if test -n "$xrpath"; then
-@@ -3348,10 +3457,12 @@
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4210,10 +4219,17 @@
fi
# Install the pseudo-library for information purposes.
@@ -228,20 +34,17 @@ $FreeBSD$
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ if test "$install_ltlibs" = yes; then
++ case $host in
++ *-*-freebsd*)
++ # Do not install the useless pseudo-library
++ ;;
++ *)
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
++ ;;
++ esac
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
-@@ -3440,7 +3551,6 @@
- fi
- libfile="$libdir/`$echo "X$lib" | $Xsed -e 's%^.*/%%g'`"
- if test -n "$libdir" && test ! -f "$libfile"; then
-- $echo "$modename: warning: \`$lib' has not been installed in \`$libdir'" 1>&2
- finalize=no
- fi
- done
diff --git a/devel/gnu-libtool/files/patch-ae b/devel/gnu-libtool/files/patch-ae
index c92b003b58cd..62aeecd4ae60 100644
--- a/devel/gnu-libtool/files/patch-ae
+++ b/devel/gnu-libtool/files/patch-ae
@@ -1,13 +1,14 @@
---- configure.orig Fri Jul 2 09:01:56 1999
-+++ configure Tue Aug 31 23:45:29 1999
-@@ -1853,10 +1853,6 @@
- *) # Relative path.
- ac_sub_cache_file="$ac_dots$cache_file" ;;
+--- configure.orig Wed Oct 23 02:26:05 2002
++++ configure Mon Feb 17 02:04:57 2003
+@@ -865,3 +865,3 @@
+
+-PACKAGE=libtool
++PACKAGE=libtool14
+
+@@ -6089,6 +6089,2 @@
esac
- case "$ac_given_INSTALL" in
- [/$]*) INSTALL="$ac_given_INSTALL" ;;
- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
- esac
- echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
- # The eval makes quoting arguments work.
diff --git a/devel/gnu-libtool/files/patch-af b/devel/gnu-libtool/files/patch-af
index beb6be3b456f..1298dce981e1 100644
--- a/devel/gnu-libtool/files/patch-af
+++ b/devel/gnu-libtool/files/patch-af
@@ -1,13 +1,11 @@
---- libltdl/Makefile.in.orig Tue Dec 7 13:03:38 1999
-+++ libltdl/Makefile.in Mon Jan 17 16:35:34 2000
-@@ -326,17 +326,16 @@
- distdir: $(DISTFILES)
- -rm -rf $(distdir)
+--- libltdl/Makefile.in.orig Wed Oct 23 02:26:07 2002
++++ libltdl/Makefile.in Mon Feb 17 02:06:58 2003
+@@ -342,3 +342,3 @@
mkdir $(distdir)
- -chmod 777 $(distdir)
+ -chmod 555 $(distdir)
@for file in $(DISTFILES); do \
- d=$(srcdir); \
+@@ -346,9 +346,8 @@
if test -d $$d/$$file; then \
- cp -pr $$d/$$file $(distdir)/$$file; \
+ echo no copy dir $$d/$$file; \
@@ -20,5 +18,20 @@
done
+ -chmod a+x $(distdir)/configure
info-am:
- info: info-am
- dvi-am:
+@@ -452,4 +451,4 @@
+ local-install-files: $(DISTFILES)
+- -rm -rf $(DESTDIR)$(datadir)/libtool/libltdl
+- $(mkinstalldirs) $(DESTDIR)$(datadir)/libtool/libltdl
++ -rm -rf $(DESTDIR)$(datadir)/libtool14/libltdl
++ $(mkinstalldirs) $(DESTDIR)$(datadir)/libtool14/libltdl
+ @for file in $(DISTFILES); do \
+@@ -457,6 +456,6 @@
+ if test -d $$d/$$file; then \
+- cp -r $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file; \
++ cp -r $$d/$$file $(DESTDIR)$(datadir)/libtool14/libltdl/$$file; \
+ else \
+- test -f $(DESTDIR)$(datadir)/libtool/libltdl/$$file \
+- || cp $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file || :; \
++ test -f $(DESTDIR)$(datadir)/libtool14/libltdl/$$file \
++ || cp $$d/$$file $(DESTDIR)$(datadir)/libtool14/libltdl/$$file || :; \
+ fi; \
diff --git a/devel/gnu-libtool/files/patch-ag b/devel/gnu-libtool/files/patch-ag
deleted file mode 100644
index 5fdcd1924641..000000000000
--- a/devel/gnu-libtool/files/patch-ag
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- libltdl/configure 2001/01/31 10:58:38 1.1
-+++ libltdl/configure 2001/01/31 10:59:14
-@@ -1455,7 +1455,7 @@
- esac
-
- # Check for any special flags to pass to ltconfig.
--libtool_flags="--cache-file=$cache_file"
-+libtool_flags="--cache-file=$cache_file --disable-ltlibs"
- test "$enable_shared" = no && libtool_flags="$libtool_flags --disable-shared"
- test "$enable_static" = no && libtool_flags="$libtool_flags --disable-static"
- test "$enable_fast_install" = no && libtool_flags="$libtool_flags --disable-fast-install"
diff --git a/devel/gnu-libtool/files/patch-libtoolize.in b/devel/gnu-libtool/files/patch-libtoolize.in
new file mode 100644
index 000000000000..b92bbeb9d8e9
--- /dev/null
+++ b/devel/gnu-libtool/files/patch-libtoolize.in
@@ -0,0 +1,9 @@
+--- libtoolize.in.orig Sun Oct 13 16:21:38 2002
++++ libtoolize.in Mon Feb 17 01:56:19 2003
+@@ -39,4 +39,4 @@
+
+-libtool_m4="$aclocaldir/libtool.m4"
+-ltdl_m4="$aclocaldir/ltdl.m4"
++libtool_m4="$aclocaldir/libtool14.m4"
++ltdl_m4="$aclocaldir/ltdl14.m4"
+
diff --git a/devel/gnu-libtool/pkg-descr.libltdl b/devel/gnu-libtool/pkg-descr.libltdl
new file mode 100644
index 000000000000..e57b99f21a5c
--- /dev/null
+++ b/devel/gnu-libtool/pkg-descr.libltdl
@@ -0,0 +1,9 @@
+This is GNU libltdl, a system independent dlopen wrapper for GNU libtool.
+
+It supports the following dlopen interfaces:
+* dlopen (Solaris, Linux and various BSD flavors)
+* shl_load (HP-UX)
+* LoadLibrary (Win16 and Win32)
+* load_add_on (BeOS)
+* GNU DLD (emulates dynamic linking for static libraries)
+* libtool's dlpreopen
diff --git a/devel/gnu-libtool/pkg-plist b/devel/gnu-libtool/pkg-plist
index f057cdf134b2..c0510d95ad88 100644
--- a/devel/gnu-libtool/pkg-plist
+++ b/devel/gnu-libtool/pkg-plist
@@ -1,29 +1,28 @@
-bin/libtool
-bin/libtoolize
-include/ltdl.h
-@unexec install-info --delete %D/info/libtool.info %D/info/dir
-info/libtool.info
-@exec install-info %D/info/libtool.info %D/info/dir
-lib/libltdl.a
-lib/libltdl.so
-lib/libltdl.so.1
-share/aclocal/libtool.m4
-share/libtool/config.guess
-share/libtool/config.sub
-share/libtool/libltdl/COPYING.LIB
-share/libtool/libltdl/Makefile.am
-share/libtool/libltdl/Makefile.in
-share/libtool/libltdl/README
-share/libtool/libltdl/acconfig.h
-share/libtool/libltdl/acinclude.m4
-share/libtool/libltdl/aclocal.m4
-share/libtool/libltdl/config.h.in
-share/libtool/libltdl/configure
-share/libtool/libltdl/configure.in
-share/libtool/libltdl/ltdl.c
-share/libtool/libltdl/ltdl.h
-share/libtool/libltdl/stamp-h.in
-share/libtool/ltconfig
-share/libtool/ltmain.sh
-@dirrm share/libtool/libltdl
-@dirrm share/libtool
+@comment $FreeBSD$
+bin/libtool14
+bin/libtoolize14
+libexec/libtool14/libtool
+libexec/libtool14/libtoolize
+@unexec install-info --delete %D/info/libtool14.info %D/info/dir
+info/libtool14.info
+@exec install-info %D/info/libtool14.info %D/info/dir
+share/aclocal/libtool14.m4
+share/aclocal/ltdl14.m4
+share/libtool14/config.guess
+share/libtool14/config.sub
+share/libtool14/libltdl/COPYING.LIB
+share/libtool14/libltdl/Makefile.am
+share/libtool14/libltdl/Makefile.in
+share/libtool14/libltdl/README
+share/libtool14/libltdl/acinclude.m4
+share/libtool14/libltdl/aclocal.m4
+share/libtool14/libltdl/config-h.in
+share/libtool14/libltdl/configure
+share/libtool14/libltdl/configure.in
+share/libtool14/libltdl/ltdl.c
+share/libtool14/libltdl/ltdl.h
+share/libtool14/libltdl/stamp-h.in
+share/libtool14/ltmain.sh
+@dirrm share/libtool14/libltdl
+@dirrm share/libtool14
+@dirrm libexec/libtool14
diff --git a/devel/gnu-libtool/pkg-plist.libltdl b/devel/gnu-libtool/pkg-plist.libltdl
new file mode 100644
index 000000000000..1a8458d1a65c
--- /dev/null
+++ b/devel/gnu-libtool/pkg-plist.libltdl
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+include/ltdl.h
+lib/libltdl.a
+lib/libltdl.so
+lib/libltdl.so.4