aboutsummaryrefslogtreecommitdiff
path: root/devel/godot2/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-12 19:28:38 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-12 19:28:38 +0000
commit7bf077f8e2f461e29376068022378f27cc314aa0 (patch)
treec871c86e977121640049420b70ba67e251e24523 /devel/godot2/Makefile
parent3d55eddff7e1761575e29e946d384ad42eca3067 (diff)
downloadports-7bf077f8e2f461e29376068022378f27cc314aa0.tar.gz
ports-7bf077f8e2f461e29376068022378f27cc314aa0.zip
devel/godot2: stop using builtin libpng
platform/x11/detect.py actually forces builtin libpng if builtin freetype or zlib is used. Use the system ones. This also fixes build on powerpc64le, since builtin libpng is not built with VSX. PR: 254703 Approved by: FreeBSD@ShaneWare.Biz (maintainer)
Diffstat (limited to 'devel/godot2/Makefile')
-rw-r--r--devel/godot2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/godot2/Makefile b/devel/godot2/Makefile
index 8e8735d530b4..1a990dfdfceb 100644
--- a/devel/godot2/Makefile
+++ b/devel/godot2/Makefile
@@ -29,7 +29,7 @@ USE_GL= gl glu
USE_GITHUB= yes
GH_ACCOUNT= godotengine
-MAKE_ARGS+= platform=x11 builtin_speex=no builtin_libmpcdec=no verbose=yes
+MAKE_ARGS+= platform=x11 builtin_speex=no builtin_libmpcdec=no verbose=yes builtin_libpng=no builtin_freetype=no builtin_zlib=no
MAKE_ARGS+= ${MAKE_ARGS_${CHOSEN_COMPILER_TYPE}}
MAKE_ARGS_clang= use_llvm=yes
CXXFLAGS+= -DGLEW_NO_GLU -DRTAUDIO_ENABLED -DCRIOGET_NOT_NEEDED