aboutsummaryrefslogtreecommitdiff
path: root/devel/google-perftools
diff options
context:
space:
mode:
authorGiuseppe Pilichi <jacula@FreeBSD.org>2010-08-31 19:36:58 +0000
committerGiuseppe Pilichi <jacula@FreeBSD.org>2010-08-31 19:36:58 +0000
commite9b20e928f5907978c4872b9a5682035c75ec7b7 (patch)
tree40a6f72e8315c3d0c86119547be9c32d7f214bae /devel/google-perftools
parenta921d54edfbeaa8af2336e3e28f92ff57db13d72 (diff)
downloadports-e9b20e928f5907978c4872b9a5682035c75ec7b7.tar.gz
ports-e9b20e928f5907978c4872b9a5682035c75ec7b7.zip
- Update to 1.6
PR: ports/149407 Submitted by: Yuri <yuri@tsoft.com> (maintainer) Approved by: pgj (mentor)
Notes
Notes: svn path=/head/; revision=260300
Diffstat (limited to 'devel/google-perftools')
-rw-r--r--devel/google-perftools/Makefile9
-rw-r--r--devel/google-perftools/distinfo6
-rw-r--r--devel/google-perftools/files/patch-Makefile.in15
-rw-r--r--devel/google-perftools/files/patch-pprof4
-rw-r--r--devel/google-perftools/pkg-plist3
5 files changed, 24 insertions, 13 deletions
diff --git a/devel/google-perftools/Makefile b/devel/google-perftools/Makefile
index ce1c141dd02a..a20fe4f4d421 100644
--- a/devel/google-perftools/Makefile
+++ b/devel/google-perftools/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= google-perftools
-PORTVERSION= 1.5
-PORTREVISION= 2
+PORTVERSION= 1.6
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
${MASTER_SITE_LOCAL}
@@ -20,6 +19,9 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAN1= pprof.1
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
post-patch:
.if defined(NOPORTDOCS)
${REINPLACE_CMD} -e \
@@ -29,7 +31,8 @@ post-patch:
post-build:
@${ECHO}
- @${ECHO} "Be aware that 3 (sampling_test.sh,profiledata_unittest,profiler_unittest.sh) out of 38 self tests is known to fail."
+ @${ECHO} "Be aware that 6 (tcmalloc_minimal_unittest tcmalloc_minimal_debug_unittest tcmalloc_unittest tcmalloc_both_unittest tcmalloc_debug_unittest tcmalloc_and_profiler_unittest) out of 38 self tests is known to fail."
+ @${ECHO} "Perftools developers were notified: http://code.google.com/p/google-perftools/issues/detail?id=212"
@${ECHO} "Run 'make check' and try to fix that. Thanks!"
@${ECHO} "Be aware that another self test (profiler_unittest) can randomly fail on the loaded system."
@${ECHO}
diff --git a/devel/google-perftools/distinfo b/devel/google-perftools/distinfo
index 55a6f80bcb79..5f68fd5363a5 100644
--- a/devel/google-perftools/distinfo
+++ b/devel/google-perftools/distinfo
@@ -1,3 +1,3 @@
-MD5 (google-perftools-1.5.tar.gz) = cab3841f23fb93f8c69aedf60afcc43f
-SHA256 (google-perftools-1.5.tar.gz) = 90651f93d3ceeba568ad0a4e5c5867ef7191433d290cdbca16a12ae3e6fac004
-SIZE (google-perftools-1.5.tar.gz) = 1159627
+MD5 (google-perftools-1.6.tar.gz) = 7acfee8d3e2ba968d20684e9f7033015
+SHA256 (google-perftools-1.6.tar.gz) = 40455b35235da304ad664b05ffbb44a1f65f4ec903e532cf365b2fae9edf1f5e
+SIZE (google-perftools-1.6.tar.gz) = 1193915
diff --git a/devel/google-perftools/files/patch-Makefile.in b/devel/google-perftools/files/patch-Makefile.in
index cdc80e30d924..673aabdeb751 100644
--- a/devel/google-perftools/files/patch-Makefile.in
+++ b/devel/google-perftools/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2009-08-02 19:57:40.000000000 -0700
-+++ Makefile.in 2009-08-02 19:57:47.000000000 -0700
-@@ -1165,7 +1165,7 @@
+--- Makefile.in.orig 2010-08-04 20:17:38.000000000 +0000
++++ Makefile.in 2010-08-27 14:22:38.000000000 +0000
+@@ -1514,7 +1514,7 @@
build_vendor = @build_vendor@
datadir = @datadir@
datarootdir = @datarootdir@
@@ -9,3 +9,12 @@
dvidir = @dvidir@
exec_prefix = @exec_prefix@
host = @host@
+@@ -1609,7 +1609,7 @@
+ # noinst doesn't seem to work with data. I separate them out anyway, in case
+ # one day we figure it out. Regardless, installing the dot files isn't the
+ # end of the world.
+-dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README \
++dist_doc_DATA = AUTHORS ChangeLog INSTALL NEWS README \
+ README_windows.txt TODO doc/index.html doc/designstyle.css \
+ $(am__append_12) doc/tcmalloc.html doc/overview.gif \
+ doc/pageheap.gif doc/spanmap.gif doc/threadheap.gif \
diff --git a/devel/google-perftools/files/patch-pprof b/devel/google-perftools/files/patch-pprof
index 220d66227569..846ad9ce2a01 100644
--- a/devel/google-perftools/files/patch-pprof
+++ b/devel/google-perftools/files/patch-pprof
@@ -4,8 +4,8 @@
my $finish;
my $offset;
my $lib;
-- if ($l =~ /^($h)-($h)\s+..x.\s+($h)\s+\S+:\S+\s+\d+\s+(\S+\.(so|dll|dylib|bundle)((\.\d+)+\w*)?)$/i) {
-+ if ($l =~ /^($h)-($h)\s+..x.\s+($h)\s+\S+:\S+\s+\d+\s+(\S+\.(so|dll|dylib|bundle)((\.\d+)+\w*)?)\s+[A-Z]+\s+[\-0-9]+$/i) {
+- if ($l =~ /^($h)-($h)\s+..x.\s+($h)\s+\S+:\S+\s+\d+\s+(\S+\.(so|dll|dylib|bundle)((\.\d+)+\w*(\.\d+){0,3})?)$/i) {
++ if ($l =~ /^($h)-($h)\s+..x.\s+($h)\s+\S+:\S+\s+\d+\s+(\S+\.(so|dll|dylib|bundle)((\.\d+)+\w*(\.\d+){0,3})?)\s+[A-Z]+\s+[\-0-9]+$/i) {
# Full line from /proc/self/maps. Example:
# 40000000-40015000 r-xp 00000000 03:01 12845071 /lib/ld-2.3.2.so
$start = HexExtend($1);
diff --git a/devel/google-perftools/pkg-plist b/devel/google-perftools/pkg-plist
index 4d916908fbd7..494cd722f11d 100644
--- a/devel/google-perftools/pkg-plist
+++ b/devel/google-perftools/pkg-plist
@@ -33,12 +33,11 @@ lib/libtcmalloc_minimal_debug.la
lib/libtcmalloc_minimal_debug.so
lib/libtcmalloc_minimal_debug.so.0
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.windows
+%%PORTDOCS%%%%DOCSDIR%%/README_windows.txt
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/cpuprofile-fileformat.html
%%PORTDOCS%%%%DOCSDIR%%/cpuprofile.html