aboutsummaryrefslogtreecommitdiff
path: root/devel/googletest
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-12-08 13:24:03 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-12-08 13:24:03 +0000
commit4ced3c507b04c6dfcbe315201e503db9b53d327b (patch)
treedfbde7522626cd0a42dff5a52c988b020c96537f /devel/googletest
parent722d26faefc32e302f92c66ba4713b67151ff5af (diff)
downloadports-4ced3c507b04c6dfcbe315201e503db9b53d327b.tar.gz
ports-4ced3c507b04c6dfcbe315201e503db9b53d327b.zip
Notes
Diffstat (limited to 'devel/googletest')
-rw-r--r--devel/googletest/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/googletest/Makefile b/devel/googletest/Makefile
index 376c2ab9acd1..71813c415e61 100644
--- a/devel/googletest/Makefile
+++ b/devel/googletest/Makefile
@@ -10,11 +10,18 @@ DISTNAME= gtest-${PORTVERSION}
MAINTAINER= clsung@FreeBSD.org
COMMENT= A framework for writing C++ tests on a variety of platforms
+USES= shebangfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_PYTHON_BUILD= yes
+USE_PYTHON_BUILD= 2
+
+python_OLD_CMD= /usr/bin/env python
+python_CMD= /usr/bin/env python2
+SHEBANG_FILES= scripts/fuse_gtest_files.py scripts/gen_gtest_pred_impl.py \
+ scripts/pump.py
regression-test:
cd ${WRKSRC}; ${MAKE} check
+
.include <bsd.port.mk>