aboutsummaryrefslogtreecommitdiff
path: root/devel/goprotobuf
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2015-12-25 12:50:02 +0000
committerCarlo Strub <cs@FreeBSD.org>2015-12-25 12:50:02 +0000
commitbd50fab94b0cff5fee3c5e732939df23bdfffed9 (patch)
tree1ad58a0c7f32f443610d58a96a07be6c234dfdbe /devel/goprotobuf
parent182898838c3dce0a7df6ec5a7d8d586a125f04da (diff)
downloadports-bd50fab94b0cff5fee3c5e732939df23bdfffed9.tar.gz
ports-bd50fab94b0cff5fee3c5e732939df23bdfffed9.zip
Notes
Diffstat (limited to 'devel/goprotobuf')
-rw-r--r--devel/goprotobuf/Makefile8
-rw-r--r--devel/goprotobuf/distinfo4
-rw-r--r--devel/goprotobuf/pkg-descr2
-rw-r--r--devel/goprotobuf/pkg-plist11
4 files changed, 19 insertions, 6 deletions
diff --git a/devel/goprotobuf/Makefile b/devel/goprotobuf/Makefile
index 1f5f6c98f816..28958cbfaeae 100644
--- a/devel/goprotobuf/Makefile
+++ b/devel/goprotobuf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= goprotobuf
-PORTVERSION= 20140812
+PORTVERSION= 20151207
CATEGORIES= devel
MASTER_SITES= http://www.c-s.li/ports/
@@ -13,8 +13,10 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= protoc:${PORTSDIR}/devel/protobuf
-GO_PKGNAME= code.google.com/p/goprotobuf
-GO_TARGET= ${GO_PKGNAME}/proto ${GO_PKGNAME}/protoc-gen-go
+GO_PKGNAME= github.com/golang/protobuf
+GO_TARGET= ${GO_PKGNAME}/proto \
+ ${GO_PKGNAME}/protoc-gen-go \
+ ${GO_PKGNAME}/jsonpb
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
diff --git a/devel/goprotobuf/distinfo b/devel/goprotobuf/distinfo
index 546d452740b4..7dd73225430d 100644
--- a/devel/goprotobuf/distinfo
+++ b/devel/goprotobuf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (goprotobuf-20140812.tar.gz) = 60f81a85ec13d20c32cda9cf1eaf98018926366f9b398b1beca6ee01a9758453
-SIZE (goprotobuf-20140812.tar.gz) = 121510
+SHA256 (goprotobuf-20151207.tar.gz) = 6b83cccaf719ab3716c3b886f2df5372a0390cc5058ace3613da0d2089b7f8ee
+SIZE (goprotobuf-20151207.tar.gz) = 178783
diff --git a/devel/goprotobuf/pkg-descr b/devel/goprotobuf/pkg-descr
index 3ea47f783aff..b7573da0d589 100644
--- a/devel/goprotobuf/pkg-descr
+++ b/devel/goprotobuf/pkg-descr
@@ -1,4 +1,4 @@
Go support, in the form of a library and protocol compiler plugin, for Google's
protocol buffers.
-WWW: http://code.google.com/p/goprotobuf/
+WWW: https://github.com/golang/protobuf/
diff --git a/devel/goprotobuf/pkg-plist b/devel/goprotobuf/pkg-plist
index 9d0d14d0ed2d..d62a963993bd 100644
--- a/devel/goprotobuf/pkg-plist
+++ b/devel/goprotobuf/pkg-plist
@@ -1,5 +1,13 @@
bin/protoc-gen-go
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/jsonpb.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/proto.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/jsonpb/jsonpb.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/jsonpb/jsonpb_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/jsonpb/jsonpb_test_proto/Makefile
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/jsonpb/jsonpb_test_proto/more_test_objects.pb.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/jsonpb/jsonpb_test_proto/more_test_objects.proto
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/jsonpb/jsonpb_test_proto/test_objects.pb.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/jsonpb/jsonpb_test_proto/test_objects.proto
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/Makefile
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/all_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/clone.go
@@ -16,6 +24,9 @@ bin/protoc-gen-go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/pointer_reflect.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/pointer_unsafe.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/properties.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/proto3_proto/proto3.pb.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/proto3_proto/proto3.proto
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/proto3_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/size2_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/size_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/testdata/Makefile