aboutsummaryrefslogtreecommitdiff
path: root/devel/grpc
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2021-01-05 15:07:47 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2021-01-05 15:07:47 +0000
commitbf733d7faa47f597f30c63f61a046a3f4921cef7 (patch)
tree874c21cf6a24bc484e3ef57d496324a3cfba1941 /devel/grpc
parentf26e6b308cf8b0e0fddba2015c7de4784717b706 (diff)
downloadports-bf733d7faa47f597f30c63f61a046a3f4921cef7.tar.gz
ports-bf733d7faa47f597f30c63f61a046a3f4921cef7.zip
devel/grpc: Update to version 1.34.0
https://github.com/grpc/grpc/releases/ Submitted by: sunpoet (patch fixes) Approved by: mfechner, sunpoet, yuri Differential Revision: https://reviews.freebsd.org/D27752
Notes
Notes: svn path=/head/; revision=560402
Diffstat (limited to 'devel/grpc')
-rw-r--r--devel/grpc/Makefile41
-rw-r--r--devel/grpc/distinfo8
-rw-r--r--devel/grpc/files/patch-CMakeLists.txt106
-rw-r--r--devel/grpc/files/patch-cmake_cares.cmake12
-rw-r--r--devel/grpc/files/patch-src_core_lib_security_credentials_jwt_jwt__verifier.cc4
-rw-r--r--devel/grpc/files/patch-src_core_tsi_alts_crypt_aes__gcm.cc4
-rw-r--r--devel/grpc/files/patch-src_core_tsi_ssl__transport__security.cc10
-rw-r--r--devel/grpc/pkg-plist98
8 files changed, 71 insertions, 212 deletions
diff --git a/devel/grpc/Makefile b/devel/grpc/Makefile
index fb4e9db431e3..4d6346e9f41a 100644
--- a/devel/grpc/Makefile
+++ b/devel/grpc/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= grpc
-PORTVERSION= 1.22.0
+PORTVERSION= 1.34.0
DISTVERSIONPREFIX= v
-PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= devel
@@ -14,28 +13,28 @@ COMMENT= HTTP/2-based RPC framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= yasm:devel/yasm
-LIB_DEPENDS= libgflags.so:devel/gflags \
+LIB_DEPENDS= libabsl_base.so:devel/abseil \
+ libbenchmark.so:devel/benchmark \
+ libcares.so:dns/c-ares \
+ libgflags.so:devel/gflags \
libprotobuf.so:devel/protobuf \
- libcares.so:dns/c-ares
-
-USES= cmake go:no_targets localbase:ldflags perl5 pkgconfig ssl
+ libre2.so:devel/re2
+USES= cmake compiler:c++17-lang localbase:ldflags pkgconfig ssl
USE_GITHUB= yes
-GH_TUPLE= google:benchmark:v1.4.1:benchmark/third_party/benchmark
USE_LDCONFIG= yes
-USE_PERL5= build
-PLIST_SUB+= SOVERSION=${PORTVERSION}
-LDFLAGS+= -lcares
-
-CMAKE_ARGS= -DgRPC_ZLIB_PROVIDER:STRING="package" \
- -DgRPC_PROTOBUF_PROVIDER:STRING="package" \
- -DgRPC_GFLAGS_PROVIDER:STRING="package" \
- -DgRPC_SSL_PROVIDER:STRING="package" \
- -DgRPC_CARES_PROVIDER:STRING="package" \
- -DgRPC_BENCHMARK_PROVIDER:STRING="module" \
- -DBENCHMARK_USE_LIBCXX=ON \
- -DBENCHMARK_ENABLE_TESTING=OFF \
- -DBUILD_SHARED_LIBS=ON
+
+CMAKE_ARGS= -DCMAKE_CXX_STANDARD=17 \
+ -DgRPC_ABSL_PROVIDER=package \
+ -DgRPC_BENCHMARK_PROVIDER=package \
+ -DgRPC_CARES_PROVIDER=package \
+ -DgRPC_GFLAGS_PROVIDER=package \
+ -DgRPC_PROTOBUF_PROVIDER=package \
+ -DgRPC_RE2_PROVIDER=package \
+ -DgRPC_SSL_PROVIDER=package \
+ -DgRPC_ZLIB_PROVIDER=package
+CMAKE_ON= BUILD_SHARED_LIBS
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.mk>
diff --git a/devel/grpc/distinfo b/devel/grpc/distinfo
index 8f90fefa28de..7ec677aea572 100644
--- a/devel/grpc/distinfo
+++ b/devel/grpc/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1562093080
-SHA256 (grpc-grpc-v1.22.0_GH0.tar.gz) = 11ac793c562143d52fd440f6549588712badc79211cdc8c509b183cb69bddad8
-SIZE (grpc-grpc-v1.22.0_GH0.tar.gz) = 15082718
-SHA256 (google-benchmark-v1.4.1_GH0.tar.gz) = f8e525db3c42efc9c7f3bc5176a8fa893a9a9920bbd08cef30fb56a51854d60d
-SIZE (google-benchmark-v1.4.1_GH0.tar.gz) = 126850
+TIMESTAMP = 1609277768
+SHA256 (grpc-grpc-v1.34.0_GH0.tar.gz) = 7372a881122cd85a7224435a1d58bc5e11c88d4fb98a64b83f36f3d1c2f16d39
+SIZE (grpc-grpc-v1.34.0_GH0.tar.gz) = 7723327
diff --git a/devel/grpc/files/patch-CMakeLists.txt b/devel/grpc/files/patch-CMakeLists.txt
deleted file mode 100644
index 26e6863d6790..000000000000
--- a/devel/grpc/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,106 +0,0 @@
---- CMakeLists.txt.orig 2018-09-24 23:51:30 UTC
-+++ CMakeLists.txt
-@@ -686,6 +686,7 @@ add_library(address_sorting
- third_party/address_sorting/address_sorting_posix.c
- third_party/address_sorting/address_sorting_windows.c
- )
-+set_target_properties(address_sorting PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(address_sorting PROPERTIES COMPILE_PDB_NAME "address_sorting"
-@@ -809,6 +810,7 @@ add_library(gpr
- src/core/lib/profiling/basic_timers.cc
- src/core/lib/profiling/stap_timers.cc
- )
-+set_target_properties(gpr PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(gpr PROPERTIES COMPILE_PDB_NAME "gpr"
-@@ -1248,6 +1250,7 @@ add_library(grpc
- src/core/ext/filters/workarounds/workaround_utils.cc
- src/core/plugin_registry/grpc_plugin_registry.cc
- )
-+set_target_properties(grpc PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc PROPERTIES COMPILE_PDB_NAME "grpc"
-@@ -1624,6 +1627,7 @@ add_library(grpc_cronet
- src/core/tsi/transport_security_grpc.cc
- src/core/plugin_registry/grpc_cronet_plugin_registry.cc
- )
-+set_target_properties(grpc_cronet PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc_cronet PROPERTIES COMPILE_PDB_NAME "grpc_cronet"
-@@ -2569,6 +2573,7 @@ add_library(grpc_unsecure
- src/core/ext/filters/workarounds/workaround_utils.cc
- src/core/plugin_registry/grpc_unsecure_plugin_registry.cc
- )
-+set_target_properties(grpc_unsecure PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc_unsecure PROPERTIES COMPILE_PDB_NAME "grpc_unsecure"
-@@ -2785,6 +2790,7 @@ add_library(grpc++
- src/cpp/util/time_cc.cc
- src/cpp/codegen/codegen_init.cc
- )
-+set_target_properties(grpc++ PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc++ PROPERTIES COMPILE_PDB_NAME "grpc++"
-@@ -3351,6 +3357,7 @@ add_library(grpc++_cronet
- src/core/ext/transport/chttp2/server/chttp2_server.cc
- src/core/ext/filters/census/grpc_context.cc
- )
-+set_target_properties(grpc++_cronet PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc++_cronet PROPERTIES COMPILE_PDB_NAME "grpc++_cronet"
-@@ -3620,6 +3627,7 @@ add_library(grpc++_error_details
- ${_gRPC_PROTO_GENS_DIR}/src/proto/grpc/status/status.grpc.pb.h
- src/cpp/util/error_details.cc
- )
-+set_target_properties(grpc++_error_details PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc++_error_details PROPERTIES COMPILE_PDB_NAME "grpc++_error_details"
-@@ -3752,6 +3760,7 @@ add_library(grpc++_reflection
- ${_gRPC_PROTO_GENS_DIR}/src/proto/grpc/reflection/v1alpha/reflection.pb.h
- ${_gRPC_PROTO_GENS_DIR}/src/proto/grpc/reflection/v1alpha/reflection.grpc.pb.h
- )
-+set_target_properties(grpc++_reflection PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc++_reflection PROPERTIES COMPILE_PDB_NAME "grpc++_reflection"
-@@ -4259,6 +4268,7 @@ add_library(grpc++_unsecure
- src/cpp/util/time_cc.cc
- src/cpp/codegen/codegen_init.cc
- )
-+set_target_properties(grpc++_unsecure PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc++_unsecure PROPERTIES COMPILE_PDB_NAME "grpc++_unsecure"
-@@ -4643,6 +4653,7 @@ add_library(grpc_plugin_support
- src/compiler/python_generator.cc
- src/compiler/ruby_generator.cc
- )
-+set_target_properties(grpc_plugin_support PROPERTIES VERSION 2.0.0 SOVERSION 2)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc_plugin_support PROPERTIES COMPILE_PDB_NAME "grpc_plugin_support"
-@@ -4706,6 +4717,7 @@ add_library(grpcpp_channelz
- ${_gRPC_PROTO_GENS_DIR}/src/proto/grpc/channelz/channelz.pb.h
- ${_gRPC_PROTO_GENS_DIR}/src/proto/grpc/channelz/channelz.grpc.pb.h
- )
-+set_target_properties(grpcpp_channelz PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpcpp_channelz PROPERTIES COMPILE_PDB_NAME "grpcpp_channelz"
-@@ -5246,6 +5258,7 @@ if (gRPC_BUILD_CSHARP_EXT)
- add_library(grpc_csharp_ext SHARED
- src/csharp/ext/grpc_csharp_ext.c
- )
-+set_target_properties(grpc_csharp_ext PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
-
- if(WIN32 AND MSVC)
- set_target_properties(grpc_csharp_ext PROPERTIES COMPILE_PDB_NAME "grpc_csharp_ext"
diff --git a/devel/grpc/files/patch-cmake_cares.cmake b/devel/grpc/files/patch-cmake_cares.cmake
deleted file mode 100644
index 10b3c46c58bd..000000000000
--- a/devel/grpc/files/patch-cmake_cares.cmake
+++ /dev/null
@@ -1,12 +0,0 @@
---- cmake/cares.cmake.orig 2018-09-24 23:51:30 UTC
-+++ cmake/cares.cmake
-@@ -31,7 +31,8 @@ if("${gRPC_CARES_PROVIDER}" STREQUAL "module")
- endif()
- elseif("${gRPC_CARES_PROVIDER}" STREQUAL "package")
- # Use "CONFIG" as there is no built-in cmake module for c-ares.
-- find_package(c-ares REQUIRED CONFIG)
-+ find_package(PkgConfig REQUIRED)
-+ pkg_search_module(CARES REQUIRED libcares)
- if(TARGET c-ares::cares)
- set(_gRPC_CARES_LIBRARIES c-ares::cares)
- set(_gRPC_CARES_INCLUDE_DIR ${c-ares_INCLUDE_DIR})
diff --git a/devel/grpc/files/patch-src_core_lib_security_credentials_jwt_jwt__verifier.cc b/devel/grpc/files/patch-src_core_lib_security_credentials_jwt_jwt__verifier.cc
index 112caa642e04..d68a3c9ce37f 100644
--- a/devel/grpc/files/patch-src_core_lib_security_credentials_jwt_jwt__verifier.cc
+++ b/devel/grpc/files/patch-src_core_lib_security_credentials_jwt_jwt__verifier.cc
@@ -1,6 +1,6 @@
---- src/core/lib/security/credentials/jwt/jwt_verifier.cc.orig 2018-09-24 23:51:30 UTC
+--- src/core/lib/security/credentials/jwt/jwt_verifier.cc.orig 2020-12-01 19:24:28 UTC
+++ src/core/lib/security/credentials/jwt/jwt_verifier.cc
-@@ -468,7 +468,7 @@ static BIGNUM* bignum_from_base64(const char* b64) {
+@@ -472,7 +472,7 @@ static BIGNUM* bignum_from_base64(const char* b64) {
return result;
}
diff --git a/devel/grpc/files/patch-src_core_tsi_alts_crypt_aes__gcm.cc b/devel/grpc/files/patch-src_core_tsi_alts_crypt_aes__gcm.cc
index 09dd0a84c30b..c14ba4026b09 100644
--- a/devel/grpc/files/patch-src_core_tsi_alts_crypt_aes__gcm.cc
+++ b/devel/grpc/files/patch-src_core_tsi_alts_crypt_aes__gcm.cc
@@ -1,6 +1,6 @@
---- src/core/tsi/alts/crypt/aes_gcm.cc.orig 2018-09-24 23:51:30 UTC
+--- src/core/tsi/alts/crypt/aes_gcm.cc.orig 2020-12-01 19:24:28 UTC
+++ src/core/tsi/alts/crypt/aes_gcm.cc
-@@ -187,7 +187,7 @@ static grpc_status_code aes_gcm_derive_aead_key(uint8_
+@@ -185,7 +185,7 @@ static grpc_status_code aes_gcm_derive_aead_key(uint8_
const uint8_t* kdf_counter) {
unsigned char buf[EVP_MAX_MD_SIZE];
unsigned char ctr = 1;
diff --git a/devel/grpc/files/patch-src_core_tsi_ssl__transport__security.cc b/devel/grpc/files/patch-src_core_tsi_ssl__transport__security.cc
index 16d005fa4d41..055a9ba95f55 100644
--- a/devel/grpc/files/patch-src_core_tsi_ssl__transport__security.cc
+++ b/devel/grpc/files/patch-src_core_tsi_ssl__transport__security.cc
@@ -1,7 +1,7 @@
---- src/core/tsi/ssl_transport_security.cc.orig 2018-09-24 23:51:30 UTC
+--- src/core/tsi/ssl_transport_security.cc.orig 2020-12-01 19:24:28 UTC
+++ src/core/tsi/ssl_transport_security.cc
-@@ -21,7 +21,7 @@
- #include "src/core/tsi/grpc_shadow_boringssl.h"
+@@ -19,7 +19,7 @@
+ #include <grpc/support/port_platform.h>
#include "src/core/tsi/ssl_transport_security.h"
-
@@ -9,7 +9,7 @@
#include <limits.h>
#include <string.h>
-@@ -61,11 +61,10 @@ extern "C" {
+@@ -70,11 +70,10 @@ extern "C" {
#define TSI_SSL_MAX_PROTECTED_FRAME_SIZE_LOWER_BOUND 1024
#define TSI_SSL_HANDSHAKER_OUTGOING_BUFFER_INITIAL_SIZE 1024
@@ -24,7 +24,7 @@
#endif
/* TODO(jboeuf): I have not found a way to get this number dynamically from the
-@@ -1676,7 +1675,7 @@ tsi_result tsi_create_ssl_client_handshaker_factory_wi
+@@ -1930,7 +1929,7 @@ tsi_result tsi_create_ssl_client_handshaker_factory_wi
options->cipher_suites);
if (result != TSI_OK) break;
diff --git a/devel/grpc/pkg-plist b/devel/grpc/pkg-plist
index ac8316fc66ef..80921dae6dec 100644
--- a/devel/grpc/pkg-plist
+++ b/devel/grpc/pkg-plist
@@ -5,7 +5,6 @@ bin/grpc_objective_c_plugin
bin/grpc_php_plugin
bin/grpc_python_plugin
bin/grpc_ruby_plugin
-include/benchmark/benchmark.h
include/grpc++/alarm.h
include/grpc++/channel.h
include/grpc++/client_context.h
@@ -91,7 +90,6 @@ include/grpc/census.h
include/grpc/compression.h
include/grpc/fork.h
include/grpc/grpc.h
-include/grpc/grpc_cronet.h
include/grpc/grpc_posix.h
include/grpc/grpc_security.h
include/grpc/grpc_security_constants.h
@@ -113,6 +111,7 @@ include/grpc/impl/codegen/propagation_bits.h
include/grpc/impl/codegen/slice.h
include/grpc/impl/codegen/status.h
include/grpc/impl/codegen/sync.h
+include/grpc/impl/codegen/sync_abseil.h
include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
@@ -132,6 +131,7 @@ include/grpc/support/log_windows.h
include/grpc/support/port_platform.h
include/grpc/support/string_util.h
include/grpc/support/sync.h
+include/grpc/support/sync_abseil.h
include/grpc/support/sync_custom.h
include/grpc/support/sync_generic.h
include/grpc/support/sync_posix.h
@@ -140,26 +140,18 @@ include/grpc/support/thd_id.h
include/grpc/support/time.h
include/grpc/support/workaround_list.h
include/grpcpp/alarm.h
-include/grpcpp/alarm_impl.h
include/grpcpp/channel.h
-include/grpcpp/channel_impl.h
include/grpcpp/client_context.h
include/grpcpp/completion_queue.h
include/grpcpp/create_channel.h
-include/grpcpp/create_channel_impl.h
include/grpcpp/create_channel_posix.h
-include/grpcpp/create_channel_posix_impl.h
include/grpcpp/ext/channelz_service_plugin.h
-include/grpcpp/ext/channelz_service_plugin_impl.h
include/grpcpp/ext/health_check_service_server_builder_option.h
include/grpcpp/ext/proto_server_reflection_plugin.h
-include/grpcpp/ext/proto_server_reflection_plugin_impl.h
include/grpcpp/generic/async_generic_service.h
include/grpcpp/generic/generic_stub.h
-include/grpcpp/generic/generic_stub_impl.h
include/grpcpp/grpcpp.h
include/grpcpp/health_check_service_interface.h
-include/grpcpp/health_check_service_interface_impl.h
include/grpcpp/impl/call.h
include/grpcpp/impl/channel_argument_option.h
include/grpcpp/impl/client_unary_call.h
@@ -175,24 +167,23 @@ include/grpcpp/impl/codegen/callback_common.h
include/grpcpp/impl/codegen/channel_interface.h
include/grpcpp/impl/codegen/client_callback.h
include/grpcpp/impl/codegen/client_context.h
-include/grpcpp/impl/codegen/client_context_impl.h
include/grpcpp/impl/codegen/client_interceptor.h
include/grpcpp/impl/codegen/client_unary_call.h
include/grpcpp/impl/codegen/completion_queue.h
-include/grpcpp/impl/codegen/completion_queue_impl.h
include/grpcpp/impl/codegen/completion_queue_tag.h
include/grpcpp/impl/codegen/config.h
include/grpcpp/impl/codegen/config_protobuf.h
include/grpcpp/impl/codegen/core_codegen.h
include/grpcpp/impl/codegen/core_codegen_interface.h
include/grpcpp/impl/codegen/create_auth_context.h
+include/grpcpp/impl/codegen/delegating_channel.h
include/grpcpp/impl/codegen/grpc_library.h
include/grpcpp/impl/codegen/intercepted_channel.h
include/grpcpp/impl/codegen/interceptor.h
include/grpcpp/impl/codegen/interceptor_common.h
include/grpcpp/impl/codegen/message_allocator.h
include/grpcpp/impl/codegen/metadata_map.h
-include/grpcpp/impl/codegen/method_handler_impl.h
+include/grpcpp/impl/codegen/method_handler.h
include/grpcpp/impl/codegen/proto_buffer_reader.h
include/grpcpp/impl/codegen/proto_buffer_writer.h
include/grpcpp/impl/codegen/proto_utils.h
@@ -201,8 +192,8 @@ include/grpcpp/impl/codegen/rpc_service_method.h
include/grpcpp/impl/codegen/security/auth_context.h
include/grpcpp/impl/codegen/serialization_traits.h
include/grpcpp/impl/codegen/server_callback.h
+include/grpcpp/impl/codegen/server_callback_handlers.h
include/grpcpp/impl/codegen/server_context.h
-include/grpcpp/impl/codegen/server_context_impl.h
include/grpcpp/impl/codegen/server_interceptor.h
include/grpcpp/impl/codegen/server_interface.h
include/grpcpp/impl/codegen/service_type.h
@@ -220,39 +211,33 @@ include/grpcpp/impl/rpc_method.h
include/grpcpp/impl/rpc_service_method.h
include/grpcpp/impl/serialization_traits.h
include/grpcpp/impl/server_builder_option.h
-include/grpcpp/impl/server_builder_option_impl.h
include/grpcpp/impl/server_builder_plugin.h
include/grpcpp/impl/server_initializer.h
-include/grpcpp/impl/server_initializer_impl.h
include/grpcpp/impl/service_type.h
include/grpcpp/resource_quota.h
-include/grpcpp/resource_quota_impl.h
+include/grpcpp/security/alts_context.h
+include/grpcpp/security/alts_util.h
include/grpcpp/security/auth_context.h
include/grpcpp/security/auth_metadata_processor.h
-include/grpcpp/security/auth_metadata_processor_impl.h
include/grpcpp/security/credentials.h
-include/grpcpp/security/credentials_impl.h
include/grpcpp/security/server_credentials.h
-include/grpcpp/security/server_credentials_impl.h
+include/grpcpp/security/tls_certificate_provider.h
+include/grpcpp/security/tls_credentials_options.h
include/grpcpp/server.h
include/grpcpp/server_builder.h
-include/grpcpp/server_builder_impl.h
include/grpcpp/server_context.h
-include/grpcpp/server_impl.h
include/grpcpp/server_posix.h
-include/grpcpp/server_posix_impl.h
include/grpcpp/support/async_stream.h
include/grpcpp/support/async_unary_call.h
include/grpcpp/support/byte_buffer.h
include/grpcpp/support/channel_arguments.h
-include/grpcpp/support/channel_arguments_impl.h
include/grpcpp/support/client_callback.h
include/grpcpp/support/client_interceptor.h
include/grpcpp/support/config.h
include/grpcpp/support/error_details.h
-include/grpcpp/support/error_details_impl.h
include/grpcpp/support/interceptor.h
include/grpcpp/support/message_allocator.h
+include/grpcpp/support/method_handler.h
include/grpcpp/support/proto_buffer_reader.h
include/grpcpp/support/proto_buffer_writer.h
include/grpcpp/support/server_callback.h
@@ -265,56 +250,51 @@ include/grpcpp/support/stub_options.h
include/grpcpp/support/sync_stream.h
include/grpcpp/support/time.h
include/grpcpp/support/validate_service_config.h
-lib/cmake/benchmark/benchmarkConfig.cmake
-lib/cmake/benchmark/benchmarkConfigVersion.cmake
-lib/cmake/benchmark/benchmarkTargets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/benchmark/benchmarkTargets.cmake
lib/cmake/grpc/gRPCConfig.cmake
lib/cmake/grpc/gRPCConfigVersion.cmake
lib/cmake/grpc/gRPCTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/grpc/gRPCTargets.cmake
+lib/cmake/grpc/modules/Findc-ares.cmake
+lib/cmake/grpc/modules/Findre2.cmake
lib/libaddress_sorting.so
-lib/libaddress_sorting.so.1
-lib/libaddress_sorting.so.%%SOVERSION%%
-lib/libbenchmark.so
-lib/libbenchmark.so.0
-lib/libbenchmark.so.0.0.0
-lib/libbenchmark_main.so
-lib/libbenchmark_main.so.0
-lib/libbenchmark_main.so.0.0.0
+lib/libaddress_sorting.so.14
+lib/libaddress_sorting.so.14.0.0
lib/libgpr.so
-lib/libgpr.so.1
-lib/libgpr.so.%%SOVERSION%%
+lib/libgpr.so.14
+lib/libgpr.so.14.0.0
lib/libgrpc++.so
lib/libgrpc++.so.1
-lib/libgrpc++.so.%%SOVERSION%%
-lib/libgrpc++_cronet.so
-lib/libgrpc++_cronet.so.1
-lib/libgrpc++_cronet.so.%%SOVERSION%%
+lib/libgrpc++.so.%%PORTVERSION%%
+lib/libgrpc++_alts.so
+lib/libgrpc++_alts.so.1
+lib/libgrpc++_alts.so.%%PORTVERSION%%
lib/libgrpc++_error_details.so
lib/libgrpc++_error_details.so.1
-lib/libgrpc++_error_details.so.%%SOVERSION%%
+lib/libgrpc++_error_details.so.%%PORTVERSION%%
lib/libgrpc++_reflection.so
lib/libgrpc++_reflection.so.1
-lib/libgrpc++_reflection.so.%%SOVERSION%%
+lib/libgrpc++_reflection.so.%%PORTVERSION%%
lib/libgrpc++_unsecure.so
+lib/libgrpc++_unsecure.so.1
+lib/libgrpc++_unsecure.so.%%PORTVERSION%%
lib/libgrpc.so
-lib/libgrpc.so.1
-lib/libgrpc.so.%%SOVERSION%%
-lib/libgrpc_cronet.so
-lib/libgrpc_cronet.so.1
-lib/libgrpc_cronet.so.%%SOVERSION%%
-lib/libgrpc_csharp_ext.so
-lib/libgrpc_csharp_ext.so.1
-lib/libgrpc_csharp_ext.so.%%SOVERSION%%
+lib/libgrpc.so.14
+lib/libgrpc.so.14.0.0
lib/libgrpc_plugin_support.so
-lib/libgrpc_plugin_support.so.2
-lib/libgrpc_plugin_support.so.2.0.0
+lib/libgrpc_plugin_support.so.1
+lib/libgrpc_plugin_support.so.%%PORTVERSION%%
lib/libgrpc_unsecure.so
-lib/libgrpc_unsecure.so.1
-lib/libgrpc_unsecure.so.%%SOVERSION%%
+lib/libgrpc_unsecure.so.14
+lib/libgrpc_unsecure.so.14.0.0
lib/libgrpcpp_channelz.so
lib/libgrpcpp_channelz.so.1
-lib/libgrpcpp_channelz.so.%%SOVERSION%%
-libdata/pkgconfig/benchmark.pc
+lib/libgrpcpp_channelz.so.%%PORTVERSION%%
+lib/libupb.so
+lib/libupb.so.14
+lib/libupb.so.14.0.0
+libdata/pkgconfig/gpr.pc
+libdata/pkgconfig/grpc++.pc
+libdata/pkgconfig/grpc++_unsecure.pc
+libdata/pkgconfig/grpc.pc
+libdata/pkgconfig/grpc_unsecure.pc
%%DATADIR%%/roots.pem