aboutsummaryrefslogtreecommitdiff
path: root/devel/grv/Makefile
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-09-20 11:31:49 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-09-20 11:31:49 +0000
commit29d16a42da3e45cfa889d2a13d63b4b48827d51d (patch)
tree02faa2c2048212fefcfd9785a72467cd3c80b570 /devel/grv/Makefile
parent361c4cd353768ce11686f9e072e119eca78c57f7 (diff)
downloadports-29d16a42da3e45cfa889d2a13d63b4b48827d51d.tar.gz
ports-29d16a42da3e45cfa889d2a13d63b4b48827d51d.zip
Notes
Diffstat (limited to 'devel/grv/Makefile')
-rw-r--r--devel/grv/Makefile42
1 files changed, 20 insertions, 22 deletions
diff --git a/devel/grv/Makefile b/devel/grv/Makefile
index 04424b235bd1..b1b9da5c8043 100644
--- a/devel/grv/Makefile
+++ b/devel/grv/Makefile
@@ -18,21 +18,24 @@ USES= go ncurses pkgconfig readline:port
USE_GITHUB= yes
GH_ACCOUNT= rgburke
GH_SUBDIR= src/github.com/rgburke/grv
-GH_TUPLE= bradfitz:slice:2b758aa:slice/src/github.com/bradfitz/slice \
- camlistore:go4:94abd69:reflectutil/src/go4.org \
- davecgh:go-spew:d8f796a:spew/src/github.com/davecgh/go-spew \
- gobwas:glob:e7a84e9:glob/src/github.com/gobwas/glob \
- golang:crypto:a1f597e:crypto/src/golang.org/x/crypto \
- golang:sys:fead790:sys/src/golang.org/x/sys \
- mattn:go-runewidth:703b5e6:runewidth/src/github.com/mattn/go-runewidth \
- pmezard:go-difflib:5d4384e:difflib/src/github.com/pmezard/go-difflib \
- rgburke:goncurses:74f667a:goncurses/src/github.com/rgburke/goncurses \
- rjeczalik:notify:629144b:notify/src/github.com/rjeczalik/notify \
- Sirupsen:logrus:v1.4.0:logrus/src/github.com/Sirupsen/logrus \
- stretchr:objx:c61a9df:objx/src/github.com/stretchr/objx \
- stretchr:testify:34c6fa2:testify/src/github.com/stretchr/testify \
- tchap:go-patricia:v2.3.0:patricia/src/github.com/tchap/go-patricia \
- libgit2:git2go:ecaeb7a:git2go/src/gopkg.in/libgit2/git2go.v27 # Keep git2go branch in sync with devel/libgit2 version
+GH_TUPLE= bradfitz:slice:2b758aa:slice/vendor/github.com/bradfitz/slice \
+ camlistore:go4:94abd69:reflectutil/vendor/go4.org \
+ davecgh:go-spew:d8f796a:spew/vendor/github.com/davecgh/go-spew \
+ gobwas:glob:e7a84e9:glob/vendor/github.com/gobwas/glob \
+ golang:crypto:a1f597e:crypto/vendor/golang.org/x/crypto \
+ golang:sys:fead790:sys/vendor/golang.org/x/sys \
+ mattn:go-runewidth:703b5e6:runewidth/vendor/github.com/mattn/go-runewidth \
+ pmezard:go-difflib:5d4384e:difflib/vendor/github.com/pmezard/go-difflib \
+ rgburke:goncurses:74f667a:goncurses/vendor/github.com/rgburke/goncurses \
+ rjeczalik:notify:629144b:notify/vendor/github.com/rjeczalik/notify \
+ Sirupsen:logrus:v1.4.0:logrus/vendor/github.com/Sirupsen/logrus \
+ stretchr:objx:c61a9df:objx/vendor/github.com/stretchr/objx \
+ stretchr:testify:34c6fa2:testify/vendor/github.com/stretchr/testify \
+ tchap:go-patricia:v2.3.0:patricia/vendor/github.com/tchap/go-patricia \
+ libgit2:git2go:ecaeb7a:git2go/vendor/gopkg.in/libgit2/git2go.v27 # Keep this in sync with devel/libgit2 version
+
+GO_TARGET= ./cmd/grv
+GO_BUILDFLAGS= -ldflags "-X main.version=${PORTVERSION}"
PLIST_FILES= bin/grv
@@ -40,14 +43,9 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= *
-do-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build ./cmd/${PORTNAME}
-
do-test:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go test ./cmd/${PORTNAME}
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} test ${GO_BUILDLAGS} ${GO_TARGET}
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}