aboutsummaryrefslogtreecommitdiff
path: root/devel/gtkparasite
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-09-23 09:31:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-09-23 09:31:30 +0000
commitab686017c2a0f93b6f34986f6fa9a3c7ec7d4988 (patch)
treeb7ed009e9afe2a819188e565265eba70712c66b4 /devel/gtkparasite
parent2188341716c75f2c02161ffba59e27e4d1211cfc (diff)
downloadports-ab686017c2a0f93b6f34986f6fa9a3c7ec7d4988.tar.gz
ports-ab686017c2a0f93b6f34986f6fa9a3c7ec7d4988.zip
Notes
Diffstat (limited to 'devel/gtkparasite')
-rw-r--r--devel/gtkparasite/Makefile35
-rw-r--r--devel/gtkparasite/distinfo3
-rw-r--r--devel/gtkparasite/files/patch-USAGE29
-rw-r--r--devel/gtkparasite/pkg-descr20
4 files changed, 87 insertions, 0 deletions
diff --git a/devel/gtkparasite/Makefile b/devel/gtkparasite/Makefile
new file mode 100644
index 000000000000..c7629d42b8c4
--- /dev/null
+++ b/devel/gtkparasite/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gtkparasite
+# Date created: 2009-02-19
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkparasite
+PORTVERSION= 20090819
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= pav
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= GTK+ UI debugging tool
+
+USE_PYTHON= 2.5+
+USE_GNOME= gtk20 pygtk2
+WRKSRC= ${WRKDIR}/chipx86-gtkparasite-a3d862d4a91ea27222e4273a6797f3e47efe6e83
+GNU_CONFIGURE= yes
+PORTDOCS= USAGE
+PLIST_FILES= lib/gtk-2.0/modules/libgtkparasite.a \
+ lib/gtk-2.0/modules/libgtkparasite.la \
+ lib/gtk-2.0/modules/libgtkparasite.so
+USE_AUTOTOOLS= autoconf:262 automake:110 libtool:22
+
+pre-configure:
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e '/.\/configure/d' ./autogen.sh \
+ && ./autogen.sh
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/USAGE ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/gtkparasite/distinfo b/devel/gtkparasite/distinfo
new file mode 100644
index 000000000000..26b90a585e80
--- /dev/null
+++ b/devel/gtkparasite/distinfo
@@ -0,0 +1,3 @@
+MD5 (gtkparasite-20090819.tar.gz) = 2fe349cf30d9406574a04dae57e9f80e
+SHA256 (gtkparasite-20090819.tar.gz) = 7517b25cae2f6e5a15e60c1bd8f1d87b496e912b0d0ee3a4afb7eb75957a7e11
+SIZE (gtkparasite-20090819.tar.gz) = 28486
diff --git a/devel/gtkparasite/files/patch-USAGE b/devel/gtkparasite/files/patch-USAGE
new file mode 100644
index 000000000000..23c4b066fc92
--- /dev/null
+++ b/devel/gtkparasite/files/patch-USAGE
@@ -0,0 +1,29 @@
+
+$FreeBSD$
+
+--- USAGE.orig
++++ USAGE
+@@ -0,0 +1,23 @@
++Parasite is pretty easy to use. Start off by launching with an application by doing the following:
++
++$ GTK_MODULES=gtkparasite appname
++
++The Parasite window will pop up immediately, followed by the application window.
++
++Click the "Inspect" button and then click anywhere in your application's UI to load the widget tree for that window and focus in on the selected widget. You should then be able to browse around the widget tree.
++
++The properties for the selected widget appear on the right-hand side of the Parasite window. Many properties can be modified (nearly anything other than pointer addresses) by clicking on the property value. You'll either be able to type in a new value, or select from a pop-up list.
++
++Toggle "Show Graphic Updates" to see debug rectangles any time part of your UI redraws. This can be used to help optimize drawing performance of a widget.
++
++The Python shell is located at the bottom of the screen. It works like a standard Python shell. You can import modules you need (such as "gtk") and write code to manipulate the widgets.
++
++A special "parasite" module is imported for you that provides a "gobj" function for converting a pointer address for a widget into something you can use in the Python shell. For example:
++
++>>> widget = parasite.gobj(0xDEADBEEF)
++
++
++You can get the pointer addresses from the "Pointer Address" column in the widget tree, or from right-clicking an item in the widget tree and choosing "Send Widget to Shell."
++
++You can then use any PyGTK functions on the widget.
++
diff --git a/devel/gtkparasite/pkg-descr b/devel/gtkparasite/pkg-descr
new file mode 100644
index 000000000000..43b7805f8437
--- /dev/null
+++ b/devel/gtkparasite/pkg-descr
@@ -0,0 +1,20 @@
+Developing and debugging UIs can be a pain. When something
+goes wrong, it's not always obvious why. You can waste hours
+writing logging statements only to find out that a widget is
+in the wrong container, or an attribute wasn't set correctly.
+
+Developing isn't much better either. Ever spend time writing
+temporary code just to test a new feature, code you know you're
+going to throw away in an hour, and yet you end up spending the
+next 20 minutes debugging your temporary code? Sucks, doesn't
+it?
+
+What your program really needs is a good Parasite infestation.
+
+Parasite is a debugging and development tool that runs inside
+your GTK+ application's process. It can inspect your application,
+giving you detailed information on your UI, such as the hierarchy,
+X window IDs, widget properties, and more. You can modify properties
+on the fly in order to experiment with the look of your UI.
+
+WWW: http://chipx86.github.com/gtkparasite/