aboutsummaryrefslogtreecommitdiff
path: root/devel/hg-git
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-04-30 00:37:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-04-30 00:37:16 +0000
commite19f586396f65f8897d0e63b8bdaed5581e9008b (patch)
tree155afa4e195928c06439aeaba0f9fb343338ae45 /devel/hg-git
parent82dc5880e82bbf67ec067fb5edf8afb36d64de19 (diff)
downloadports-e19f586396f65f8897d0e63b8bdaed5581e9008b.tar.gz
ports-e19f586396f65f8897d0e63b8bdaed5581e9008b.zip
Notes
Diffstat (limited to 'devel/hg-git')
-rw-r--r--devel/hg-git/Makefile9
-rw-r--r--devel/hg-git/distinfo4
-rw-r--r--devel/hg-git/files/patch-setup.py17
-rw-r--r--devel/hg-git/pkg-descr2
-rw-r--r--devel/hg-git/pkg-plist2
5 files changed, 22 insertions, 12 deletions
diff --git a/devel/hg-git/Makefile b/devel/hg-git/Makefile
index f21349c15f8b..10ed2da43ed6 100644
--- a/devel/hg-git/Makefile
+++ b/devel/hg-git/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hg-git
-PORTVERSION= 0.3.4
+PORTVERSION= 0.4.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,12 +12,13 @@ COMMENT= Mercurial extension to pull from or push to a Git repository
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dulwich>=0.8.5:${PORTSDIR}/devel/dulwich \
- mercurial>=2.3.2:${PORTSDIR}/devel/mercurial
+RUN_DEPENDS= ${PKGNAMEPREFIX}dulwich>=0.8.7:${PORTSDIR}/devel/dulwich \
+ mercurial>=2.5.2:${PORTSDIR}/devel/mercurial \
+ ${PKGNAMEPREFIX}ordereddict>=1.1:${PORTSDIR}/devel/py-ordereddict
MAKE_JOBS_SAFE= yes
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/-/_/}
diff --git a/devel/hg-git/distinfo b/devel/hg-git/distinfo
index c6d272edb74a..8d2f78ec7fb9 100644
--- a/devel/hg-git/distinfo
+++ b/devel/hg-git/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hg-git-0.3.4.tar.gz) = 3770dd4ce9f230fedff9c699f3a8f8d7210510b799c2ee7df774758026612c50
-SIZE (hg-git-0.3.4.tar.gz) = 18554
+SHA256 (hg-git-0.4.0.tar.gz) = 6a2289539bae5f898c25e66c149cb27eacb3ac2bcd90d3e247ba42ebba9f8a9c
+SIZE (hg-git-0.4.0.tar.gz) = 21981
diff --git a/devel/hg-git/files/patch-setup.py b/devel/hg-git/files/patch-setup.py
index adceafea0bd6..bdab16745110 100644
--- a/devel/hg-git/files/patch-setup.py
+++ b/devel/hg-git/files/patch-setup.py
@@ -1,17 +1,24 @@
---- ./setup.py.orig 2012-11-01 15:10:46.000000000 +0100
-+++ ./setup.py 2012-11-03 10:28:03.799021557 +0100
-@@ -1,7 +1,4 @@
+--- ./setup.py.orig 2013-03-24 22:35:51.000000000 +0100
++++ ./setup.py 2013-03-30 13:51:43.535271164 +0100
+@@ -1,13 +1,5 @@
-try:
- from setuptools import setup
-except:
- from distutils.core import setup
+-
+-try:
+- from collections import OrderedDict
+- extra_req = []
+-except ImportError:
+- extra_req = ['ordereddict>=1.1']
+from distutils.core import setup
++from collections import OrderedDict
setup(
name='hg-git',
-@@ -20,5 +17,4 @@
+@@ -26,5 +18,4 @@
license='GPLv2',
packages=['hggit'],
package_data={ 'hggit': ['help/git.rst'] },
-- install_requires=['dulwich>=0.8.0'],
+- install_requires=['dulwich>=0.8.6'] + extra_req,
)
diff --git a/devel/hg-git/pkg-descr b/devel/hg-git/pkg-descr
index 888a42b8d610..bad3160c97f6 100644
--- a/devel/hg-git/pkg-descr
+++ b/devel/hg-git/pkg-descr
@@ -18,4 +18,4 @@ The plugin is basically functional and usable now, but there are still some
edge cases. However, there are several people using it effectively, so please
test it yourself and report encountered bugs upstream (see website). Thanks!
-WWW: http://hg-git.github.com/
+WWW: http://hg-git.github.com/
diff --git a/devel/hg-git/pkg-plist b/devel/hg-git/pkg-plist
index cebe734e6558..279e14bf8507 100644
--- a/devel/hg-git/pkg-plist
+++ b/devel/hg-git/pkg-plist
@@ -19,4 +19,6 @@
%%PYTHON_SITELIBDIR%%/hggit/util.py
%%PYTHON_SITELIBDIR%%/hggit/util.pyc
%%PYTHON_SITELIBDIR%%/hggit/util.pyo
+%%PYTHON_SITELIBDIR%%/hggit/help/git.rst
+@dirrm %%PYTHON_SITELIBDIR%%/hggit/help
@dirrm %%PYTHON_SITELIBDIR%%/hggit