aboutsummaryrefslogtreecommitdiff
path: root/devel/horde-chora
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-16 12:23:15 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-16 12:23:15 +0000
commit904b85e26155d75cdada9e8dd47ea495706e1592 (patch)
tree38d0a2a2f99b8c4542011647887f194986da331c /devel/horde-chora
parent3b769f462ea31be5386049ea55e91c69992cc60c (diff)
downloadports-904b85e26155d75cdada9e8dd47ea495706e1592.tar.gz
ports-904b85e26155d75cdada9e8dd47ea495706e1592.zip
Notes
Diffstat (limited to 'devel/horde-chora')
-rw-r--r--devel/horde-chora/Makefile11
-rw-r--r--devel/horde-chora/distinfo2
-rw-r--r--devel/horde-chora/pkg-deinstall27
-rw-r--r--devel/horde-chora/pkg-plist13
4 files changed, 48 insertions, 5 deletions
diff --git a/devel/horde-chora/Makefile b/devel/horde-chora/Makefile
index 0329a050b774..d62db78531b1 100644
--- a/devel/horde-chora/Makefile
+++ b/devel/horde-chora/Makefile
@@ -6,11 +6,14 @@
#
PORTNAME= chora
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= devel www
-MASTER_SITES= ftp://ftp.horde.org/pub/chora/tarballs/%SUBDIR%/
-MASTER_SITE_SUBDIR= . old
+MASTER_SITES= ftp://ftp.horde.org/pub/chora/ \
+ ftp://ftp.au.horde.org/pub/horde/chora/ \
+ ftp://ftp.es.horde.org/pub/chora/ \
+ ftp://ftp.it.horde.org/pub/mirror/horde.org/chora/ \
+ ftp://ftp.nl.horde.org/mirror/horde-ftp/pub/chora/ \
+ ftp://ftp.pt.horde.org/pub/horde-ftp/chora/
MAINTAINER= thierry@pompo.net
diff --git a/devel/horde-chora/distinfo b/devel/horde-chora/distinfo
index 4524fff306c1..0ae3903a9fd9 100644
--- a/devel/horde-chora/distinfo
+++ b/devel/horde-chora/distinfo
@@ -1 +1 @@
-MD5 (chora-1.1.tar.gz) = fffcdc04a6440ec42bdc62de79941a4a
+MD5 (chora-1.2.tar.gz) = 27438aa6319c408d93c52e1b25536f95
diff --git a/devel/horde-chora/pkg-deinstall b/devel/horde-chora/pkg-deinstall
new file mode 100644
index 000000000000..02a46f12daa8
--- /dev/null
+++ b/devel/horde-chora/pkg-deinstall
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Backup Chora config files, if needed.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -z "${PACKAGE_BUILDING}" ]; then
+ for cf in `ls ${PKG_PREFIX}/www/horde/chora/config/*php ${PKG_PREFIX}/www/horde/chora/config/*txt`; do
+ diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ case $? in
+ 0) # original config file, will be deleted by pkg-plist
+ ;;
+ 1) # config file has been updated, must be backuped
+ cp -p $cf $cf.previous
+ echo "===> Backing-up..."
+ echo "---> $cf has been saved ***"
+ echo "---> as $cf.previous ***"
+ ;;
+ *) # not found?
+ ;;
+ esac
+ done
+fi
diff --git a/devel/horde-chora/pkg-plist b/devel/horde-chora/pkg-plist
index bd94f74e373a..0b89e2318b32 100644
--- a/devel/horde-chora/pkg-plist
+++ b/devel/horde-chora/pkg-plist
@@ -52,20 +52,25 @@
%%CHORADIR%%/locale/.htaccess
%%CHORADIR%%/locale/cs_CZ/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/de_DE/LC_MESSAGES/chora.mo
+%%CHORADIR%%/locale/en_US/help.xml
%%CHORADIR%%/locale/es_ES/LC_MESSAGES/chora.mo
+%%CHORADIR%%/locale/fi_FI/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/fr_FR/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/nb_NO/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/nl_NL/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/pl_PL/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/pt_BR/LC_MESSAGES/chora.mo
%%CHORADIR%%/locale/sv_SE/LC_MESSAGES/chora.mo
+%%CHORADIR%%/menu.php
%%CHORADIR%%/po/.htaccess
%%CHORADIR%%/po/Makefile
%%CHORADIR%%/po/README
+%%CHORADIR%%/po/chora.pot
%%CHORADIR%%/po/cs_CZ.po
%%CHORADIR%%/po/de_DE.po
%%CHORADIR%%/po/es_ES.po
%%CHORADIR%%/po/extract.pl
+%%CHORADIR%%/po/fi_FI.po
%%CHORADIR%%/po/fr_FR.po
%%CHORADIR%%/po/nb_NO.po
%%CHORADIR%%/po/nl_NL.po
@@ -74,6 +79,8 @@
%%CHORADIR%%/po/shtool
%%CHORADIR%%/po/sv_SE.po
%%CHORADIR%%/po/xgettext.sh
+%%CHORADIR%%/prefs.php
+%%CHORADIR%%/status.php
%%CHORADIR%%/templates/.htaccess
%%CHORADIR%%/templates/annotate/footer.inc
%%CHORADIR%%/templates/annotate/header.inc
@@ -96,6 +103,7 @@
%%CHORADIR%%/templates/directory/footer.inc
%%CHORADIR%%/templates/directory/header.inc
%%CHORADIR%%/templates/error_page.inc
+%%CHORADIR%%/templates/headerbar.inc
%%CHORADIR%%/templates/history/blank.inc
%%CHORADIR%%/templates/history/branch_cell.inc
%%CHORADIR%%/templates/history/footer.inc
@@ -108,6 +116,7 @@
%%CHORADIR%%/templates/log/header.inc
%%CHORADIR%%/templates/log/request.inc
%%CHORADIR%%/templates/log/rev.inc
+%%CHORADIR%%/templates/menu/menu.inc
etc/horde/httpd.conf.chora
%%PORTDOCS%%@dirrm share/doc/chora
@dirrm %%CHORADIR%%/config
@@ -121,8 +130,11 @@ etc/horde/httpd.conf.chora
@dirrm %%CHORADIR%%/locale/cs_CZ
@dirrm %%CHORADIR%%/locale/de_DE/LC_MESSAGES
@dirrm %%CHORADIR%%/locale/de_DE
+@dirrm %%CHORADIR%%/locale/en_US
@dirrm %%CHORADIR%%/locale/es_ES/LC_MESSAGES
@dirrm %%CHORADIR%%/locale/es_ES
+@dirrm %%CHORADIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%CHORADIR%%/locale/fi_FI
@dirrm %%CHORADIR%%/locale/fr_FR/LC_MESSAGES
@dirrm %%CHORADIR%%/locale/fr_FR
@dirrm %%CHORADIR%%/locale/nb_NO/LC_MESSAGES
@@ -145,6 +157,7 @@ etc/horde/httpd.conf.chora
@dirrm %%CHORADIR%%/templates/history
@dirrm %%CHORADIR%%/templates/index
@dirrm %%CHORADIR%%/templates/log
+@dirrm %%CHORADIR%%/templates/menu
@dirrm %%CHORADIR%%/templates
@dirrm %%CHORADIR%%
@unexec if cmp -s %D/www/horde/config/mime_drivers.php %D/www/horde/config/mime_drivers.php.afterChora; then rm -f %D/www/horde/config/mime_drivers.php.afterChora; mv %D/www/horde/config/mime_drivers.php.beforeChora %D/www/horde/config/mime_drivers.php; fi