aboutsummaryrefslogtreecommitdiff
path: root/devel/horde3-chora
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-12-12 12:24:01 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-12-12 12:24:01 +0000
commit1e429944f998b352d7f3efd46ff0c1a0a2f44f03 (patch)
tree368eaa45923e728a9578f2f58fe2e52c54200f10 /devel/horde3-chora
parente252b7167c93062ce5b1ca4853ea7e4d1b684b3d (diff)
downloadports-1e429944f998b352d7f3efd46ff0c1a0a2f44f03.tar.gz
ports-1e429944f998b352d7f3efd46ff0c1a0a2f44f03.zip
Notes
Diffstat (limited to 'devel/horde3-chora')
-rw-r--r--devel/horde3-chora/Makefile62
-rw-r--r--devel/horde3-chora/distinfo2
-rw-r--r--devel/horde3-chora/files/patch-config::sourceroots.php.dist20
-rw-r--r--devel/horde3-chora/pkg-descr16
-rw-r--r--devel/horde3-chora/pkg-plist192
5 files changed, 292 insertions, 0 deletions
diff --git a/devel/horde3-chora/Makefile b/devel/horde3-chora/Makefile
new file mode 100644
index 000000000000..5082469b5695
--- /dev/null
+++ b/devel/horde3-chora/Makefile
@@ -0,0 +1,62 @@
+# Ports collection makefile for: Chora
+# Date created: Mon Nov 26, 2001
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= chora
+PORTVERSION= 2.1.1
+PORTREVISION= 6
+CATEGORIES= devel www
+DIST_SUBDIR= horde
+
+MAINTAINER= davide.italiano@gmail.com
+COMMENT= CVS web-viewer
+
+#-----------------------------------------------------------------------
+# You may define these options:
+#
+# - WITHOUT_SVN : if you don't need subversion;
+#
+# - WITHOUT_CVSPS : if you don't need cvsps;
+#
+# - WITHOUT_CVSGRAPH : if you don't need cvsgraph;
+#
+# - A4 or DJ : if you run enscript with this paper size.
+#
+#-----------------------------------------------------------------------
+
+.if !defined(WITHOUT_SVN)
+RUN_DEPENDS+= ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion
+.endif
+
+.if !defined(WITHOUT_CVSPS)
+RUN_DEPENDS+= ${LOCALBASE}/bin/cvsps:${PORTSDIR}/devel/cvsps
+.endif
+
+.if !defined(WITHOUT_CVSGRAPH)
+RUN_DEPENDS+= ${LOCALBASE}/bin/cvsgraph:${PORTSDIR}/devel/cvsgraph
+.endif
+
+# Specify where your repository belongs.
+# (You can reconfigure it after installation anyway)
+.if defined(PACKAGE_BUILDING) || !defined(CVSROOT) || empty(CVSROOT)
+CVSROOT= /home/cvs
+.endif
+
+USE_HORDE= base pkg-message
+USE_GETTEXT= yes
+PORTDOCS= README BUGS CHANGES CREDITS INSTALL RELEASE_NOTES TODO
+
+pre-configure:
+ @${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|" \
+ -e "s|/usr/bin/cvsgraph|${LOCALBASE}/bin/cvsgraph|" \
+ -e "s|/usr/bin/svn|${LOCALBASE}/bin/svn|" \
+ ${WRKSRC}/config/conf.xml
+ @${REINPLACE_CMD} -e "s|%%CVSROOT%%|${CVSROOT}|" \
+ -e "s|%%CONFDIR%%|${CONFDIR}|" \
+ ${WRKSRC}/config/sourceroots.php.dist
+
+.include "${.CURDIR}/../../www/horde3-base/bsd.horde.mk"
+.include <bsd.port.mk>
diff --git a/devel/horde3-chora/distinfo b/devel/horde3-chora/distinfo
new file mode 100644
index 000000000000..e70bb6d68cb9
--- /dev/null
+++ b/devel/horde3-chora/distinfo
@@ -0,0 +1,2 @@
+SHA256 (horde/chora-h3-2.1.1.tar.gz) = f1af4179d7e03e9bf9fc32ca8e79a8fe0dbb1595a978ddc9a9f74262e7a213e4
+SIZE (horde/chora-h3-2.1.1.tar.gz) = 1028264
diff --git a/devel/horde3-chora/files/patch-config::sourceroots.php.dist b/devel/horde3-chora/files/patch-config::sourceroots.php.dist
new file mode 100644
index 000000000000..1a75771ecaf1
--- /dev/null
+++ b/devel/horde3-chora/files/patch-config::sourceroots.php.dist
@@ -0,0 +1,20 @@
+--- config/sourceroots.php.dist.orig 2008-10-09 09:40:03.000000000 -0800
++++ config/sourceroots.php.dist 2009-03-24 14:46:09.000000000 -0800
+@@ -37,6 +37,17 @@
+ * repositories that require authentication).
+ */
+
++$sourceroots['myprojects'] = array(
++ 'name' => 'Here',
++ 'location' => '%%CVSROOT%%',
++ 'title' => 'To be configured in %%CONFDIR%%/sourceroots.php',
++ 'intro' => 'longIntro.txt',
++ 'default' => true,
++ 'type' => 'cvs',
++);
++
++/*
++
+ $sourceroots['php4'] = array(
+ 'name' => 'PHP4',
+ 'location' => '/home/cvs/php4',
diff --git a/devel/horde3-chora/pkg-descr b/devel/horde3-chora/pkg-descr
new file mode 100644
index 000000000000..25cf61a374ef
--- /dev/null
+++ b/devel/horde3-chora/pkg-descr
@@ -0,0 +1,16 @@
+Chora is the Horde CVS viewer; it provides an advanced web-based view of
+any local CVS repository. It now includes annotation support, visual
+branch viewing capability, and human-readable diffs.
+
+Other features are:
+
+- Support for multiple CVS repositories
+- MIME-awareness, to pretty-print code or convert PDFs to text
+- Visual branch histories, to view the flow of code through a project
+- Internationalisation, with several languages supported
+- Annotation (or 'blame') support
+
+... as well as all the usual CVS functions you are familiar with from
+other similar applications.
+
+WWW: http://horde.org/chora/
diff --git a/devel/horde3-chora/pkg-plist b/devel/horde3-chora/pkg-plist
new file mode 100644
index 000000000000..2841803ce256
--- /dev/null
+++ b/devel/horde3-chora/pkg-plist
@@ -0,0 +1,192 @@
+%%HORDIR%%/.htaccess
+%%HORDIR%%/annotate.php
+%%HORDIR%%/browse.php
+%%HORDIR%%/co.php
+%%HORDIR%%/config/.htaccess
+%%HORDIR%%/config/conf.xml
+%%HORDIR%%/config/cvsgraph.conf.dist
+%%HORDIR%%/config/longIntro.txt.dist
+%%HORDIR%%/config/mime_drivers.php.dist
+%%HORDIR%%/config/prefs.php.dist
+%%HORDIR%%/config/sourceroots.php.dist
+%%HORDIR%%/cvs.php
+%%HORDIR%%/cvsgraph.php
+%%HORDIR%%/diff.php
+%%HORDIR%%/history.php
+%%HORDIR%%/index.php
+%%HORDIR%%/js/QuickFinder.js
+%%HORDIR%%/js/prototype.js
+%%HORDIR%%/js/revlog.js
+%%HORDIR%%/js/src/QuickFinder.js
+%%HORDIR%%/js/src/prototype.js
+%%HORDIR%%/js/src/revlog.js
+%%HORDIR%%/js/src/stripe.js
+%%HORDIR%%/js/src/tables.js
+%%HORDIR%%/js/stripe.js
+%%HORDIR%%/js/tables.js
+%%HORDIR%%/lib/.htaccess
+%%HORDIR%%/lib/Block/tree_menu.php
+%%HORDIR%%/lib/Chora.php
+%%HORDIR%%/lib/api.php
+%%HORDIR%%/lib/base.php
+%%HORDIR%%/lib/version.php
+%%HORDIR%%/locale/.htaccess
+%%HORDIR%%/locale/cs_CZ/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/da_DK/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/de_DE/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/de_DE/help.xml
+%%HORDIR%%/locale/en_US/help.xml
+%%HORDIR%%/locale/es_ES/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/es_ES/help.xml
+%%HORDIR%%/locale/fi_FI/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/fi_FI/help.xml
+%%HORDIR%%/locale/fr_FR/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/it_IT/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/nb_NO/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/nl_NL/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/pl_PL/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/pt_BR/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/ro_RO/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/ru_RU/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/sk_SK/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/sv_SE/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/zh_CN/LC_MESSAGES/chora.mo
+%%HORDIR%%/locale/zh_TW/LC_MESSAGES/chora.mo
+%%HORDIR%%/patchsets.php
+%%HORDIR%%/po/.htaccess
+%%HORDIR%%/po/README
+%%HORDIR%%/po/chora.pot
+%%HORDIR%%/po/cs_CZ.po
+%%HORDIR%%/po/da_DK.po
+%%HORDIR%%/po/de_DE.po
+%%HORDIR%%/po/es_ES.po
+%%HORDIR%%/po/fi_FI.po
+%%HORDIR%%/po/fr_FR.po
+%%HORDIR%%/po/it_IT.po
+%%HORDIR%%/po/nb_NO.po
+%%HORDIR%%/po/nl_NL.po
+%%HORDIR%%/po/pl_PL.po
+%%HORDIR%%/po/pt_BR.po
+%%HORDIR%%/po/ro_RO.po
+%%HORDIR%%/po/ru_RU.po
+%%HORDIR%%/po/sk_SK.po
+%%HORDIR%%/po/sv_SE.po
+%%HORDIR%%/po/zh_CN.po
+%%HORDIR%%/po/zh_TW.po
+%%HORDIR%%/stats.php
+%%HORDIR%%/templates/.htaccess
+%%HORDIR%%/templates/annotate/footer.inc
+%%HORDIR%%/templates/annotate/header.inc
+%%HORDIR%%/templates/annotate/line.inc
+%%HORDIR%%/templates/checkout/checkout.inc
+%%HORDIR%%/templates/common-header.inc
+%%HORDIR%%/templates/cvsgraph/cvsgraph.inc
+%%HORDIR%%/templates/diff/hr/add.inc
+%%HORDIR%%/templates/diff/hr/change.inc
+%%HORDIR%%/templates/diff/hr/empty.inc
+%%HORDIR%%/templates/diff/hr/footer.inc
+%%HORDIR%%/templates/diff/hr/header.inc
+%%HORDIR%%/templates/diff/hr/nochange.inc
+%%HORDIR%%/templates/diff/hr/remove.inc
+%%HORDIR%%/templates/diff/hr/row.inc
+%%HORDIR%%/templates/directory/back.inc
+%%HORDIR%%/templates/directory/dir.inc
+%%HORDIR%%/templates/directory/file.inc
+%%HORDIR%%/templates/directory/header.inc
+%%HORDIR%%/templates/error_page.inc
+%%HORDIR%%/templates/headerbar.inc
+%%HORDIR%%/templates/history/blank.inc
+%%HORDIR%%/templates/history/branch_cell.inc
+%%HORDIR%%/templates/history/footer.inc
+%%HORDIR%%/templates/history/header.inc
+%%HORDIR%%/templates/history/rev.inc
+%%HORDIR%%/templates/log/footer.inc
+%%HORDIR%%/templates/log/header.inc
+%%HORDIR%%/templates/log/rev.inc
+%%HORDIR%%/templates/menu.inc
+%%HORDIR%%/templates/patchsets/footer.inc
+%%HORDIR%%/templates/patchsets/header.inc
+%%HORDIR%%/templates/patchsets/ps.inc
+%%HORDIR%%/templates/stats/stats.inc
+%%HORDIR%%/test.php
+%%HORDIR%%/themes/burntorange/screen.css
+%%HORDIR%%/themes/graphics/az.png
+%%HORDIR%%/themes/graphics/back.png
+%%HORDIR%%/themes/graphics/chora.png
+%%HORDIR%%/themes/graphics/deleted.png
+%%HORDIR%%/themes/graphics/diff.png
+%%HORDIR%%/themes/graphics/favicon.ico
+%%HORDIR%%/themes/graphics/folder.png
+%%HORDIR%%/themes/graphics/za.png
+%%HORDIR%%/themes/hordeweb/screen.css
+%%HORDIR%%/themes/screen.css
+%%HORDIR%%/themes/silver/graphics/az.png
+%%HORDIR%%/themes/silver/graphics/back.png
+%%HORDIR%%/themes/silver/graphics/chora.png
+%%HORDIR%%/themes/silver/graphics/deleted.png
+%%HORDIR%%/themes/silver/graphics/diff.png
+%%HORDIR%%/themes/silver/graphics/favicon.ico
+%%HORDIR%%/themes/silver/graphics/folder.png
+%%HORDIR%%/themes/silver/graphics/za.png
+%%HORDIR%%/themes/silver/themed_graphics
+@dirrm %%HORDIR%%/themes/silver/graphics
+@dirrm %%HORDIR%%/themes/silver
+@dirrm %%HORDIR%%/themes/hordeweb
+@dirrm %%HORDIR%%/themes/graphics
+@dirrm %%HORDIR%%/themes/burntorange
+@dirrm %%HORDIR%%/themes
+@dirrm %%HORDIR%%/templates/stats
+@dirrm %%HORDIR%%/templates/patchsets
+@dirrm %%HORDIR%%/templates/log
+@dirrm %%HORDIR%%/templates/history
+@dirrm %%HORDIR%%/templates/directory
+@dirrm %%HORDIR%%/templates/diff/hr
+@dirrm %%HORDIR%%/templates/diff
+@dirrm %%HORDIR%%/templates/cvsgraph
+@dirrm %%HORDIR%%/templates/checkout
+@dirrm %%HORDIR%%/templates/annotate
+@dirrm %%HORDIR%%/templates
+@dirrm %%HORDIR%%/po
+@dirrm %%HORDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/zh_TW
+@dirrm %%HORDIR%%/locale/zh_CN/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/zh_CN
+@dirrm %%HORDIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/sv_SE
+@dirrm %%HORDIR%%/locale/sk_SK/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/sk_SK
+@dirrm %%HORDIR%%/locale/ru_RU/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ru_RU
+@dirrm %%HORDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ro_RO
+@dirrm %%HORDIR%%/locale/pt_BR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pt_BR
+@dirrm %%HORDIR%%/locale/pl_PL/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pl_PL
+@dirrm %%HORDIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nl_NL
+@dirrm %%HORDIR%%/locale/nb_NO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nb_NO
+@dirrm %%HORDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/it_IT
+@dirrm %%HORDIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fr_FR
+@dirrm %%HORDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fi_FI
+@dirrm %%HORDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/es_ES
+@dirrm %%HORDIR%%/locale/en_US
+@dirrm %%HORDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/de_DE
+@dirrm %%HORDIR%%/locale/da_DK/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/da_DK
+@dirrm %%HORDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/cs_CZ
+@dirrm %%HORDIR%%/locale
+@dirrm %%HORDIR%%/lib/Block
+@dirrm %%HORDIR%%/lib
+@dirrm %%HORDIR%%/js/src
+@dirrm %%HORDIR%%/js
+@dirrmtry %%HORDIR%%/config
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%