aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-DrIFT
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
committerGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
commit39b8e49140afdb1d1d001c477befb4b05efa7fc3 (patch)
tree607a5ca77efd301a2b4dc49b05d108829fcffa77 /devel/hs-DrIFT
parent75b64b1cb42c127b71646f039269eb7bd560d8ef (diff)
downloadports-39b8e49140afdb1d1d001c477befb4b05efa7fc3.tar.gz
ports-39b8e49140afdb1d1d001c477befb4b05efa7fc3.zip
Notes
Diffstat (limited to 'devel/hs-DrIFT')
-rw-r--r--devel/hs-DrIFT/Makefile4
-rw-r--r--devel/hs-DrIFT/files/patch-src_ParseLib2.hs25
2 files changed, 27 insertions, 2 deletions
diff --git a/devel/hs-DrIFT/Makefile b/devel/hs-DrIFT/Makefile
index 8f15319c7ed3..d95e146dd200 100644
--- a/devel/hs-DrIFT/Makefile
+++ b/devel/hs-DrIFT/Makefile
@@ -2,7 +2,7 @@
PORTNAME= DrIFT
PORTVERSION= 2.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,7 +10,7 @@ COMMENT= Program to derive type class instances
LICENSE= BSD3CLAUSE
-USE_CABAL= random
+USE_CABAL= old-time random
EXECUTABLE= DrIFT drift-ghc
diff --git a/devel/hs-DrIFT/files/patch-src_ParseLib2.hs b/devel/hs-DrIFT/files/patch-src_ParseLib2.hs
new file mode 100644
index 000000000000..19cfa80fac8d
--- /dev/null
+++ b/devel/hs-DrIFT/files/patch-src_ParseLib2.hs
@@ -0,0 +1,25 @@
+--- src/ParseLib2.hs.orig 2013-11-11 15:22:00 UTC
++++ src/ParseLib2.hs
+@@ -32,6 +32,7 @@ module ParseLib2
+ opt, skipUntil, skipUntilOff,skipUntilParse,skipNest) where
+
+ import Data.Char
++import Control.Applicative (Alternative, empty, (<|>))
+ import Control.Monad
+
+ infixr 5 +++
+@@ -62,6 +63,14 @@ instance MonadPlus Parser where
+ -- mplus :: Parser a -> Parser a -> Parser a
+ (P p) `mplus` (P q) = P (\pos inp -> (p pos inp ++ q pos inp))
+
++instance Applicative Parser where
++ pure = return
++ (<*>) = ap
++
++instance Alternative Parser where
++ empty = mzero
++ (<|>) = mplus
++
+ -- bits which donn't fit into Haskell's type classes just yet :-(
+
+ env :: Parser Pos