aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-abstract-par
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-06-03 18:57:20 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-06-03 18:57:20 +0000
commitc02b54f2d6f9156b35cb7469bccf7fa923f78393 (patch)
tree2781ce8fb715a7122969fdc08d6bb5b19a81fd48 /devel/hs-abstract-par
parent7885c5f5dc617ce9fc4ccac341ba4129efa27f06 (diff)
downloadports-c02b54f2d6f9156b35cb7469bccf7fa923f78393.tar.gz
ports-c02b54f2d6f9156b35cb7469bccf7fa923f78393.zip
Notes
Diffstat (limited to 'devel/hs-abstract-par')
-rw-r--r--devel/hs-abstract-par/Makefile20
-rw-r--r--devel/hs-abstract-par/distinfo2
-rw-r--r--devel/hs-abstract-par/pkg-descr10
3 files changed, 32 insertions, 0 deletions
diff --git a/devel/hs-abstract-par/Makefile b/devel/hs-abstract-par/Makefile
new file mode 100644
index 000000000000..dd535636349c
--- /dev/null
+++ b/devel/hs-abstract-par/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-abstract-par
+# Date created: May 9, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= abstract-par
+PORTVERSION= 0.3.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Type classes generalizing the functionality of the 'monad-par' library
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-abstract-par/distinfo b/devel/hs-abstract-par/distinfo
new file mode 100644
index 000000000000..3212e63a7c57
--- /dev/null
+++ b/devel/hs-abstract-par/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/abstract-par-0.3.1.tar.gz) = d3ab9ea69100d90668b22cac9a2533d524e8d5bf362792333c600d818028fb63
+SIZE (cabal/abstract-par-0.3.1.tar.gz) = 4792
diff --git a/devel/hs-abstract-par/pkg-descr b/devel/hs-abstract-par/pkg-descr
new file mode 100644
index 000000000000..b1685653b46c
--- /dev/null
+++ b/devel/hs-abstract-par/pkg-descr
@@ -0,0 +1,10 @@
+The Par monad(s) offer an alternative parallel programming API to that
+provided by the 'parallel' package. A Par monad allows the simple
+description of parallel computations, and can be used to add parallelism
+to pure Haskell code. The basic API is straightforward: a Par monad
+supports forking and simple communication in terms of IVars. This module
+is an interface module only. It provides a number of type clasess, but
+not an implementation. The type classes separate different levels of Par
+functionality.
+
+WWW: https://github.com/simonmar/monad-par