aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-idoc
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-05-09 05:28:57 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-05-09 05:28:57 +0000
commit0c76a8384fc1de4958eb1228befbee727f00c596 (patch)
tree28680b3da252da7f45a2d25108e4e2a6e41a77e5 /devel/hs-idoc
parentf2febc81eeab0d296325ecc49e1825762e5cd5d7 (diff)
downloadports-0c76a8384fc1de4958eb1228befbee727f00c596.tar.gz
ports-0c76a8384fc1de4958eb1228befbee727f00c596.zip
Notes
Diffstat (limited to 'devel/hs-idoc')
-rw-r--r--devel/hs-idoc/Makefile5
-rw-r--r--devel/hs-idoc/distinfo1
-rw-r--r--devel/hs-idoc/files/patch-Makefile40
3 files changed, 44 insertions, 2 deletions
diff --git a/devel/hs-idoc/Makefile b/devel/hs-idoc/Makefile
index 9f072dba4325..3e110885135f 100644
--- a/devel/hs-idoc/Makefile
+++ b/devel/hs-idoc/Makefile
@@ -6,7 +6,7 @@
PORTNAME= idoc
PORTVERSION= 0.2.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel haskell
MASTER_SITES= http://www.cse.unsw.edu.au/~chak/haskell/idoc/
PKGNAMEPREFIX= hs-
@@ -14,6 +14,9 @@ PKGNAMEPREFIX= hs-
MAINTAINER= haskell@FreeBSD.org
COMMENT= A No Frills Haskell Interface Documentation System
+LICENSE= GPLv2
+FILE_LICENSE= COPYING
+
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
diff --git a/devel/hs-idoc/distinfo b/devel/hs-idoc/distinfo
index 78a356447ba9..84032f7f48a6 100644
--- a/devel/hs-idoc/distinfo
+++ b/devel/hs-idoc/distinfo
@@ -1,3 +1,2 @@
-MD5 (idoc-0.2.6.tar.gz) = 5acb412b8fe0c13a9818f2b84c9637c4
SHA256 (idoc-0.2.6.tar.gz) = 9ef75016bc74b17e959d64e2542441605aeaeba394fa7a8e134ef8ee23ccef8d
SIZE (idoc-0.2.6.tar.gz) = 27594
diff --git a/devel/hs-idoc/files/patch-Makefile b/devel/hs-idoc/files/patch-Makefile
new file mode 100644
index 000000000000..27d4bf3f2d28
--- /dev/null
+++ b/devel/hs-idoc/files/patch-Makefile
@@ -0,0 +1,40 @@
+--- Makefile.orig 2002-02-28 07:33:03.000000000 +0100
++++ Makefile 2011-03-26 12:47:27.290996479 +0100
+@@ -56,7 +56,6 @@
+ #
+ PACKAGE = idoc
+ SRCS = GetOpt.hs IDoc.hs
+-OBJS = $(patsubst %.hs,%.o,$(filter %.hs,$(SRCS)))
+
+ # file that contains a `versnum = "x.y.z"' line
+ #
+@@ -78,18 +77,10 @@
+ #
+ default: idoc
+
+-# compile rules
+-#
+-%.o: %.hs
+- $(RM) $@
+- $(HC) -c $(HCFLAGS) $<
+-%.hi: %.o
+- @:
+-
+ # link target
+ #
+-idoc: $(OBJS)
+- $(HC) $(HCFLAGS) -o $@ $^
++idoc: $(SRCS)
++ $(HC) --make $(HCFLAGS) -o $@ $^
+
+ # install target
+ #
+@@ -116,8 +107,3 @@
+ tar czf $(PACKAGE)-$(VERSION).tar.gz\
+ $(addprefix $(PACKAGE)-$(VERSION)/,$(DISTFILES))
+ $(RM) $(PACKAGE)-$(VERSION)
+-
+-# dependencies
+-#
+-IDoc.o : IDoc.hs GetOpt.hi
+-GetOpt.o: GetOpt.hs