aboutsummaryrefslogtreecommitdiff
path: root/devel/ice
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2016-07-10 12:47:32 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2016-07-10 12:47:32 +0000
commit5560ebe54df426008552ab385f28d093d24359d1 (patch)
tree96e904ab432ac892ebae2c11ac88227caee9d399 /devel/ice
parentb6f628c82d91020d0542254906f7946d0072638d (diff)
Notes
Diffstat (limited to 'devel/ice')
-rw-r--r--devel/ice/Makefile1
-rw-r--r--devel/ice/files/patch-cpp-src-IceGrid-Parser.cpp27
2 files changed, 28 insertions, 0 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 15bf3223e63b..cf2767522399 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Ice
PORTVERSION= 3.6.2
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= devel
diff --git a/devel/ice/files/patch-cpp-src-IceGrid-Parser.cpp b/devel/ice/files/patch-cpp-src-IceGrid-Parser.cpp
new file mode 100644
index 000000000000..39d41e788afe
--- /dev/null
+++ b/devel/ice/files/patch-cpp-src-IceGrid-Parser.cpp
@@ -0,0 +1,27 @@
+--- cpp/src/IceGrid/Parser.cpp.orig 2016-05-16 22:49:28.132976967 +0200
++++ cpp/src/IceGrid/Parser.cpp 2016-05-16 23:15:17.589867966 +0200
+@@ -1912,10 +1912,24 @@
+ return;
+ }
+
++
+ Ice::ObjectPrx admin = _admin->getServerAdmin(server);
+ Ice::PropertiesAdminPrx propAdmin =
+ Ice::PropertiesAdminPrx::uncheckedCast(admin, "IceBox.Service." + service + ".Properties");
+
++ try
++ {
++ propAdmin->ice_ping();
++ }
++ catch(const Ice::ObjectNotExistException&)
++ {
++ Ice::PropertiesAdminPrx serverPropAdmin = Ice::PropertiesAdminPrx::uncheckedCast(admin, "Properties");
++ if (atoi(serverPropAdmin->getProperty("IceBox.UseSharedCommunicator." + service).c_str()))
++ {
++ propAdmin = Ice::PropertiesAdminPrx::uncheckedCast(admin, "IceBox.SharedCommunicator.Properties");
++ }
++ }
++
+ if(single)
+ {
+ string val = propAdmin->getProperty(property);