aboutsummaryrefslogtreecommitdiff
path: root/devel/intel-graphics-compiler
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-12-23 13:57:39 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-12-23 13:57:39 +0000
commitb63963d29cb24f6c5d81ee596c8de76110e17977 (patch)
treeee06104fd6e22099e964d8db8060693757f5f42f /devel/intel-graphics-compiler
parentaeee40f2c301ac00b09eeac31e73beaa407f0e29 (diff)
downloadports-b63963d29cb24f6c5d81ee596c8de76110e17977.tar.gz
ports-b63963d29cb24f6c5d81ee596c8de76110e17977.zip
devel/intel-graphics-compiler: update to 1.0.5884
Notes
Notes: svn path=/head/; revision=558991
Diffstat (limited to 'devel/intel-graphics-compiler')
-rw-r--r--devel/intel-graphics-compiler/Makefile3
-rw-r--r--devel/intel-graphics-compiler/distinfo8
-rw-r--r--devel/intel-graphics-compiler/files/patch-llvm1123
3 files changed, 24 insertions, 10 deletions
diff --git a/devel/intel-graphics-compiler/Makefile b/devel/intel-graphics-compiler/Makefile
index 4d0d2cef6adf..8e506814d9c0 100644
--- a/devel/intel-graphics-compiler/Makefile
+++ b/devel/intel-graphics-compiler/Makefile
@@ -2,13 +2,12 @@
PORTNAME= intel-graphics-compiler
DISTVERSIONPREFIX= igc-
-DISTVERSION= 1.0.5819
+DISTVERSION= 1.0.5884
CATEGORIES= devel
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= d878880cbb3b.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/129
PATCHFILES+= f44eb990ac84.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/156
-PATCHFILES+= cf887180a0e3.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/156
PATCHFILES+= 02d82a7ccbe6.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/156
MAINTAINER= jbeich@FreeBSD.org
diff --git a/devel/intel-graphics-compiler/distinfo b/devel/intel-graphics-compiler/distinfo
index 852fa0db7135..0985b5084f2d 100644
--- a/devel/intel-graphics-compiler/distinfo
+++ b/devel/intel-graphics-compiler/distinfo
@@ -1,13 +1,11 @@
-TIMESTAMP = 1607250955
-SHA256 (intel-intel-graphics-compiler-igc-1.0.5819_GH0.tar.gz) = f000414534bc29266f08203213fe9628f241751d992be6690431c0c65a774fac
-SIZE (intel-intel-graphics-compiler-igc-1.0.5819_GH0.tar.gz) = 7123768
+TIMESTAMP = 1607752911
+SHA256 (intel-intel-graphics-compiler-igc-1.0.5884_GH0.tar.gz) = 9bf29ef4c70ff7951f67861c21825e5f341716b8cc48af29aef3fc023845d7a7
+SIZE (intel-intel-graphics-compiler-igc-1.0.5884_GH0.tar.gz) = 7169150
SHA256 (intel-vc-intrinsics-2de2dd4_GH0.tar.gz) = 30e6faf9add7c8773aa99641d2f366b7455b267232a47323acda1742640ef643
SIZE (intel-vc-intrinsics-2de2dd4_GH0.tar.gz) = 120395
SHA256 (d878880cbb3b.patch) = f430b2da0d212594ce73f23b279a1435f08dea60f30ec35494411ab0dc0fcf70
SIZE (d878880cbb3b.patch) = 9088
SHA256 (f44eb990ac84.patch) = 4774683855caa8ef44a85a43356b7d509683bbdbef23e31ab6f5e4075715d67c
SIZE (f44eb990ac84.patch) = 1547
-SHA256 (cf887180a0e3.patch) = 20c5afc646f61180880fc8e07abcd0feac04bfb190ab27d8af939d459b61a9a0
-SIZE (cf887180a0e3.patch) = 4191
SHA256 (02d82a7ccbe6.patch) = 396198830fb7e55318a870d46e93d93aaa5dca90a7979e3b3f7afcca965f1938
SIZE (02d82a7ccbe6.patch) = 1292
diff --git a/devel/intel-graphics-compiler/files/patch-llvm11 b/devel/intel-graphics-compiler/files/patch-llvm11
index f5521d75892a..81bc1a81104f 100644
--- a/devel/intel-graphics-compiler/files/patch-llvm11
+++ b/devel/intel-graphics-compiler/files/patch-llvm11
@@ -1,17 +1,34 @@
+IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp:2148:16: error: call to 'invertCondition' is ambiguous
+ Mask = invertCondition(Mask);
+ ^~~~~~~~~~~~~~~
+IGC/VectorCompiler/lib/GenXCodeGen/GenXUtil.h:206:8: note: candidate function
+Value *invertCondition(Value *Condition);
+ ^
+/usr/local/llvm11/include/llvm/Transforms/Utils/Local.h:557:8: note: candidate function
+Value *invertCondition(Value *Condition);
+ ^
IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp:2216:41: error: no viable conversion from 'llvm::ElementCount' to 'unsigned int'
return ConstantDataVector::getSplat(IGCLLVM::getElementCount(OperandWidth),
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/usr/local/llvm11/include/llvm/IR/Constants.h:803:38: note: passing argument to parameter 'NumElts' here
static Constant *getSplat(unsigned NumElts, Constant *Elt);
^
-
IGC/VectorCompiler/lib/GenXCodeGen/GenXThreadPrivateMemory.cpp:462:37: error: no member named 'getMask' in 'llvm::ShuffleVectorInst'
NewVec1, NewVec2, ShuffleVec->getMask(), ShuffleVec->getName() + ".tpm");
~~~~~~~~~~ ^
---- IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp.orig 2020-12-06 10:35:55 UTC
+--- IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp.orig 2020-12-12 06:01:51 UTC
+++ IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp
-@@ -2213,7 +2213,7 @@ static void decomposeSdivPow2(Instruction &Sdiv,
+@@ -2145,7 +2145,7 @@ static bool mergeToWrRegion(SelectInst *SI) {
+ Value *Mask = SI->getCondition();
+ // Invert mask if needed.
+ if (Inverted)
+- Mask = invertCondition(Mask);
++ Mask = genx::invertCondition(Mask);
+ // Create new wrregion.
+ Region WrReg(Wr, BaleInfo());
+ WrReg.Mask = Mask;
+@@ -2269,7 +2269,7 @@ static void decomposeSdivPow2(Instruction &Sdiv,
auto createConstantVector = [](unsigned int OperandWidth, Type *Ty,
int Value) {