aboutsummaryrefslogtreecommitdiff
path: root/devel/intel-graphics-compiler
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-12-02 22:48:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-12-02 22:48:06 +0000
commitc2efc9437ed9dee3943bef209783585756274647 (patch)
treec0aa0daea62236e68875472105bb42af52a601eb /devel/intel-graphics-compiler
parentbbf43cfe9bda1498f0d25df5c810eb71e89e178c (diff)
downloadports-c2efc9437ed9dee3943bef209783585756274647.tar.gz
ports-c2efc9437ed9dee3943bef209783585756274647.zip
devel/intel-graphics-compiler: drop devel/llvm90 dependency
Notes
Notes: svn path=/head/; revision=556860
Diffstat (limited to 'devel/intel-graphics-compiler')
-rw-r--r--devel/intel-graphics-compiler/Makefile10
-rw-r--r--devel/intel-graphics-compiler/distinfo4
-rw-r--r--devel/intel-graphics-compiler/files/patch-clang20
3 files changed, 7 insertions, 27 deletions
diff --git a/devel/intel-graphics-compiler/Makefile b/devel/intel-graphics-compiler/Makefile
index 963e8bc45a20..8ed0a4440e14 100644
--- a/devel/intel-graphics-compiler/Makefile
+++ b/devel/intel-graphics-compiler/Makefile
@@ -3,10 +3,13 @@
PORTNAME= intel-graphics-compiler
DISTVERSIONPREFIX= igc-
DISTVERSION= 1.0.5699
+PORTREVISION= 1
CATEGORIES= devel
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= d878880cbb3b.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/129
+PATCHFILES+= f44eb990ac84.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/156
+PATCHFILES+= cf887180a0e3.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/156
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Intel Graphics Compiler for OpenCL
@@ -28,13 +31,6 @@ CMAKE_OFF= INSTALL_SPIRVDLL
CFLAGS+= -Wno-macro-redefined # __fastcall
PLIST_SUB= ARCH_SUFX=${ARCH:S/i386/32/:S/amd//:S/x86_//}
-.if (exists(/usr/lib/clang/10.0.0) || exists(/usr/lib/clang/10.0.1) || exists(/usr/lib/clang/11.0.0)) && ${CXX} == c++
-# https://github.com/intel/intel-graphics-compiler/issues/126
-BUILD_DEPENDS+= clang++90:devel/llvm90
-USES:= ${USES:Ncompiler*}
-CXX= clang++90
-.endif
-
post-patch:
# lang/python* don't install unsuffixed symlinks
@${REINPLACE_CMD} -i .python \
diff --git a/devel/intel-graphics-compiler/distinfo b/devel/intel-graphics-compiler/distinfo
index f2ff79de8d82..3a36ab8645a8 100644
--- a/devel/intel-graphics-compiler/distinfo
+++ b/devel/intel-graphics-compiler/distinfo
@@ -5,3 +5,7 @@ SHA256 (intel-vc-intrinsics-a08fe5b_GH0.tar.gz) = e57f05d56e385449ed86fdbbb3b5f7
SIZE (intel-vc-intrinsics-a08fe5b_GH0.tar.gz) = 119121
SHA256 (d878880cbb3b.patch) = f430b2da0d212594ce73f23b279a1435f08dea60f30ec35494411ab0dc0fcf70
SIZE (d878880cbb3b.patch) = 9088
+SHA256 (f44eb990ac84.patch) = 4774683855caa8ef44a85a43356b7d509683bbdbef23e31ab6f5e4075715d67c
+SIZE (f44eb990ac84.patch) = 1547
+SHA256 (cf887180a0e3.patch) = 20c5afc646f61180880fc8e07abcd0feac04bfb190ab27d8af939d459b61a9a0
+SIZE (cf887180a0e3.patch) = 4191
diff --git a/devel/intel-graphics-compiler/files/patch-clang b/devel/intel-graphics-compiler/files/patch-clang
deleted file mode 100644
index 9450f393bc7c..000000000000
--- a/devel/intel-graphics-compiler/files/patch-clang
+++ /dev/null
@@ -1,20 +0,0 @@
-Regressed by http://github.com/intel/intel-graphics-compiler/commit/d0874824631f
-
-IGC/VectorCompiler/lib/GenXCodeGen/GenXLowering.cpp:2601:12: error: reference to local binding 'IsSignedOps' declared in enclosing function '(anonymous namespace)::GenXLowering::lowerMulSat'
- return IsSignedOps ? B.CreateSExt(Val, MulType, Val->getName() + ".sext")
- ^
-IGC/VectorCompiler/lib/GenXCodeGen/GenXLowering.cpp:2581:22: note: 'IsSignedOps' declared here
- auto [IsSignedRes, IsSignedOps] = IsSignedMulSat(IntrinsicID);
- ^
-
---- IGC/VectorCompiler/lib/GenXCodeGen/GenXLowering.cpp.orig 2020-10-30 09:08:26 UTC
-+++ IGC/VectorCompiler/lib/GenXCodeGen/GenXLowering.cpp
-@@ -2597,7 +2597,7 @@ bool GenXLowering::lowerMulSat(CallInst *CI, unsigned
- IGCLLVM::FixedVectorType::get(MulType, cast<VectorType>(OpType)->getNumElements());
-
- IRBuilder<> B(CI);
-- auto ExtendMulOperand = [&](Value *Val) {
-+ auto ExtendMulOperand = [&, IsSignedOps=IsSignedOps](Value *Val) {
- return IsSignedOps ? B.CreateSExt(Val, MulType, Val->getName() + ".sext")
- : B.CreateZExt(Val, MulType, Val->getName() + ".zext");
- };