aboutsummaryrefslogtreecommitdiff
path: root/devel/jakarta-commons-jxpath/Makefile
diff options
context:
space:
mode:
authorTong LIU <nemoliu@FreeBSD.org>2008-12-12 07:33:39 +0000
committerTong LIU <nemoliu@FreeBSD.org>2008-12-12 07:33:39 +0000
commitdeec2edb79622d581b269173fc5e0cc50366cad0 (patch)
treefac0a4f38ab61fe25274829b1c05facd2f989100 /devel/jakarta-commons-jxpath/Makefile
parenta379e5c7e24fcf79ae44728c3f7756f08b72d9d4 (diff)
downloadports-deec2edb79622d581b269173fc5e0cc50366cad0.tar.gz
ports-deec2edb79622d581b269173fc5e0cc50366cad0.zip
Notes
Diffstat (limited to 'devel/jakarta-commons-jxpath/Makefile')
-rw-r--r--devel/jakarta-commons-jxpath/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/jakarta-commons-jxpath/Makefile b/devel/jakarta-commons-jxpath/Makefile
index 2f4de5989de2..c44c515114c7 100644
--- a/devel/jakarta-commons-jxpath/Makefile
+++ b/devel/jakarta-commons-jxpath/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= commons-jxpath
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.3
CATEGORIES= devel www java
MASTER_SITES= ${MASTER_SITE_APACHE_COMMONS_BINARIES}
MASTER_SITE_SUBDIR= ${PORTNAME:S,commons-,,}
PKGNAMEPREFIX= jakarta-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities for manipulating Java Beans using the XPath syntax
@@ -29,12 +29,12 @@ PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
do-install:
@${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
@${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}/..."
- @cd ${WRKSRC}/docs \
+ @cd ${WRKDIR}/${PORTNAME}-${PORTVERSION}/apidocs \
&& ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
&& ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
@${ECHO_MSG} " [ DONE ]"