aboutsummaryrefslogtreecommitdiff
path: root/devel/jtag
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-13 07:02:23 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-13 07:02:23 +0000
commitbf3c79edaaa0850991318948ab96be4d6f8d2d6f (patch)
tree089126a30a866aacae4456aa145940010c45582b /devel/jtag
parenta08bdaf5ca29e642d6be9773fc1f6f96593baff0 (diff)
downloadports-bf3c79edaaa0850991318948ab96be4d6f8d2d6f.tar.gz
ports-bf3c79edaaa0850991318948ab96be4d6f8d2d6f.zip
Notes
Diffstat (limited to 'devel/jtag')
-rw-r--r--devel/jtag/Makefile45
-rw-r--r--devel/jtag/pkg-plist2
2 files changed, 27 insertions, 20 deletions
diff --git a/devel/jtag/Makefile b/devel/jtag/Makefile
index f8c46eaa9288..0dde2e482294 100644
--- a/devel/jtag/Makefile
+++ b/devel/jtag/Makefile
@@ -1,10 +1,5 @@
-# New ports collection makefile for: jtag
-# Date created: 2006-08-05
-# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
-#
-# $MBSDlabs$
+# Created by: Stanislav Sedov <ssedov@mbsd.msk.ru>
# $FreeBSD$
-#
PORTNAME= jtag
PORTVERSION= 0.5.1
@@ -15,25 +10,36 @@ MASTER_SITES= SF/openwince/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Utility to work with JTAG-aware boards
+LICENSE= GPLv2 # (or later)
+
BUILD_DEPENDS= ${OPENWINCE_INCLUDE_DEP}:${PORTSDIR}/devel/openwince-include
RUN_DEPENDS:= ${BUILD_DEPENDS}
+OPTIONS_DEFINE= NLS DOCS
+OPTIONS_DEFAULT=NLS
+
USE_BZIP2= yes
-USE_GETTEXT= yes
+USE_READLINE= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= *
ONLY_FOR_ARCHS= i386
OPENWINCE_INCLUDE=${LOCALBASE}/include/openwince
OPENWINCE_INCLUDE_DEP=${OPENWINCE_INCLUDE}/common.h
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
+.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/lib/libreadline.so.6)
-LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-extract:
@@ -42,10 +48,11 @@ post-extract:
${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/TODO \
- ${WRKSRC}/doc/internals.xml ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for f in README TODO doc/internals.xml
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/jtag/pkg-plist b/devel/jtag/pkg-plist
index cce393476a2c..e383d4780a90 100644
--- a/devel/jtag/pkg-plist
+++ b/devel/jtag/pkg-plist
@@ -41,7 +41,7 @@ bin/jtag
%%DATADIR%%/xilinx/xcr3128xl-cs144/xcr3128xl-cs144
%%DATADIR%%/xilinx/xcr3256xl-ft256/STEPPINGS
%%DATADIR%%/xilinx/xcr3256xl-ft256/xcr3256xl-ft256
-share/locale/sk/LC_MESSAGES/jtag.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/jtag.mo
@dirrm %%DATADIR%%/xilinx/xcr3256xl-ft256
@dirrm %%DATADIR%%/xilinx/xcr3128xl-cs144
@dirrm %%DATADIR%%/xilinx/xc2c256-tq144