aboutsummaryrefslogtreecommitdiff
path: root/devel/kdevplatform
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-04-15 13:40:41 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-04-15 13:40:41 +0000
commit873b7eca6c8dcbd26ff9df8f077f85fe5fe79c63 (patch)
tree673078e334862ec8cfa5086e4842e97a696b81b9 /devel/kdevplatform
parent5a86b66bd12c530d7ead42b11b432197a713dcf4 (diff)
Update KDevelop to 4.7.3 and KDevplatform to 1.7.3.
Release announcements: - https://www.kdevelop.org/kde4/kdevelop-472-released - https://www.kdevelop.org/news/kdevelop-473-release The majority of the work here has been done by Adriaan de Groot in kde@'s experimental area51 repository. Submitted by: Adriaan de Groot <groot@kde.org>
Notes
Notes: svn path=/head/; revision=413341
Diffstat (limited to 'devel/kdevplatform')
-rw-r--r--devel/kdevplatform/Makefile3
-rw-r--r--devel/kdevplatform/distinfo4
-rw-r--r--devel/kdevplatform/files/patch-git-fix-subversion-1.9147
-rw-r--r--devel/kdevplatform/files/patch-plugins_filetemplates_CMakeLists.txt14
-rw-r--r--devel/kdevplatform/files/patch-po-CMakeLists.patch12
-rw-r--r--devel/kdevplatform/pkg-plist3
6 files changed, 18 insertions, 165 deletions
diff --git a/devel/kdevplatform/Makefile b/devel/kdevplatform/Makefile
index 0e6e77ec5eae..79edbc31d209 100644
--- a/devel/kdevplatform/Makefile
+++ b/devel/kdevplatform/Makefile
@@ -3,7 +3,6 @@
PORTNAME= kdevplatform
PORTVERSION= ${KDEVELOP_VERSION:S/4./1./}
-PORTREVISION= 1
CATEGORIES= devel kde
MASTER_SITES= KDE/${KDEVELOP_BRANCH}/kdevelop/${KDEVELOP_VERSION}/src
DIST_SUBDIR= KDE/kdevelop/${KDEVELOP_VERSION}
@@ -19,7 +18,7 @@ LIB_DEPENDS= libsvn_client-1.so:devel/subversion \
USE_KDE4= kate_run kdelibs kdeprefix automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build \
corelib designer_build gui webkit
-USES= cmake:outsource compiler:c++11-lib shebangfix tar:xz
+USES= cmake:outsource compiler:c++11-lib shebangfix tar:bz2
USE_LDCONFIG= yes
SHEBANG_FILES= util/kdev_format_source util/kdevplatform_shell_environment.sh
diff --git a/devel/kdevplatform/distinfo b/devel/kdevplatform/distinfo
index de9ab223392c..c0dfc0ecc71e 100644
--- a/devel/kdevplatform/distinfo
+++ b/devel/kdevplatform/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdevelop/4.7.1/kdevplatform-1.7.1.tar.xz) = dfd8953aec204f04bd949443781aa0f6d9d58c40f73027619a168bb4ffc4b1ac
-SIZE (KDE/kdevelop/4.7.1/kdevplatform-1.7.1.tar.xz) = 1930560
+SHA256 (KDE/kdevelop/4.7.3/kdevplatform-1.7.3.tar.bz2) = 195134bde11672de38838f4b341ed28c58042374ca12beedacca9d30e6ab4a2b
+SIZE (KDE/kdevelop/4.7.3/kdevplatform-1.7.3.tar.bz2) = 2417125
diff --git a/devel/kdevplatform/files/patch-git-fix-subversion-1.9 b/devel/kdevplatform/files/patch-git-fix-subversion-1.9
deleted file mode 100644
index ba3d83b70e53..000000000000
--- a/devel/kdevplatform/files/patch-git-fix-subversion-1.9
+++ /dev/null
@@ -1,147 +0,0 @@
-From 8117ca137b45816865554d6e86b96d9e633a7e08 Mon Sep 17 00:00:00 2001
-From: Alex Merry <alex.merry@kde.org>
-Date: Sun, 16 Aug 2015 23:59:35 +0100
-Subject: [PATCH] Make subversion plugin compile with subversion 1.9.
-
-The plugin was formerly using private API, which was hidden in 1.9.
-
-REVIEW: 124783
-(cherry picked from commit cfb7f8d89e4749c7b07c7880b3065bf8a86be22c)
----
- plugins/subversion/kdevsvncpp/client_ls.cpp | 69 +++++++++++++++++++++++++++++
- plugins/subversion/kdevsvncpp/dirent.cpp | 4 +-
- plugins/subversion/kdevsvncpp/dirent.hpp | 2 +-
- 3 files changed, 72 insertions(+), 3 deletions(-)
-
-diff --git a/plugins/subversion/kdevsvncpp/client_ls.cpp b/plugins/subversion/kdevsvncpp/client_ls.cpp
-index 6cd79bb..95fd6cb 100644
---- plugins/subversion/kdevsvncpp/client_ls.cpp
-+++ plugins/subversion/kdevsvncpp/client_ls.cpp
-@@ -29,6 +29,7 @@
- #include "svn_client.h"
- #include "svn_path.h"
- #include "svn_sorts.h"
-+#include "svn_version.h"
- //#include "svn_utf.h"
-
- // svncpp
-@@ -37,6 +38,8 @@
- #include "kdevsvncpp/exception.hpp"
-
-
-+#if SVN_VER_MAJOR == 1 && SVN_VER_MINOR < 8
-+
- static int
- compare_items_as_paths(const svn_sort__item_t *a, const svn_sort__item_t *b)
- {
-@@ -90,6 +93,72 @@ namespace svn
- }
- }
-
-+#else
-+
-+#include <algorithm>
-+
-+static svn_error_t* store_entry(
-+ void *baton,
-+ const char *path,
-+ const svn_dirent_t *dirent,
-+ const svn_lock_t *,
-+ const char *abs_path,
-+ const char *,
-+ const char *,
-+ apr_pool_t *scratch_pool)
-+{
-+ svn::DirEntries *entries = reinterpret_cast<svn::DirEntries*>(baton);
-+ if (path[0] == '\0') {
-+ if (dirent->kind == svn_node_file) {
-+ // for compatibility with svn_client_ls behaviour, listing a file
-+ // stores that file name
-+ entries->push_back(svn::DirEntry(svn_path_basename(abs_path, scratch_pool), dirent));
-+ }
-+ } else {
-+ entries->push_back(svn::DirEntry(path, dirent));
-+ }
-+ return SVN_NO_ERROR;
-+}
-+
-+static bool sort_by_path(svn::DirEntry const& a, svn::DirEntry const& b)
-+{
-+ return svn_path_compare_paths(a.name(), b.name()) < 0;
-+}
-+
-+namespace svn
-+{
-+ DirEntries
-+ Client::list(const char * pathOrUrl,
-+ svn_opt_revision_t * revision,
-+ bool recurse) throw(ClientException)
-+ {
-+ Pool pool;
-+ DirEntries entries;
-+
-+ svn_error_t * error =
-+ svn_client_list3(pathOrUrl,
-+ revision,
-+ revision,
-+ SVN_DEPTH_INFINITY_OR_IMMEDIATES(recurse),
-+ SVN_DIRENT_ALL,
-+ FALSE, // fetch locks
-+ FALSE, // include externals
-+ &store_entry,
-+ &entries,
-+ *m_context,
-+ pool);
-+
-+ if (error != SVN_NO_ERROR)
-+ throw ClientException(error);
-+
-+ std::sort(entries.begin(), entries.end(), &sort_by_path);
-+
-+ return entries;
-+ }
-+}
-+
-+#endif
-+
- /* -----------------------------------------------------------------
- * local variables:
- * eval: (load-file "../../rapidsvn-dev.el")
-diff --git a/plugins/subversion/kdevsvncpp/dirent.cpp b/plugins/subversion/kdevsvncpp/dirent.cpp
-index f911e91..75dd29c 100644
---- plugins/subversion/kdevsvncpp/dirent.cpp
-+++ plugins/subversion/kdevsvncpp/dirent.cpp
-@@ -47,7 +47,7 @@ public:
- {
- }
-
-- Data(const char * _name, svn_dirent_t * dirEntry)
-+ Data(const char * _name, const svn_dirent_t * dirEntry)
- : name(_name), kind(dirEntry->kind), size(dirEntry->size),
- hasProps(dirEntry->has_props != 0),
- createdRev(dirEntry->created_rev), time(dirEntry->time)
-@@ -78,7 +78,7 @@ public:
- {
- }
-
-- DirEntry::DirEntry(const char * name, svn_dirent_t * DirEntry)
-+ DirEntry::DirEntry(const char * name, const svn_dirent_t * DirEntry)
- : m(new Data(name, DirEntry))
- {
- }
-diff --git a/plugins/subversion/kdevsvncpp/dirent.hpp b/plugins/subversion/kdevsvncpp/dirent.hpp
-index cabef7e..2f0f8d8 100644
---- plugins/subversion/kdevsvncpp/dirent.hpp
-+++ plugins/subversion/kdevsvncpp/dirent.hpp
-@@ -41,7 +41,7 @@ namespace svn
- /**
- * constructor for existing @a svn_dirent_t entries
- */
-- DirEntry(const char * name, svn_dirent_t * dirEntry);
-+ DirEntry(const char * name, const svn_dirent_t * dirEntry);
-
- /**
- * copy constructor
---
-2.6.1
-
diff --git a/devel/kdevplatform/files/patch-plugins_filetemplates_CMakeLists.txt b/devel/kdevplatform/files/patch-plugins_filetemplates_CMakeLists.txt
deleted file mode 100644
index d8a8a75e2088..000000000000
--- a/devel/kdevplatform/files/patch-plugins_filetemplates_CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-Make sure the dependency exists, as testfiletemplates depends on ui files
-generated by kdevfiletemplates.
-
-Submitted upstream: https://phabricator.kde.org/D1160
---- plugins/filetemplates/CMakeLists.txt.orig 2016-03-17 11:59:47 UTC
-+++ plugins/filetemplates/CMakeLists.txt
-@@ -81,6 +81,7 @@ main.cpp
- )
-
- kde4_add_executable(testfiletemplates ${test_srcs})
-+add_dependencies(testfiletemplates kdevfiletemplates)
-
- target_link_libraries(testfiletemplates
- ${KDE4_KDECORE_LIBS}
diff --git a/devel/kdevplatform/files/patch-po-CMakeLists.patch b/devel/kdevplatform/files/patch-po-CMakeLists.patch
new file mode 100644
index 000000000000..ad106724c114
--- /dev/null
+++ b/devel/kdevplatform/files/patch-po-CMakeLists.patch
@@ -0,0 +1,12 @@
+--- po/CMakeLists.txt 2016-01-22 19:05:47.000000000 +0100
++++ po/CMakeLists.txt 2015-02-02 15:19:35.000000000 +0100
+@@ -1,3 +1,9 @@
++# The pofiles macro creates in some versions same name targets
++# which since cmake 2.8 leads to target clashes.
++# Hence force the old policy for all po directories.
++# http://public.kitware.com/Bug/view.php?id=12952
++cmake_policy(SET CMP0002 OLD)
++
+ find_package(Gettext REQUIRED)
+ if (NOT GETTEXT_MSGMERGE_EXECUTABLE)
+ MESSAGE(FATAL_ERROR "Please install msgmerge binary")
diff --git a/devel/kdevplatform/pkg-plist b/devel/kdevplatform/pkg-plist
index 704359d200e4..2497c0ff4d95 100644
--- a/devel/kdevplatform/pkg-plist
+++ b/devel/kdevplatform/pkg-plist
@@ -565,6 +565,7 @@ share/kde4/servicetypes/kdevelopplugin.desktop
%%NLS%%share/locale/bs/LC_MESSAGES/kdevpatchreview.mo
%%NLS%%share/locale/bs/LC_MESSAGES/kdevplatform.mo
%%NLS%%share/locale/bs/LC_MESSAGES/kdevproblemreporter.mo
+%%NLS%%share/locale/bs/LC_MESSAGES/kdevprojectdashboard.mo
%%NLS%%share/locale/bs/LC_MESSAGES/kdevprojectfilter.mo
%%NLS%%share/locale/bs/LC_MESSAGES/kdevprojectmanagerview.mo
%%NLS%%share/locale/bs/LC_MESSAGES/kdevquickopen.mo
@@ -630,6 +631,7 @@ share/kde4/servicetypes/kdevelopplugin.desktop
%%NLS%%share/locale/ca@valencia/LC_MESSAGES/kdevpatchreview.mo
%%NLS%%share/locale/ca@valencia/LC_MESSAGES/kdevplatform.mo
%%NLS%%share/locale/ca@valencia/LC_MESSAGES/kdevproblemreporter.mo
+%%NLS%%share/locale/ca@valencia/LC_MESSAGES/kdevprojectdashboard.mo
%%NLS%%share/locale/ca@valencia/LC_MESSAGES/kdevprojectfilter.mo
%%NLS%%share/locale/ca@valencia/LC_MESSAGES/kdevprojectmanagerview.mo
%%NLS%%share/locale/ca@valencia/LC_MESSAGES/kdevquickopen.mo
@@ -923,6 +925,7 @@ share/kde4/servicetypes/kdevelopplugin.desktop
%%NLS%%share/locale/gl/LC_MESSAGES/kdevpatchreview.mo
%%NLS%%share/locale/gl/LC_MESSAGES/kdevplatform.mo
%%NLS%%share/locale/gl/LC_MESSAGES/kdevproblemreporter.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/kdevprojectdashboard.mo
%%NLS%%share/locale/gl/LC_MESSAGES/kdevprojectfilter.mo
%%NLS%%share/locale/gl/LC_MESSAGES/kdevprojectmanagerview.mo
%%NLS%%share/locale/gl/LC_MESSAGES/kdevquickopen.mo