aboutsummaryrefslogtreecommitdiff
path: root/devel/kf5-kcrash
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-06-17 10:45:51 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-06-17 10:45:51 +0000
commitf252dcdc08d039a071b9c8c14b19ccce94cda197 (patch)
tree1b37dc577739eff7c1dab6766e47e5db39672540 /devel/kf5-kcrash
parent46af12750b053adbc9b67ca5d3582de3081101aa (diff)
downloadports-f252dcdc08d039a071b9c8c14b19ccce94cda197.tar.gz
ports-f252dcdc08d039a071b9c8c14b19ccce94cda197.zip
Update KDE Frameworks to 5.71.0
June 06, 2020. KDE today announces the release of KDE Frameworks 5.71.0. KDE Frameworks are over 70 addon libraries to Qt which provide a wide variety of commonly needed functionality in mature, peer reviewed and well tested libraries with friendly licensing terms. For an introduction see the KDE Frameworks web page. This release is part of a series of planned monthly releases making improvements available to developers in a quick and predictable manner. Announcement: https://kde.org/announcements/kde-frameworks-5.71.0 Exp-run by: antoine PR: 247240
Notes
Notes: svn path=/head/; revision=539415
Diffstat (limited to 'devel/kf5-kcrash')
-rw-r--r--devel/kf5-kcrash/Makefile3
-rw-r--r--devel/kf5-kcrash/distinfo8
-rw-r--r--devel/kf5-kcrash/files/patch-src_kcrash.cpp23
3 files changed, 31 insertions, 3 deletions
diff --git a/devel/kf5-kcrash/Makefile b/devel/kf5-kcrash/Makefile
index e4fe1f9f9092..4ab97270224f 100644
--- a/devel/kf5-kcrash/Makefile
+++ b/devel/kf5-kcrash/Makefile
@@ -4,6 +4,9 @@ PORTNAME= kcrash
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
CATEGORIES= devel kde kde-frameworks
+PATCH_SITES= https://github.com/KDE/kcrash/commit/
+PATCHFILES= 223908ac1030a3a4fe297748101aafcf81076dbc.patch:-p1
+
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 library to handle crash analysis and bug report from apps
diff --git a/devel/kf5-kcrash/distinfo b/devel/kf5-kcrash/distinfo
index 058d5b430020..aa556508961a 100644
--- a/devel/kf5-kcrash/distinfo
+++ b/devel/kf5-kcrash/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1588492991
-SHA256 (KDE/frameworks/5.70.0/kcrash-5.70.0.tar.xz) = 37c78b1af6f8cb4645682276bcc7ca2efe9a3cb3364b3c4ac4cbef2b334c5e87
-SIZE (KDE/frameworks/5.70.0/kcrash-5.70.0.tar.xz) = 22320
+TIMESTAMP = 1592074567
+SHA256 (KDE/frameworks/5.71.0/kcrash-5.71.0.tar.xz) = 526242aa9fde7cff11ecaa88bf75d6fbbfc412f46bf19a7a9e185f2adb616005
+SIZE (KDE/frameworks/5.71.0/kcrash-5.71.0.tar.xz) = 22620
+SHA256 (KDE/frameworks/5.71.0/223908ac1030a3a4fe297748101aafcf81076dbc.patch) = 2d5b310b3e569c75bf58a96efcbcdf8f3ec0e0eec2988e0b62d1fd6bd6334ff5
+SIZE (KDE/frameworks/5.71.0/223908ac1030a3a4fe297748101aafcf81076dbc.patch) = 1375
diff --git a/devel/kf5-kcrash/files/patch-src_kcrash.cpp b/devel/kf5-kcrash/files/patch-src_kcrash.cpp
new file mode 100644
index 000000000000..710bf160271e
--- /dev/null
+++ b/devel/kf5-kcrash/files/patch-src_kcrash.cpp
@@ -0,0 +1,23 @@
+Obtained from:
+ https://github.com/KDE/kcrash/commit/a82b949adc1619ad44da002a207073b019865f4b
+
+--- src/kcrash.cpp.orig 2020-06-07 09:24:34 UTC
++++ src/kcrash.cpp
+@@ -89,6 +89,8 @@ typedef struct {
+ #define LAUNCHER_OK 4
+ #define LAUNCHER_EXEC_NEW 12
+
++extern "C" char **environ;
++
+ namespace KCrash
+ {
+ KCRASH_EXPORT bool loadedByKdeinit = false;
+@@ -719,7 +721,7 @@ static pid_t startDirectly(const char *argv[])
+ #ifndef Q_OS_OSX
+ closeAllFDs(); // We are in the child now. Close FDs unconditionally.
+ #endif
+- execvpe(argv[0], const_cast< char ** >(argv), const_cast<char**> (environ_data.data()));
++ execve(argv[0], const_cast< char ** >(argv), const_cast<char**> (environ_data.data()));
+ fprintf(stderr, "KCrash failed to exec(), errno = %d\n", errno);
+ _exit(253);
+ default: