aboutsummaryrefslogtreecommitdiff
path: root/devel/kf5-kio
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-10-20 18:07:07 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-10-20 18:07:07 +0000
commit69d11931763481cd56fb287eb5cf1e59e6bf6ae5 (patch)
treebd0015c7c8846e3f3dc62e1bb8505df3b0afff21 /devel/kf5-kio
parent8bd4af7af45e21d305d112025e25419e9ec6feb4 (diff)
downloadports-69d11931763481cd56fb287eb5cf1e59e6bf6ae5.tar.gz
ports-69d11931763481cd56fb287eb5cf1e59e6bf6ae5.zip
devel/kf5-kio: add upstream patch to fix crash when accessing help
Notes
Notes: svn path=/head/; revision=482610
Diffstat (limited to 'devel/kf5-kio')
-rw-r--r--devel/kf5-kio/Makefile1
-rw-r--r--devel/kf5-kio/files/patch-git_cf3b0d1044
2 files changed, 45 insertions, 0 deletions
diff --git a/devel/kf5-kio/Makefile b/devel/kf5-kio/Makefile
index 6c1e819e6067..4d28e2f46651 100644
--- a/devel/kf5-kio/Makefile
+++ b/devel/kf5-kio/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kio
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
diff --git a/devel/kf5-kio/files/patch-git_cf3b0d10 b/devel/kf5-kio/files/patch-git_cf3b0d10
new file mode 100644
index 000000000000..184457d483de
--- /dev/null
+++ b/devel/kf5-kio/files/patch-git_cf3b0d10
@@ -0,0 +1,44 @@
+From cf3b0d102855a4a90db3fb65a99e0009fcdd3755 Mon Sep 17 00:00:00 2001
+From: Michael Pyne <mpyne@kde.org>
+Date: Sat, 13 Oct 2018 19:09:50 -0400
+Subject: kio_help: Fix crash in QCoreApplication when accessing help://.
+
+A recent commit d428fc8e6447ede81f1e1911d0b66b39265672f3 removed old
+custom crash handling code in favor of KCrash. But this actually adds a
+dependency on there being a valid QCoreApplication object.
+
+I took from the example of the similar kio_file to simply create the
+QCoreApplication here.
+
+BUG:399709
+
+Differential Revision: https://phabricator.kde.org/D16189
+---
+ src/ioslaves/help/main.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/ioslaves/help/main.cpp b/src/ioslaves/help/main.cpp
+index f09987a..f800a9d 100644
+--- src/ioslaves/help/main.cpp
++++ src/ioslaves/help/main.cpp
+@@ -10,6 +10,7 @@ extern "C" int xmlLoadExtDtdDefaultValue;
+
+ #include <QDebug>
+
++#include <QCoreApplication>
+ #include <QString>
+
+ #include <stdlib.h>
+@@ -40,6 +41,9 @@ extern "C"
+ {
+ Q_DECL_EXPORT int kdemain(int argc, char **argv)
+ {
++ QCoreApplication app(argc, argv); // needed for KCrash
++ app.setApplicationName(QStringLiteral("kio_help"));
++
+ KDocTools::setupStandardDirs();
+
+ //qDebug() << "Starting " << getpid();
+--
+cgit v0.11.2
+