aboutsummaryrefslogtreecommitdiff
path: root/devel/kf5-kio
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-06-17 10:45:51 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-06-17 10:45:51 +0000
commitf252dcdc08d039a071b9c8c14b19ccce94cda197 (patch)
tree1b37dc577739eff7c1dab6766e47e5db39672540 /devel/kf5-kio
parent46af12750b053adbc9b67ca5d3582de3081101aa (diff)
downloadports-f252dcdc08d039a071b9c8c14b19ccce94cda197.tar.gz
ports-f252dcdc08d039a071b9c8c14b19ccce94cda197.zip
Update KDE Frameworks to 5.71.0
June 06, 2020. KDE today announces the release of KDE Frameworks 5.71.0. KDE Frameworks are over 70 addon libraries to Qt which provide a wide variety of commonly needed functionality in mature, peer reviewed and well tested libraries with friendly licensing terms. For an introduction see the KDE Frameworks web page. This release is part of a series of planned monthly releases making improvements available to developers in a quick and predictable manner. Announcement: https://kde.org/announcements/kde-frameworks-5.71.0 Exp-run by: antoine PR: 247240
Notes
Notes: svn path=/head/; revision=539415
Diffstat (limited to 'devel/kf5-kio')
-rw-r--r--devel/kf5-kio/Makefile2
-rw-r--r--devel/kf5-kio/distinfo6
-rw-r--r--devel/kf5-kio/files/patch-git_6452a34cf90
-rw-r--r--devel/kf5-kio/pkg-plist13
4 files changed, 11 insertions, 100 deletions
diff --git a/devel/kf5-kio/Makefile b/devel/kf5-kio/Makefile
index c8f6f23bc478..3f6c39e15387 100644
--- a/devel/kf5-kio/Makefile
+++ b/devel/kf5-kio/Makefile
@@ -2,8 +2,6 @@
PORTNAME= kio
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
-PORTREVISION= 1
-KDE_FRAMEWORKS_VERSION= 5.70.1
CATEGORIES= devel kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
diff --git a/devel/kf5-kio/distinfo b/devel/kf5-kio/distinfo
index d2d19b138c72..8fd0207759c2 100644
--- a/devel/kf5-kio/distinfo
+++ b/devel/kf5-kio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589642194
-SHA256 (KDE/frameworks/5.70.1/kio-5.70.1.tar.xz) = b440f1a9408cd90ecc8a6bbeecbc4bde12365547bd8ca55c69619a2e659363b8
-SIZE (KDE/frameworks/5.70.1/kio-5.70.1.tar.xz) = 3200752
+TIMESTAMP = 1592072459
+SHA256 (KDE/frameworks/5.71.0/kio-5.71.0.tar.xz) = b972c8dede50be3e89babb5a536054759db2a87003e6df770c598c7c1c94b8d6
+SIZE (KDE/frameworks/5.71.0/kio-5.71.0.tar.xz) = 3249764
diff --git a/devel/kf5-kio/files/patch-git_6452a34cf b/devel/kf5-kio/files/patch-git_6452a34cf
deleted file mode 100644
index 20648e469102..000000000000
--- a/devel/kf5-kio/files/patch-git_6452a34cf
+++ /dev/null
@@ -1,90 +0,0 @@
-From 6452a34cf01d03d3167b38bc28a2fe8e13569021 Mon Sep 17 00:00:00 2001
-From: Jonathan Marten <jjm@keelhaul.me.uk>
-Date: Thu, 14 May 2020 19:17:54 +0100
-Subject: Fix service file specifying 'Run in terminal' giving an error code
- 100
-
-Happens because KIO::DesktopExecParser::resultingArguments() prepends
-the terminal application to the command line. If this is a relative path,
-as it is most likely to be (and will be in the default 'konsole' case),
-the "realExecutable" check in KProcessRunner::KProcessRunner() is triggered
-and the job aborts with an error.
-
-Expand the specified terminal executable into a full path in resultingArguments(),
-and return an error immediately if it cannot be found. This full terminal path
-is not relative for the KProcessRunner::KProcessRunner() check and does not fail.
-
-Check that resultingArguments() is not empty (an error return) before accessing
-the first word of the command, so that it does not assert if the list is empty.
-Also only call resultingArguments() once.
-
-BUG: 421374
-FIXED-IN: 5.71
-
-Differential Revision: https://phabricator.kde.org/D29738
----
- src/core/desktopexecparser.cpp | 10 +++++++++-
- src/gui/kprocessrunner.cpp | 17 +++++++++--------
- 2 files changed, 18 insertions(+), 9 deletions(-)
-
-diff --git a/src/core/desktopexecparser.cpp b/src/core/desktopexecparser.cpp
-index a3b5219..fcf83d9 100644
---- src/core/desktopexecparser.cpp.orig
-+++ src/core/desktopexecparser.cpp
-@@ -421,7 +421,15 @@ QStringList KIO::DesktopExecParser::resultingArguments() const
- if (d->service.terminal()) {
- KConfigGroup cg(KSharedConfig::openConfig(), "General");
- QString terminal = cg.readPathEntry("TerminalApplication", QStringLiteral("konsole"));
-- if (terminal == QLatin1String("konsole")) {
-+ const bool isKonsole = (terminal == QLatin1String("konsole"));
-+
-+ QString terminalPath = QStandardPaths::findExecutable(terminal);
-+ if (terminalPath.isEmpty()) {
-+ qCWarning(KIO_CORE) << "Terminal" << terminal << "not found, service" << d->service.name();
-+ return QStringList();
-+ }
-+ terminal = terminalPath;
-+ if (isKonsole) {
- if (!d->service.workingDirectory().isEmpty()) {
- terminal += QLatin1String(" --workdir ") + KShell::quoteArg(d->service.workingDirectory());
- }
-diff --git a/src/gui/kprocessrunner.cpp b/src/gui/kprocessrunner.cpp
-index a4701a7..cc57b54 100644
---- src/gui/kprocessrunner.cpp.orig
-+++ src/gui/kprocessrunner.cpp
-@@ -88,9 +88,17 @@ KProcessRunner::KProcessRunner(const KService::Ptr &service, const QList<QUrl> &
- emitDelayedError(i18n("The desktop entry file\n%1\nis not valid.", service->entryPath()));
- return;
- }
-+
- KIO::DesktopExecParser execParser(*service, urls);
-+ execParser.setUrlsAreTempFiles(flags & KIO::ApplicationLauncherJob::DeleteTemporaryFiles);
-+ execParser.setSuggestedFileName(suggestedFileName);
-+ const QStringList args = execParser.resultingArguments();
-+ if (args.isEmpty()) {
-+ emitDelayedError(i18n("Error processing Exec field in %1", service->entryPath()));
-+ return;
-+ }
-
-- const QString realExecutable = execParser.resultingArguments().at(0);
-+ const QString realExecutable = args.at(0);
- // realExecutable is a full path if DesktopExecParser was able to locate it. Otherwise it's still relative, which is a bad sign.
- if (QDir::isRelativePath(realExecutable) || !QFileInfo(realExecutable).isExecutable()) {
- // Does it really not exist, or is it non-executable? (bug #415567)
-@@ -103,13 +111,6 @@ KProcessRunner::KProcessRunner(const KService::Ptr &service, const QList<QUrl> &
- return;
- }
-
-- execParser.setUrlsAreTempFiles(flags & KIO::ApplicationLauncherJob::DeleteTemporaryFiles);
-- execParser.setSuggestedFileName(suggestedFileName);
-- const QStringList args = execParser.resultingArguments();
-- if (args.isEmpty()) {
-- emitDelayedError(i18n("Error processing Exec field in %1", service->entryPath()));
-- return;
-- }
- //qDebug() << "KProcess args=" << args;
- *m_process << args;
-
---
-cgit v1.1
-
diff --git a/devel/kf5-kio/pkg-plist b/devel/kf5-kio/pkg-plist
index f40e3f5e27fd..1b5180dc102f 100644
--- a/devel/kf5-kio/pkg-plist
+++ b/devel/kf5-kio/pkg-plist
@@ -172,9 +172,11 @@ include/KF5/KIOFileWidgets/kurlnavigator.h
include/KF5/KIOGui/KIO/ApplicationLauncherJob
include/KF5/KIOGui/KIO/CommandLauncherJob
include/KF5/KIOGui/KIO/FavIconRequestJob
+include/KF5/KIOGui/KIO/OpenUrlJob
include/KF5/KIOGui/kio/applicationlauncherjob.h
include/KF5/KIOGui/kio/commandlauncherjob.h
include/KF5/KIOGui/kio/faviconrequestjob.h
+include/KF5/KIOGui/kio/openurljob.h
include/KF5/KIOGui/kiogui_export.h
include/KF5/KIOWidgets/KAbstractFileItemActionPlugin
include/KF5/KIOWidgets/KAutoMount
@@ -264,19 +266,19 @@ lib/cmake/KF5KIO/KF5KIOTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/KF5KIO/KF5KIOTargets.cmake
lib/libKF5KIOCore.so
lib/libKF5KIOCore.so.5
-lib/libKF5KIOCore.so.5.70.0
+lib/libKF5KIOCore.so.%%KDE_FRAMEWORKS_VERSION%%
lib/libKF5KIOFileWidgets.so
lib/libKF5KIOFileWidgets.so.5
-lib/libKF5KIOFileWidgets.so.5.70.0
+lib/libKF5KIOFileWidgets.so.%%KDE_FRAMEWORKS_VERSION%%
lib/libKF5KIOGui.so
lib/libKF5KIOGui.so.5
-lib/libKF5KIOGui.so.5.70.0
+lib/libKF5KIOGui.so.%%KDE_FRAMEWORKS_VERSION%%
lib/libKF5KIONTLM.so
lib/libKF5KIONTLM.so.5
-lib/libKF5KIONTLM.so.5.70.0
+lib/libKF5KIONTLM.so.%%KDE_FRAMEWORKS_VERSION%%
lib/libKF5KIOWidgets.so
lib/libKF5KIOWidgets.so.5
-lib/libKF5KIOWidgets.so.5.70.0
+lib/libKF5KIOWidgets.so.%%KDE_FRAMEWORKS_VERSION%%
lib/libexec/kf5/kio_http_cache_cleaner
lib/libexec/kf5/kiod5
lib/libexec/kf5/kioexec
@@ -978,6 +980,7 @@ share/kservicetypes5/uasprovider.desktop
share/locale/af/LC_MESSAGES/kio5.mo
share/locale/ast/LC_MESSAGES/kio5.mo
share/locale/ar/LC_MESSAGES/kio5.mo
+share/locale/az/LC_MESSAGES/kio5.mo
share/locale/be/LC_MESSAGES/kio5.mo
share/locale/be@latin/LC_MESSAGES/kio5.mo
share/locale/bg/LC_MESSAGES/kio5.mo