aboutsummaryrefslogtreecommitdiff
path: root/devel/libbfd
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2004-04-28 20:24:39 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2004-04-28 20:24:39 +0000
commitfdfb17efb84ec4765a56aab9ac7fe3cc2779de37 (patch)
treec28ff8e6e00eb3eb458ae3b9ec18c4156e24e15d /devel/libbfd
parenta2356ca7d9453cfcc6d4a8dd775d580c6d50f4bd (diff)
downloadports-fdfb17efb84ec4765a56aab9ac7fe3cc2779de37.tar.gz
ports-fdfb17efb84ec4765a56aab9ac7fe3cc2779de37.zip
Notes
Diffstat (limited to 'devel/libbfd')
-rw-r--r--devel/libbfd/Makefile30
-rw-r--r--devel/libbfd/distinfo2
-rw-r--r--devel/libbfd/pkg-descr4
-rw-r--r--devel/libbfd/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/libbfd/Makefile b/devel/libbfd/Makefile
new file mode 100644
index 000000000000..8ce67ce92692
--- /dev/null
+++ b/devel/libbfd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libbfd
+# Date created: 26 Feb 2004
+# Whom: Joerg Wunsch <joerg@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbfd
+PORTVERSION= 2.14
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
+MASTER_SITE_SUBDIR= binutils/releases
+DISTNAME= binutils-${PORTVERSION}
+
+MAINTAINER= joerg@freebsd.org
+COMMENT= Universal BFD library from GNU binutils
+
+WRKSRC= ${WRKDIR}/binutils-${PORTVERSION}/bfd
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --enable-install-libbfd \
+ --enable-commonbfdlib \
+ --disable-nls \
+ --enable-targets=all
+USE_LIBTOOL= yes
+
+INFO= bfd
+
+.include <bsd.port.mk>
diff --git a/devel/libbfd/distinfo b/devel/libbfd/distinfo
new file mode 100644
index 000000000000..5e31e03c3586
--- /dev/null
+++ b/devel/libbfd/distinfo
@@ -0,0 +1,2 @@
+MD5 (binutils-2.14.tar.bz2) = 2da8def15d28af3ec6af0982709ae90a
+SIZE (binutils-2.14.tar.bz2) = 10921504
diff --git a/devel/libbfd/pkg-descr b/devel/libbfd/pkg-descr
new file mode 100644
index 000000000000..11b4d4c445e8
--- /dev/null
+++ b/devel/libbfd/pkg-descr
@@ -0,0 +1,4 @@
+Universal BFD library from the GNU binutils
+
+BFD stands for "Binary File Descriptor". This library can handle
+almost any object file format on earth.
diff --git a/devel/libbfd/pkg-plist b/devel/libbfd/pkg-plist
new file mode 100644
index 000000000000..5155fe538d6d
--- /dev/null
+++ b/devel/libbfd/pkg-plist
@@ -0,0 +1,5 @@
+include/ansidecl.h
+include/bfd.h
+include/bfdlink.h
+include/symcat.h
+lib/libbfd.a