aboutsummaryrefslogtreecommitdiff
path: root/devel/libevent2
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-24 13:32:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-24 13:32:58 +0000
commitb5646534525f3eb9cce485f6580fe9a473ce2ba7 (patch)
treeffddb673c48038e781d69f6c3d08ec8855ad33a5 /devel/libevent2
parentafee9d5cd365a4ef10c99ef86e5358e76a5d37f2 (diff)
downloadports-b5646534525f3eb9cce485f6580fe9a473ce2ba7.tar.gz
ports-b5646534525f3eb9cce485f6580fe9a473ce2ba7.zip
Notes
Diffstat (limited to 'devel/libevent2')
-rw-r--r--devel/libevent2/Makefile39
-rw-r--r--devel/libevent2/files/patch-Makefile.in20
-rw-r--r--devel/libevent2/files/patch-libevent.pc.in12
-rw-r--r--devel/libevent2/files/patch-libevent_openssl.pc.in12
-rw-r--r--devel/libevent2/files/patch-libevent_pthreads.pc.in13
-rw-r--r--devel/libevent2/pkg-plist99
6 files changed, 58 insertions, 137 deletions
diff --git a/devel/libevent2/Makefile b/devel/libevent2/Makefile
index e1f2ba2085ee..1ad863992875 100644
--- a/devel/libevent2/Makefile
+++ b/devel/libevent2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libevent2
PORTVERSION= 2.0.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://cloud.github.com/downloads/libevent/libevent/
DISTNAME= ${PORTNAME:S/2//}-${DISTVERSION}-stable
@@ -11,39 +11,24 @@ DISTNAME= ${PORTNAME:S/2//}-${DISTVERSION}-stable
MAINTAINER= mm@FreeBSD.org
COMMENT= API for executing callback functions on events or timeouts
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
GNU_CONFIGURE= yes
-USES= libtool:oldver pathfix
-USE_LDCONFIG= ${PREFIX}/lib/event2
+USES= libtool pathfix
+USE_LDCOFNIG= yes
OPTIONS_DEFINE= OPENSSL THREADS
OPTIONS_DEFAULT= OPENSSL THREADS
+OPTIONS_SUB= yes
+INSTALL_TARGET= install-strip
-CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/event2
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL= yes
-CPPFLAGS+= -I${OPENSSLINC}
-LDFLAGS+= -L${OPENSSLLIB}
-PLIST_SUB+= OPENSSL=""
-.else
-CONFIGURE_ARGS+= --disable-openssl
-PLIST_SUB+= OPENSSL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTHREADS}
-PLIST_SUB+= THREADS=""
-.else
-CONFIGURE_ARGS+= --disable-thread-support
-PLIST_SUB+= THREADS="@comment "
-.endif
-
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/event_rpcgen.py ${STAGEDIR}${PREFIX}/bin/event2_rpcgen.py
+OPENSSL_USE= openssl=yes
+OPENSSL_CPPFLAGS= -I${OPENSSLINC}
+OPENSLS_LDFLAGS= -L${OPENSSLLIB}
+OPENSSL_CONFIGURE_ENABLE= openssl
+
+THREADS_CONFIGURE_ENABLE= support
regression-test: build
@(${SH} ${WRKSRC}/test/regress)
diff --git a/devel/libevent2/files/patch-Makefile.in b/devel/libevent2/files/patch-Makefile.in
deleted file mode 100644
index 2627024cb5f4..000000000000
--- a/devel/libevent2/files/patch-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig 2011-02-22 13:57:32.509779266 +0100
-+++ Makefile.in 2011-02-22 14:03:10.651310739 +0100
-@@ -338,7 +338,7 @@
- host_os = @host_os@
- host_vendor = @host_vendor@
- htmldir = @htmldir@
--includedir = @includedir@
-+includedir = @includedir@/event2/compat
- infodir = @infodir@
- install_sh = @install_sh@
- libdir = @libdir@
-@@ -1130,7 +1130,7 @@
-
- install-dvi-am:
-
--install-exec-am: install-dist_binSCRIPTS install-libLTLIBRARIES
-+install-exec-am: install-libLTLIBRARIES
-
- install-html: install-html-recursive
-
diff --git a/devel/libevent2/files/patch-libevent.pc.in b/devel/libevent2/files/patch-libevent.pc.in
deleted file mode 100644
index f27c50b52857..000000000000
--- a/devel/libevent2/files/patch-libevent.pc.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- libevent.pc.in.orig 2010-08-15 15:21:18.000000000 +0200
-+++ libevent.pc.in 2011-03-06 21:15:00.816214067 +0100
-@@ -10,7 +10,7 @@
- Version: @VERSION@
- Requires:
- Conflicts:
--Libs: -L${libdir} -levent
-+Libs: -L${libdir} -levent-2.0
- Libs.private: @LIBS@
--Cflags: -I${includedir}
-+Cflags: -I${includedir}/event2/compat -I${includedir}
-
diff --git a/devel/libevent2/files/patch-libevent_openssl.pc.in b/devel/libevent2/files/patch-libevent_openssl.pc.in
deleted file mode 100644
index 9b4789068690..000000000000
--- a/devel/libevent2/files/patch-libevent_openssl.pc.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- libevent_openssl.pc.in.orig 2011-05-23 23:45:50.000000000 +0200
-+++ libevent_openssl.pc.in 2011-06-19 11:22:11.784914479 +0200
-@@ -10,7 +10,7 @@
- Version: @VERSION@
- Requires: libevent
- Conflicts:
--Libs: -L${libdir} -levent_openssl
-+Libs: -L${libdir} -levent_openssl-2.0
- Libs.private: @LIBS@ -lssl -lcrypto
--Cflags: -I${includedir}
-+Cflags: -I${includedir}/event2/compat -I${includedir}
-
diff --git a/devel/libevent2/files/patch-libevent_pthreads.pc.in b/devel/libevent2/files/patch-libevent_pthreads.pc.in
deleted file mode 100644
index 3473f4d543b7..000000000000
--- a/devel/libevent2/files/patch-libevent_pthreads.pc.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- libevent_pthreads.pc.in.orig 2013-02-14 10:10:38.000000000 +0100
-+++ libevent_pthreads.pc.in 2013-02-14 10:11:05.000000000 +0100
-@@ -10,7 +10,7 @@
- Version: @VERSION@
- Requires: libevent
- Conflicts:
--Libs: -L${libdir} -levent_pthreads
--Libs.private: @LIBS@ @PTHREAD_LIBS@
--Cflags: -I${includedir} @PTHREAD_CFLAGS@
-+Libs: -L${libdir} -levent_pthreads-2.0
-+Libs.private: @LIBS@ -pthread
-+Cflags: -I${includedir}
-
diff --git a/devel/libevent2/pkg-plist b/devel/libevent2/pkg-plist
index 8759f7668f31..a69423f75f8a 100644
--- a/devel/libevent2/pkg-plist
+++ b/devel/libevent2/pkg-plist
@@ -1,62 +1,55 @@
-bin/event2_rpcgen.py
-include/event2/compat/evdns.h
-include/event2/compat/event.h
-include/event2/compat/evhttp.h
-include/event2/compat/evrpc.h
-include/event2/compat/evutil.h
-include/event2/keyvalq_struct.h
-include/event2/util.h
+bin/event_rpcgen.py
+include/evdns.h
+include/event.h
+include/event2/buffer.h
+include/event2/buffer_compat.h
+include/event2/bufferevent.h
+include/event2/bufferevent_compat.h
+include/event2/bufferevent_ssl.h
+include/event2/bufferevent_struct.h
+include/event2/dns.h
+include/event2/dns_compat.h
+include/event2/dns_struct.h
include/event2/event-config.h
include/event2/event.h
-include/event2/http_struct.h
-include/event2/dns_compat.h
-include/event2/thread.h
-include/event2/rpc_struct.h
-include/event2/tag_compat.h
-include/event2/bufferevent_compat.h
-include/event2/rpc.h
-include/event2/bufferevent.h
+include/event2/event_compat.h
include/event2/event_struct.h
-include/event2/tag.h
-include/event2/listener.h
-include/event2/bufferevent_ssl.h
include/event2/http.h
-include/event2/buffer_compat.h
include/event2/http_compat.h
-include/event2/dns.h
-include/event2/buffer.h
+include/event2/http_struct.h
+include/event2/keyvalq_struct.h
+include/event2/listener.h
+include/event2/rpc.h
include/event2/rpc_compat.h
-include/event2/dns_struct.h
-include/event2/event_compat.h
-include/event2/bufferevent_struct.h
-lib/event2/libevent-2.0.so
-lib/event2/libevent-2.0.so.6
-lib/event2/libevent_core-2.0.so
-lib/event2/libevent_core-2.0.so.6
-lib/event2/libevent_core.a
-lib/event2/libevent_core.la
-lib/event2/libevent_core.so
-lib/event2/libevent_extra-2.0.so
-lib/event2/libevent_extra-2.0.so.6
-lib/event2/libevent_extra.a
-lib/event2/libevent_extra.la
-lib/event2/libevent_extra.so
-%%THREADS%%lib/event2/libevent_pthreads-2.0.so
-%%THREADS%%lib/event2/libevent_pthreads-2.0.so.6
-%%THREADS%%lib/event2/libevent_pthreads.a
-%%THREADS%%lib/event2/libevent_pthreads.la
-%%THREADS%%lib/event2/libevent_pthreads.so
-%%OPENSSL%%lib/event2/libevent_openssl-2.0.so
-%%OPENSSL%%lib/event2/libevent_openssl-2.0.so.6
-%%OPENSSL%%lib/event2/libevent_openssl.a
-%%OPENSSL%%lib/event2/libevent_openssl.la
-%%OPENSSL%%lib/event2/libevent_openssl.so
-lib/event2/libevent.a
-lib/event2/libevent.la
-lib/event2/libevent.so
+include/event2/rpc_struct.h
+include/event2/tag.h
+include/event2/tag_compat.h
+include/event2/thread.h
+include/event2/util.h
+include/evhttp.h
+include/evrpc.h
+include/evutil.h
+lib/libevent-2.0.so.5
+lib/libevent-2.0.so.5.1.9
+lib/libevent.a
+lib/libevent.so
+lib/libevent_core-2.0.so.5
+lib/libevent_core-2.0.so.5.1.9
+lib/libevent_core.a
+lib/libevent_core.so
+lib/libevent_extra-2.0.so.5
+lib/libevent_extra-2.0.so.5.1.9
+lib/libevent_extra.a
+lib/libevent_extra.so
+%%OPENSSL%%lib/libevent_openssl-2.0.so.5
+%%OPENSSL%%lib/libevent_openssl-2.0.so.5.1.9
+%%OPENSSL%%lib/libevent_openssl.a
+%%OPENSSL%%lib/libevent_openssl.so
+%%THREADS%%lib/libevent_pthreads-2.0.so.5
+%%THREADS%%lib/libevent_pthreads-2.0.so.5.1.9
+%%THREADS%%lib/libevent_pthreads.a
+%%THREADS%%lib/libevent_pthreads.so
libdata/pkgconfig/libevent.pc
-%%THREADS%%libdata/pkgconfig/libevent_pthreads.pc
%%OPENSSL%%libdata/pkgconfig/libevent_openssl.pc
-@dirrm lib/event2
-@dirrm include/event2/compat
+%%THREADS%%libdata/pkgconfig/libevent_pthreads.pc
@dirrm include/event2