aboutsummaryrefslogtreecommitdiff
path: root/devel/libfwnt/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-01-22 12:26:41 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-01-22 12:26:41 +0000
commitf343f4c86f490ef5ea03863faef45eca197ed7f5 (patch)
treea3fe460cdb49a42bf809ef49f327d7cd146c1cf5 /devel/libfwnt/Makefile
parentd3e93611cc1f1f1a14527551c2c976b3e8b5a876 (diff)
Notes
Diffstat (limited to 'devel/libfwnt/Makefile')
-rw-r--r--devel/libfwnt/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/devel/libfwnt/Makefile b/devel/libfwnt/Makefile
index 0fccc27c1305..d661575e3bdd 100644
--- a/devel/libfwnt/Makefile
+++ b/devel/libfwnt/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= libfwnt
-# If/When moving from experimental to alpha, switch to DISTVERSIONPREFIX to prevent PORTEPOCH
-DISTVERSION= experimental-20161103
+PORTVERSION= 20170115
+DISTVERSIONPREFIX= alpha-
CATEGORIES= devel
-MASTER_SITES= https://github.com/libyal/libfwnt/releases/download/${PORTVERSION:E}/ \
+MASTER_SITES= https://github.com/libyal/libfwnt/releases/download/${PORTVERSION}/ \
LOCAL/antoine
MAINTAINER= antoine@FreeBSD.org
@@ -15,17 +15,21 @@ LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE}
-USES= gettext libtool pathfix python
+CONFIGURE_ARGS= --enable-python
+USES= libtool pathfix python
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PORTDOCS= AUTHORS ChangeLog
+OPTIONS_DEFINE= DOCS NLS
+
+NLS_USES= gettext
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_OFF= --disable-nls
-OPTIONS_DEFINE= DOCS
+PORTDOCS= AUTHORS ChangeLog
-post-install-DOCS-on:
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}