aboutsummaryrefslogtreecommitdiff
path: root/devel/libgalago/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-04-27 15:38:58 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-04-27 15:38:58 +0000
commit7a8508583c5abda54b8702e5ec48bfb80b2fa358 (patch)
tree531f0b6aaff3d673e4a2fa5ae3d962657bf085cf /devel/libgalago/Makefile
parent53f8fdbe9501f6f3afc3feb38da2cfd7cc96f146 (diff)
downloadports-7a8508583c5abda54b8702e5ec48bfb80b2fa358.tar.gz
ports-7a8508583c5abda54b8702e5ec48bfb80b2fa358.zip
Notes
Diffstat (limited to 'devel/libgalago/Makefile')
-rw-r--r--devel/libgalago/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/libgalago/Makefile b/devel/libgalago/Makefile
new file mode 100644
index 000000000000..0d3ef19815b9
--- /dev/null
+++ b/devel/libgalago/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libgalago
+# Date created: Apr 27 2007
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgalago
+PORTVERSION= 0.5.2
+CATEGORIES= devel deskutils
+MASTER_SITES= http://www.galago-project.org/files/releases/source/${PORTNAME}/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Galago desktop presence library
+
+LIB_PC_DEPENDS= dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib
+
+BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+
+USE_GNOME= gnomehack pkgconfig
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-tests
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+post-configure:
+ @${ECHO_CMD} "#define HAVE_STRCHR 1" >> ${WRKSRC}/config.h
+
+.include <bsd.port.mk>