aboutsummaryrefslogtreecommitdiff
path: root/devel/libgii
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-03-24 12:12:31 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-03-24 12:12:31 +0000
commit1862a9f852bfbdee27dee84490a2a2b0f0ae90df (patch)
tree290b9722f3f54af2376775b250c6910676233ba3 /devel/libgii
parent65b0aba11c9c03ad54f9a1c4e440aa42c0ff697d (diff)
Cleanup the GGI ports:
- trim header - remove a dead master site - update my email address - remove article in COMMENT - add LICENSE - use OPTIONS(NG) - do not specify lib version in LIB_DEPENDS - libvgl can be used on amd64 since ~3 years (libgii and libggi) - libgii can use xxf86dga extension PR: ports/177332 Approved by: bapt
Notes
Notes: svn path=/head/; revision=315112
Diffstat (limited to 'devel/libgii')
-rw-r--r--devel/libgii/Makefile44
1 files changed, 23 insertions, 21 deletions
diff --git a/devel/libgii/Makefile b/devel/libgii/Makefile
index 3ad5cef52e7e..574095ce0b3e 100644
--- a/devel/libgii/Makefile
+++ b/devel/libgii/Makefile
@@ -1,22 +1,18 @@
-# New ports collection makefile for: libgii
-# Date created: 4 January 2000
-# Whom: mwest@uct.ac.za
-#
+# Created by: mwest@uct.ac.za
# $FreeBSD$
-#
PORTNAME= libgii
PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
-MASTER_SITES= http://www.ggi-project.org/ftp/ggi/v2.2/ \
- SF/ggi/ggi-core/${PORTNAME}-${PORTVERSION}
-
+MASTER_SITES= SF/ggi/ggi-core/${PORTNAME}-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
-MAINTAINER= antoine.brodin@laposte.net
+MAINTAINER= antoine@FreeBSD.org
COMMENT= GGI API for input sources
+LICENSE= MIT
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
USE_LDCONFIG= yes
@@ -184,28 +180,34 @@ MLINKS= gg-error.3 ggi-error.3 - gii-error.3 \
gii_cmddata_getvalinfo.3 gii_phystype.3 - gii_valrange.3 \
filter-key.7 filter-keytrans.7
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT=X11
+
+.include <bsd.port.options.mk>
+
.if exists(/usr/include/dev/kii/kii.h)
-CONFIGURE_ARGS+= --enable-kii --with-extra-includes=/usr/include/dev
+CONFIGURE_ARGS+=--enable-kii --with-extra-includes=/usr/include/dev
PLIST_SUB+= KII=""
.else
+CONFIGURE_ARGS+=--disable-kii
PLIST_SUB+= KII="@comment "
.endif
-.if !defined(WITHOUT_X11)
-USE_XORG= x11
+.if ${PORT_OPTIONS:MX11}
+USE_XORG= x11 xxf86dga
+CONFIGURE_ARGS+=--enable-x --with-x
PLIST_SUB+= WITH_X=""
.else
-CONFIGURE_ARGS+= --disable-x --without-x
+CONFIGURE_ARGS+=--disable-x --without-x
PLIST_SUB+= WITH_X="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if !exists(/usr/include/vgl.h) || ${ARCH} != "i386"
-CONFIGURE_ARGS+= --disable-vgl
-PLIST_SUB+= VGL="@comment "
-.else
+.if exists(/usr/include/vgl.h) && (${ARCH} == "i386" || ${ARCH} == "amd64")
+CONFIGURE_ARGS+=--enable-vgl
PLIST_SUB+= VGL=""
+.else
+CONFIGURE_ARGS+=--disable-vgl
+PLIST_SUB+= VGL="@comment "
.endif
post-install:
@@ -213,4 +215,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/filter/mouse/mouse ${PREFIX}/etc/ggi/filter/mouse.dist
${INSTALL_DATA} ${WRKSRC}/filter/keytrans/keytrans ${PREFIX}/etc/ggi/filter/keytrans.dist
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>