aboutsummaryrefslogtreecommitdiff
path: root/devel/libmcs/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-11 13:15:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-11 13:15:45 +0000
commit8e333308211c2bdccff1ce35bd20137270945a6e (patch)
tree5ff68e9d5b3d3836bb14f862c334a93871111f7f /devel/libmcs/Makefile
parent9809cc72d14ace198094bec1b7a8ccfa76d64295 (diff)
downloadports-8e333308211c2bdccff1ce35bd20137270945a6e.tar.gz
ports-8e333308211c2bdccff1ce35bd20137270945a6e.zip
Notes
Diffstat (limited to 'devel/libmcs/Makefile')
-rw-r--r--devel/libmcs/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/devel/libmcs/Makefile b/devel/libmcs/Makefile
index 08244f94ffff..f00806a5758c 100644
--- a/devel/libmcs/Makefile
+++ b/devel/libmcs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libmcs
-# Date created: 27th February 2007
-# Whom: Oliver Lehmann <oliver@FreeBSD.org>
-#
+# Created by: Oliver Lehmann <oliver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libmcs
PORTVERSION= 0.7.2
@@ -17,16 +13,17 @@ COMMENT= A BSD licenced configuration database system
LIB_DEPENDS= mowgli.2:${PORTSDIR}/devel/libmowgli
-OPTIONS= GCONF "Enable gconf support" on
+OPTIONS_DEFINE= GCONF
+OPTIONS_DEFAULT= GCONF
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_GCONF)
+.if ${PORT_OPTIONS:MGCONF}
USE_GNOME+= gconf2
CONFIGURE_ARGS+=--enable-gconf
PLIST_SUB= GCONF=""
@@ -39,4 +36,4 @@ post-patch:
@${REINPLACE_CMD} 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|g' \
${WRKSRC}/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>