aboutsummaryrefslogtreecommitdiff
path: root/devel/libosinfo/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2014-07-15 17:16:46 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2014-07-15 17:16:46 +0000
commitdceefd37dab9ed0af45b674991b0a4ef63d82844 (patch)
tree82861c1403c6f7e3795127faec8d105eb51f35d2 /devel/libosinfo/Makefile
parent8f42b293546560d8a15763bc018da2952c14d47c (diff)
downloadports-dceefd37dab9ed0af45b674991b0a4ef63d82844.tar.gz
ports-dceefd37dab9ed0af45b674991b0a4ef63d82844.zip
Notes
Diffstat (limited to 'devel/libosinfo/Makefile')
-rw-r--r--devel/libosinfo/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/libosinfo/Makefile b/devel/libosinfo/Makefile
new file mode 100644
index 000000000000..514d57fb5ca0
--- /dev/null
+++ b/devel/libosinfo/Makefile
@@ -0,0 +1,27 @@
+# Created by: Roman Bogorodskiy <novel@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libosinfo
+PORTVERSION= 0.2.10
+CATEGORIES= devel
+MASTER_SITES= https://fedorahosted.org/releases/l/i/libosinfo/
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= Library for managing OS information for virtualization
+
+LIB_DEPENDS= libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome
+
+USES= gmake libtool pathfix pkgconfig
+USE_GNOME= gnomehier glib20 libxml2 libxslt introspection:build intltool
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --disable-tests --disable-vala
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB=yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.mk>