aboutsummaryrefslogtreecommitdiff
path: root/devel/libsoup
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /devel/libsoup
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'devel/libsoup')
-rw-r--r--devel/libsoup/Makefile34
-rw-r--r--devel/libsoup/distinfo4
-rw-r--r--devel/libsoup/files/patch-tests_coding-test.c11
-rw-r--r--devel/libsoup/pkg-plist130
4 files changed, 155 insertions, 24 deletions
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index ed37b0d69ae3..7c097bad6d50 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: libsoup
-# Date created: 12 March 2003
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/devel/libsoup/Makefile,v 1.106 2011/07/28 19:00:08 kwm Exp $
-#
+# $MCom: ports/devel/libsoup/Makefile,v 1.116 2013/01/15 02:25:57 kwm Exp $
PORTNAME= libsoup
-PORTVERSION= 2.34.3
+PORTVERSION= 2.40.3
PORTREVISION?= 0
CATEGORIES= devel gnome
MASTER_SITES= GNOME
@@ -16,31 +12,29 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A SOAP (Simple Object Access Protocol) implementation in C
-USE_XZ= yes
+BUILD_DEPENDS= glib-networking>=2.29.18:${PORTSDIR}/net/glib-networking
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
+RUN_DEPENDS= glib-networking>=2.29.18:${PORTSDIR}/net/glib-networking
-BUILD_DEPENDS= glib-networking>=2.28.4:${PORTSDIR}/net/glib-networking
-LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
-RUN_DEPENDS= glib-networking>=2.28.4:${PORTSDIR}/net/glib-networking
+USE_XZ= yes
.if !defined(REFERENCE_PORT)
-USE_GNOME= gnomehack glib20 libxml2 ltverhack referencehack
+USE_GETTEXT= yes
+USE_GNOME= gnomehier gnomehack glib20 libxml2 ltverhack referencehack \
+ intltool
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
- --disable-gtk-doc
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION="2.4"
-.include <bsd.port.pre.mk>
-
.if defined(SOUP_SLAVE)
-LIB_DEPENDS+= soup-2.4.1:${PORTSDIR}/devel/libsoup \
- gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring \
- sqlite3.8:${PORTSDIR}/databases/sqlite3
+USE_SQLITE= yes
+LIB_DEPENDS+= soup-2.4:${PORTSDIR}/devel/libsoup \
+ gnome-keyring:${PORTSDIR}/security/libgnome-keyring
CONFIGURE_ARGS+=--with-gnome
.else
BUILD_DEPENDS+= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
@@ -73,6 +67,6 @@ post-install:
${PREFIX}/include/libsoup-2.4/libsoup/soup-connection.h
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
.endif
diff --git a/devel/libsoup/distinfo b/devel/libsoup/distinfo
index 8849804ccbe4..4d489f751be9 100644
--- a/devel/libsoup/distinfo
+++ b/devel/libsoup/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/libsoup-2.34.3.tar.xz) = c43f8865a9f7016c618b481bea3dd9ea65d9200685d4a94cddc54f8663704a1c
-SIZE (gnome2/libsoup-2.34.3.tar.xz) = 595916
+SHA256 (gnome2/libsoup-2.40.3.tar.xz) = 82c92f1f6f4cbfd501df783ed87e7de9410b4a12a3bb0b19c64722e185d2bbc9
+SIZE (gnome2/libsoup-2.40.3.tar.xz) = 709124
diff --git a/devel/libsoup/files/patch-tests_coding-test.c b/devel/libsoup/files/patch-tests_coding-test.c
new file mode 100644
index 000000000000..899c799bc71d
--- /dev/null
+++ b/devel/libsoup/files/patch-tests_coding-test.c
@@ -0,0 +1,11 @@
+--- tests/coding-test.c.orig 2012-06-29 12:07:41.000000000 +0200
++++ tests/coding-test.c 2012-06-29 12:47:16.000000000 +0200
+@@ -66,7 +66,7 @@
+ }
+ }
+ if (file_path && encoding) {
+- file = g_strdup_printf (file_path, path);
++ file = g_strdup_printf ("%s", path);
+ if (g_file_test (file, G_FILE_TEST_EXISTS)) {
+ soup_message_headers_append (msg->response_headers,
+ "Content-Encoding",
diff --git a/devel/libsoup/pkg-plist b/devel/libsoup/pkg-plist
index 8b0a55444603..83bdbba6e77f 100644
--- a/devel/libsoup/pkg-plist
+++ b/devel/libsoup/pkg-plist
@@ -21,6 +21,7 @@ include/libsoup-%%VERSION%%/libsoup/soup-message.h
include/libsoup-%%VERSION%%/libsoup/soup-method.h
include/libsoup-%%VERSION%%/libsoup/soup-misc.h
include/libsoup-%%VERSION%%/libsoup/soup-multipart.h
+include/libsoup-%%VERSION%%/libsoup/soup-multipart-input-stream.h
include/libsoup-%%VERSION%%/libsoup/soup-password-manager.h
include/libsoup-%%VERSION%%/libsoup/soup-portability.h
include/libsoup-%%VERSION%%/libsoup/soup-proxy-resolver.h
@@ -38,6 +39,7 @@ include/libsoup-%%VERSION%%/libsoup/soup-session-sync.h
include/libsoup-%%VERSION%%/libsoup/soup-session.h
include/libsoup-%%VERSION%%/libsoup/soup-socket.h
include/libsoup-%%VERSION%%/libsoup/soup-status.h
+include/libsoup-%%VERSION%%/libsoup/soup-tld.h
include/libsoup-%%VERSION%%/libsoup/soup-types.h
include/libsoup-%%VERSION%%/libsoup/soup-uri.h
include/libsoup-%%VERSION%%/libsoup/soup-value-utils.h
@@ -50,7 +52,131 @@ lib/libsoup-%%VERSION%%.so
lib/libsoup-%%VERSION%%.so.1
libdata/pkgconfig/libsoup-%%VERSION%%.pc
share/gir-1.0/Soup-%%VERSION%%.gir
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupAddress.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupAuth.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupAuthDomain.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupAuthDomainBasic.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupAuthDomainDigest.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupCache.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupContentDecoder.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupContentSniffer.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupCookie.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupCookieJar.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupCookieJarText.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupLogger.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupMessage.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupMessageBody.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupMessageHeaders.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupMultipart.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupMultipartInputStream.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupProxyResolverDefault.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupProxyURIResolver.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupRequest.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupRequestData.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupRequestFile.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupRequestHTTP.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupServer.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupSession.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupSessionAsync.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupSessionFeature.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupSessionSync.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupSocket.html
+share/gtk-doc/html/libsoup-%%VERSION%%/SoupURI.html
+share/gtk-doc/html/libsoup-%%VERSION%%/annotation-glossary.html
+share/gtk-doc/html/libsoup-%%VERSION%%/ch01.html
+share/gtk-doc/html/libsoup-%%VERSION%%/ch02.html
+share/gtk-doc/html/libsoup-%%VERSION%%/ch03.html
+share/gtk-doc/html/libsoup-%%VERSION%%/ch04.html
+share/gtk-doc/html/libsoup-%%VERSION%%/ch05.html
+share/gtk-doc/html/libsoup-%%VERSION%%/ch06.html
+share/gtk-doc/html/libsoup-%%VERSION%%/ch07.html
+share/gtk-doc/html/libsoup-%%VERSION%%/home.png
+share/gtk-doc/html/libsoup-%%VERSION%%/index.html
+share/gtk-doc/html/libsoup-%%VERSION%%/index.sgml
+share/gtk-doc/html/libsoup-%%VERSION%%/ix01.html
+share/gtk-doc/html/libsoup-%%VERSION%%/left.png
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-GValue-Support.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-HTML-Form-Support.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-Soup-Miscellaneous-Utilities.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-SoupCookieJarSqlite.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-SoupRequester.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-Top-Level-Domain-utils.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-XMLRPC-Support.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-soup-gnome-features.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-soup-method.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%-soup-status.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-%%VERSION%%.devhelp2
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-build-howto.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-client-howto.html
+share/gtk-doc/html/libsoup-%%VERSION%%/libsoup-server-howto.html
+share/gtk-doc/html/libsoup-%%VERSION%%/right.png
+share/gtk-doc/html/libsoup-%%VERSION%%/style.css
+share/gtk-doc/html/libsoup-%%VERSION%%/up.png
+share/locale/as/LC_MESSAGES/libsoup.mo
+share/locale/be/LC_MESSAGES/libsoup.mo
+share/locale/bg/LC_MESSAGES/libsoup.mo
+share/locale/bn_IN/LC_MESSAGES/libsoup.mo
+share/locale/ca/LC_MESSAGES/libsoup.mo
+share/locale/ca@valencia/LC_MESSAGES/libsoup.mo
+share/locale/cs/LC_MESSAGES/libsoup.mo
+share/locale/da/LC_MESSAGES/libsoup.mo
+share/locale/de/LC_MESSAGES/libsoup.mo
+share/locale/el/LC_MESSAGES/libsoup.mo
+share/locale/en_GB/LC_MESSAGES/libsoup.mo
+share/locale/eo/LC_MESSAGES/libsoup.mo
+share/locale/es/LC_MESSAGES/libsoup.mo
+share/locale/et/LC_MESSAGES/libsoup.mo
+share/locale/fa/LC_MESSAGES/libsoup.mo
+share/locale/fr/LC_MESSAGES/libsoup.mo
+share/locale/fur/LC_MESSAGES/libsoup.mo
+share/locale/gl/LC_MESSAGES/libsoup.mo
+share/locale/gu/LC_MESSAGES/libsoup.mo
+share/locale/he/LC_MESSAGES/libsoup.mo
+share/locale/hi/LC_MESSAGES/libsoup.mo
+share/locale/hu/LC_MESSAGES/libsoup.mo
+share/locale/id/LC_MESSAGES/libsoup.mo
+share/locale/it/LC_MESSAGES/libsoup.mo
+share/locale/ja/LC_MESSAGES/libsoup.mo
+share/locale/kn/LC_MESSAGES/libsoup.mo
+share/locale/ko/LC_MESSAGES/libsoup.mo
+share/locale/lt/LC_MESSAGES/libsoup.mo
+share/locale/lv/LC_MESSAGES/libsoup.mo
+share/locale/ml/LC_MESSAGES/libsoup.mo
+share/locale/mr/LC_MESSAGES/libsoup.mo
+share/locale/nb/LC_MESSAGES/libsoup.mo
+share/locale/or/LC_MESSAGES/libsoup.mo
+share/locale/pa/LC_MESSAGES/libsoup.mo
+share/locale/pl/LC_MESSAGES/libsoup.mo
+share/locale/pt/LC_MESSAGES/libsoup.mo
+share/locale/pt_BR/LC_MESSAGES/libsoup.mo
+share/locale/ro/LC_MESSAGES/libsoup.mo
+share/locale/ru/LC_MESSAGES/libsoup.mo
+share/locale/sk/LC_MESSAGES/libsoup.mo
+share/locale/sl/LC_MESSAGES/libsoup.mo
+share/locale/sr/LC_MESSAGES/libsoup.mo
+share/locale/sr@latin/LC_MESSAGES/libsoup.mo
+share/locale/sv/LC_MESSAGES/libsoup.mo
+share/locale/ta/LC_MESSAGES/libsoup.mo
+share/locale/te/LC_MESSAGES/libsoup.mo
+share/locale/th/LC_MESSAGES/libsoup.mo
+share/locale/tr/LC_MESSAGES/libsoup.mo
+share/locale/ug/LC_MESSAGES/libsoup.mo
+share/locale/uk/LC_MESSAGES/libsoup.mo
+share/locale/uz@cyrillic/LC_MESSAGES/libsoup.mo
+share/locale/vi/LC_MESSAGES/libsoup.mo
+share/locale/zh_CN/LC_MESSAGES/libsoup.mo
+share/locale/zh_HK/LC_MESSAGES/libsoup.mo
+share/locale/zh_TW/LC_MESSAGES/libsoup.mo
+@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
+@dirrmtry share/locale/uz@cyrillic
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/fur/LC_MESSAGES
+@dirrmtry share/locale/fur
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrm share/gtk-doc/html/libsoup-%%VERSION%%
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc/
@dirrm include/libsoup-%%VERSION%%/libsoup
@dirrm include/libsoup-%%VERSION%%
-@dirrmtry lib/girepository-1.0
-@dirrmtry share/gir-1.0