aboutsummaryrefslogtreecommitdiff
path: root/devel/libvirt
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2014-04-07 19:48:53 +0000
committerJason Helfman <jgh@FreeBSD.org>2014-04-07 19:48:53 +0000
commitba38df01527a97a2cf59e4046f44b71dc36fa1e4 (patch)
treea51c066d6c3d497b53139537eff93b2326dcfcea /devel/libvirt
parentd7e3f8342746dd5f41350fe952a2f9f49069af73 (diff)
downloadports-ba38df01527a97a2cf59e4046f44b71dc36fa1e4.tar.gz
ports-ba38df01527a97a2cf59e4046f44b71dc36fa1e4.zip
Notes
Diffstat (limited to 'devel/libvirt')
-rw-r--r--devel/libvirt/Makefile13
-rw-r--r--devel/libvirt/distinfo4
-rw-r--r--devel/libvirt/files/patch-src__Makefile.in25
-rw-r--r--devel/libvirt/pkg-plist5
4 files changed, 18 insertions, 29 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 1f3eb3c8f818..2a50339b8fe0 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libvirt
-PORTVERSION= 1.2.2
+PORTVERSION= 1.2.3
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/ \
ftp://libvirt.org/libvirt/
@@ -18,8 +18,10 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
libgnutls.so:${PORTSDIR}/security/gnutls \
libssh2.so:${PORTSDIR}/security/libssh2
-OPTIONS_DEFINE= QEMU DOCS NLS
+OPTIONS_DEFINE= DOCS NLS QEMU
+OPTIONS_DEFINE_amd64= BHYVE
QEMU_DESC= QEMU driver
+BHYVE_DESC= bhyve driver
OPTIONS_SUB= yes
@@ -29,6 +31,8 @@ QEMU_LIB_DEPENDS= libyajl.so:${PORTSDIR}/devel/yajl
QEMU_RUN_DEPENDS= dmidecode:${PORTSDIR}/sysutils/dmidecode \
qemu-io:${PORTSDIR}/emulators/qemu-devel
+BHYVE_CONFIGURE_WITH= bhyve
+
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
@@ -75,6 +79,11 @@ STRIP_FILES= libvirt.so.${SHLIB_VER} \
.include <bsd.port.options.mk>
+#work around an options bug (thanks mat@)
+.if ${ARCH} != amd64
+PLIST_SUB+= BHYVE="@comment "
+.endif
+
post-patch:
.if ${OSVERSION} < 900000
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||' \
diff --git a/devel/libvirt/distinfo b/devel/libvirt/distinfo
index e2f8d4d27a59..873ba010c4ea 100644
--- a/devel/libvirt/distinfo
+++ b/devel/libvirt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libvirt-1.2.2.tar.gz) = a48377e307c5c21b67e43db99af909a23c33aff8cbbaa3361fd389eb047cbbc3
-SIZE (libvirt-1.2.2.tar.gz) = 28340039
+SHA256 (libvirt-1.2.3.tar.gz) = b489d1a29c6166643d34b72795a89b03c6ac775cdaeadb6aa86fc1a982c02e31
+SIZE (libvirt-1.2.3.tar.gz) = 28605530
diff --git a/devel/libvirt/files/patch-src__Makefile.in b/devel/libvirt/files/patch-src__Makefile.in
deleted file mode 100644
index 0fc4507281ba..000000000000
--- a/devel/libvirt/files/patch-src__Makefile.in
+++ /dev/null
@@ -1,25 +0,0 @@
---- ./src/Makefile.in.orig 2014-03-07 08:08:47.000000000 -0800
-+++ ./src/Makefile.in 2014-03-07 08:10:53.000000000 -0800
-@@ -288,9 +288,9 @@
- @WITH_LIBVIRTD_TRUE@am__append_159 = lockd.la
- @WITH_LIBVIRTD_TRUE@am__append_160 = locking/libvirt_lockd.aug \
- @WITH_LIBVIRTD_TRUE@ locking/virtlockd.aug
--@WITH_LIBVIRTD_TRUE@am__append_161 = test_libvirt_lockd.aug \
--@WITH_LIBVIRTD_TRUE@ test_virtlockd.aug
--@WITH_LIBVIRTD_TRUE@am__append_162 = test_libvirt_lockd.aug
-+@WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@am__append_161 = test_libvirt_lockd.aug \
-+@WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@ test_virtlockd.aug
-+@WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@am__append_162 = test_libvirt_lockd.aug
- @WITH_DTRACE_PROBES_TRUE@@WITH_LIBVIRTD_TRUE@am__append_163 = libvirt_probes.lo
- @WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@am__append_164 = locking/qemu-lockd.conf
- @WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@am__append_165 = locking/qemu-lockd.conf
-@@ -9678,6 +9678,8 @@
- @WITH_QEMU_TRUE@ locking/qemu-lockd.conf $(AUG_GENTEST)
- @WITH_QEMU_TRUE@ $(AM_V_GEN)$(AUG_GENTEST) locking/qemu-lockd.conf $< $@
-
-+@WITH_QEMU_FALSE@test_libvirt_lockd.aug:
-+
- test_virtlockd.aug: locking/test_virtlockd.aug.in \
- locking/virtlockd.conf $(AUG_GENTEST)
- $(AM_V_GEN)$(AUG_GENTEST) $(srcdir)/locking/virtlockd.conf $< $@
-
diff --git a/devel/libvirt/pkg-plist b/devel/libvirt/pkg-plist
index 2187faa5f245..a27cd827b236 100644
--- a/devel/libvirt/pkg-plist
+++ b/devel/libvirt/pkg-plist
@@ -159,6 +159,9 @@ share/augeas/lenses/tests/test_libvirtd.aug
%%DOCSDIR%%%%PORTVERSION%%/html/uri.html
%%DOCSDIR%%%%PORTVERSION%%/html/virshcmdref.html
%%DOCSDIR%%%%PORTVERSION%%/html/windows.html
+%%DOCSDIR%%%%PORTVERSION%%/html/drvbhyve.html
+%%DOCSDIR%%%%PORTVERSION%%/html/governance.html
+%%DOCSDIR%%%%PORTVERSION%%/html/internals/oomtesting.html
share/gtk-doc/html/libvirt/general.html
share/gtk-doc/html/libvirt/home.png
share/gtk-doc/html/libvirt/index.html
@@ -266,6 +269,8 @@ share/gtk-doc/html/libvirt/up.png
%%NLS%%share/locale/zu/LC_MESSAGES/libvirt.mo
%%QEMU%%lib/libvirt/connection-driver/libvirt_driver_qemu.so
%%QEMU%%lib/libvirt/connection-driver/libvirt_driver_qemu.la
+%%BHYVE%%lib/libvirt/connection-driver/libvirt_driver_bhyve.la
+%%BHYVE%%lib/libvirt/connection-driver/libvirt_driver_bhyve.so
lib/libvirt/connection-driver/libvirt_driver_secret.so
lib/libvirt/connection-driver/libvirt_driver_secret.la
lib/libvirt/connection-driver/libvirt_driver_storage.so