aboutsummaryrefslogtreecommitdiff
path: root/devel/libvolume_id
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-04-16 04:06:56 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-04-16 04:06:56 +0000
commitdd184e992e4e6959f5125c3a8d5c750229183bc2 (patch)
tree4d385182d5ad020c9ebb3083730616021e268ad0 /devel/libvolume_id
parent058b2f6bd9f409df6ebcf73c131306a24bc03114 (diff)
downloadports-dd184e992e4e6959f5125c3a8d5c750229183bc2.tar.gz
ports-dd184e992e4e6959f5125c3a8d5c750229183bc2.zip
Notes
Diffstat (limited to 'devel/libvolume_id')
-rw-r--r--devel/libvolume_id/Makefile7
-rw-r--r--devel/libvolume_id/distinfo6
-rw-r--r--devel/libvolume_id/files/patch-udf.c20
3 files changed, 4 insertions, 29 deletions
diff --git a/devel/libvolume_id/Makefile b/devel/libvolume_id/Makefile
index 6a1977094776..1d041338f293 100644
--- a/devel/libvolume_id/Makefile
+++ b/devel/libvolume_id/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= libvolume_id
-PORTVERSION= 0.71.0
-PORTREVISION= 1
+PORTVERSION= 0.75.0
CATEGORIES= devel
MASTER_SITES= http://www.marcuscom.com/downloads/
@@ -28,10 +27,6 @@ PLIST_FILES= include/libvolume_id.h \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= not supported on 4.X
-.endif
-
do-install:
${MKDIR} ${PREFIX}/libdata/pkgconfig
${INSTALL_DATA} ${WRKSRC}/libvolume_id.pc ${PREFIX}/libdata/pkgconfig/libvolume_id.pc
diff --git a/devel/libvolume_id/distinfo b/devel/libvolume_id/distinfo
index 328c63836ac0..9cf44d0fe7b8 100644
--- a/devel/libvolume_id/distinfo
+++ b/devel/libvolume_id/distinfo
@@ -1,3 +1,3 @@
-MD5 (libvolume_id-0.71.0.tar.bz2) = 7a27f133d6c441801bc0626c2393cdcf
-SHA256 (libvolume_id-0.71.0.tar.bz2) = 65446fa12c2556cea6cab3cd406d0bb9a6e672894f89ff84e168c8add9ce1038
-SIZE (libvolume_id-0.71.0.tar.bz2) = 18951
+MD5 (libvolume_id-0.75.0.tar.bz2) = 804d222ea29b9401fb4a6ba00a22b072
+SHA256 (libvolume_id-0.75.0.tar.bz2) = 54072554468f732e60dae024947efaa880cf7847df2651b6dfcc16f2a58832d8
+SIZE (libvolume_id-0.75.0.tar.bz2) = 19408
diff --git a/devel/libvolume_id/files/patch-udf.c b/devel/libvolume_id/files/patch-udf.c
deleted file mode 100644
index 6ab40bd8658b..000000000000
--- a/devel/libvolume_id/files/patch-udf.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- udf.c.orig Sat Jan 13 16:35:48 2007
-+++ udf.c Sat Jan 13 16:36:03 2007
-@@ -127,7 +127,7 @@ nsr:
-
- anchor:
- /* read anchor volume descriptor */
-- vd = (struct volume_descriptor *) volume_id_get_buffer(id, off + (256 * bs), 0x200);
-+ vd = (struct volume_descriptor *) volume_id_get_buffer(id, off + (256 * bs), bs);
- if (vd == NULL)
- return -1;
-
-@@ -142,7 +142,7 @@ anchor:
-
- /* pick the primary descriptor from the list */
- for (b = 0; b < count; b++) {
-- vd = (struct volume_descriptor *) volume_id_get_buffer(id, off + ((loc + b) * bs), 0x200);
-+ vd = (struct volume_descriptor *) volume_id_get_buffer(id, off + ((loc + b) * bs), bs);
- if (vd == NULL)
- return -1;
-