aboutsummaryrefslogtreecommitdiff
path: root/devel/lightning/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-09-25 12:31:15 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-09-25 12:31:15 +0000
commitf0ddc8f08028cb003a30b6c7e89cd5d4887d778e (patch)
tree560edd89ed0b721e0b63c218392076a1a873062c /devel/lightning/Makefile
parentbc3cef62efadf6d5322b11b900cd6b84d40f9446 (diff)
Notes
Diffstat (limited to 'devel/lightning/Makefile')
-rw-r--r--devel/lightning/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/devel/lightning/Makefile b/devel/lightning/Makefile
index d11a6b834443..09db75a49856 100644
--- a/devel/lightning/Makefile
+++ b/devel/lightning/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lightning
-PORTVERSION= 2.0.0
+PORTVERSION= 2.0.1
CATEGORIES= devel
MASTER_SITES= GNU
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -13,6 +13,9 @@ COMMENT= Generates assembly language code at run-time
OPTIONS_DEFINE= ASSERTIONS
ASSERTIONS_DESC=Enable runtime code generation assertions
+ASSERTIONS_CONFIGURE_ON=--enable-assertions=yes
+ASSERTIONS_CONFIGURE_OFF=--enable-assertions=no
+
ONLY_FOR_ARCHS= i386 amd64 arm ia64 powerpc sparc64 mips
USE_LDCONFIG= yes
@@ -21,16 +24,6 @@ CONFIGURE_ARGS= --enable-disassembler=no
PLIST_SUB+= JIT_ARCH=${ARCH:S/i386/x86/:S/amd64/x86/:S/sparc64/sparc/:S/powerpc/ppc/}
-INFO= lightning
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MASSERTIONS}
-CONFIGURE_ARGS+=--enable-assertions=yes
-.else
-CONFIGURE_ARGS+=--enable-assertions=no
-.endif
-
regression-test: build
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)