aboutsummaryrefslogtreecommitdiff
path: root/devel/linux-js/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-13 08:35:30 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-13 08:35:30 +0000
commitfe22d50fbdd61870a8edd935850984c1e5ee78eb (patch)
tree9ca8ca313c8800b5ead65fa4197a753bc00991ce /devel/linux-js/Makefile
parentdd84410f0445fbd7f3256a8f1926899def128f87 (diff)
downloadports-fe22d50fbdd61870a8edd935850984c1e5ee78eb.tar.gz
ports-fe22d50fbdd61870a8edd935850984c1e5ee78eb.zip
Notes
Diffstat (limited to 'devel/linux-js/Makefile')
-rw-r--r--devel/linux-js/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/linux-js/Makefile b/devel/linux-js/Makefile
index d5365778c30e..d94a042dfa37 100644
--- a/devel/linux-js/Makefile
+++ b/devel/linux-js/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= linux-js
-PORTVERSION= 2.1
+PORTVERSION= 2.2
CATEGORIES= devel emulators
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= jylefort
@@ -21,7 +21,8 @@ MAN4= linux_js.4
PORTDOCS= joystick-api.txt
USE_RCORDER= jscal.sh linux_js.sh
-OPTIONS= JOY "PC joystick support" on \
+OPTIONS= LINUX "Linux mode support (i386/amd64 only)" on \
+ JOY "PC joystick support" on \
UHID "USB joystick support" on
MAKE_ENV= WITHOUT_DEBUG=yes
@@ -36,6 +37,10 @@ IGNORE= requires FreeBSD 5.3 or superior
IGNORE= requires kernel source files
.endif
+.if defined(WITHOUT_LINUX)
+MAKE_ENV+= WITHOUT_LINUX=yes
+.endif
+
.if defined(WITHOUT_JOY)
MAKE_ENV+= WITHOUT_JOY=yes
.endif