aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2019-10-22 18:40:11 +0000
committerBrooks Davis <brooks@FreeBSD.org>2019-10-22 18:40:11 +0000
commit61ad0994b21dda3a0b79f53d0179b1922970e5fc (patch)
tree1cb9d2c1053fc77baef66ae749caa1b03c64f66b /devel/llvm-devel
parent4d738f27c954ca0e0637dcd82dc9ee5227b4b5b2 (diff)
downloadports-61ad0994b21dda3a0b79f53d0179b1922970e5fc.tar.gz
ports-61ad0994b21dda3a0b79f53d0179b1922970e5fc.zip
Fix typo in patch to fix clang build.
Adjust the set of headers installed with clang to match llvm90. Also correct the location of the patch. Reported by: yuri (lack on unwind.h)
Notes
Notes: svn path=/head/; revision=515208
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/files/clang/patch-fformat_extensions.diff2
-rw-r--r--devel/llvm-devel/files/clang/patch-tools_clang_lib_Headers_CMakeLists.txt32
-rw-r--r--devel/llvm-devel/files/patch-tools_clang_lib_Headers_CMakeLists.txt44
-rw-r--r--devel/llvm-devel/pkg-plist6
4 files changed, 39 insertions, 45 deletions
diff --git a/devel/llvm-devel/files/clang/patch-fformat_extensions.diff b/devel/llvm-devel/files/clang/patch-fformat_extensions.diff
index 0950f939dedb..0a852534e583 100644
--- a/devel/llvm-devel/files/clang/patch-fformat_extensions.diff
+++ b/devel/llvm-devel/files/clang/patch-fformat_extensions.diff
@@ -4,7 +4,7 @@
Flags<[CC1Option]>;
def fno_use_line_directives : Flag<["-"], "fno-use-line-directives">, Group<f_Group>;
-+def fformat_extensions: Flag<["-"], "fformat-extensions">, Group<f_Group>, Flag s<[CC1Option]>,
++def fformat_extensions: Flag<["-"], "fformat-extensions">, Group<f_Group>, Flags<[CC1Option]>,
+ HelpText<"Enable FreeBSD kernel specific format string extensions">;
def ffreestanding : Flag<["-"], "ffreestanding">, Group<f_Group>, Flags<[CC1Option]>,
HelpText<"Assert that the compilation takes place in a freestanding environment">;
diff --git a/devel/llvm-devel/files/clang/patch-tools_clang_lib_Headers_CMakeLists.txt b/devel/llvm-devel/files/clang/patch-tools_clang_lib_Headers_CMakeLists.txt
new file mode 100644
index 000000000000..17043c6072cf
--- /dev/null
+++ b/devel/llvm-devel/files/clang/patch-tools_clang_lib_Headers_CMakeLists.txt
@@ -0,0 +1,32 @@
+--- tools/clang/lib/Headers/CMakeLists.txt.orig
++++ tools/clang/lib/Headers/CMakeLists.txt
+@@ -56,7 +56,6 @@
+ intrin.h
+ inttypes.h
+ iso646.h
+- limits.h
+ lwpintrin.h
+ lzcntintrin.h
+ mm3dnow.h
+@@ -76,21 +75,13 @@
+ s390intrin.h
+ shaintrin.h
+ smmintrin.h
+- stdalign.h
+- stdarg.h
+- stdatomic.h
+- stdbool.h
+- stddef.h
+ __stddef_max_align_t.h
+- stdint.h
+- stdnoreturn.h
+ tbmintrin.h
+ tgmath.h
+ tmmintrin.h
+ unwind.h
+ vadefs.h
+ vaesintrin.h
+- varargs.h
+ vecintrin.h
+ vpclmulqdqintrin.h
+ wmmintrin.h
diff --git a/devel/llvm-devel/files/patch-tools_clang_lib_Headers_CMakeLists.txt b/devel/llvm-devel/files/patch-tools_clang_lib_Headers_CMakeLists.txt
deleted file mode 100644
index 10efad9db02f..000000000000
--- a/devel/llvm-devel/files/patch-tools_clang_lib_Headers_CMakeLists.txt
+++ /dev/null
@@ -1,44 +0,0 @@
---- ./tools/clang/lib/Headers/CMakeLists.txt-orig 2018-10-23 20:12:12.000000000 -0300
-+++ ./tools/clang/lib/Headers/CMakeLists.txt 2018-12-06 12:47:11.915695000 -0200
-@@ -47,7 +47,6 @@
- clwbintrin.h
- emmintrin.h
- f16cintrin.h
-- float.h
- fma4intrin.h
- fmaintrin.h
- fxsrintrin.h
-@@ -56,11 +55,7 @@
- htmxlintrin.h
- ia32intrin.h
- immintrin.h
-- intrin.h
-- inttypes.h
- invpcidintrin.h
-- iso646.h
-- limits.h
- lwpintrin.h
- lzcntintrin.h
- mm3dnow.h
-@@ -84,21 +79,11 @@
- s390intrin.h
- shaintrin.h
- smmintrin.h
-- stdalign.h
-- stdarg.h
-- stdatomic.h
-- stdbool.h
-- stddef.h
- __stddef_max_align_t.h
-- stdint.h
-- stdnoreturn.h
- tbmintrin.h
-- tgmath.h
- tmmintrin.h
-- unwind.h
- vadefs.h
- vaesintrin.h
-- varargs.h
- vecintrin.h
- vpclmulqdqintrin.h
- waitpkgintrin.h
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 622a2ffce8a3..0800e0288fb9 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -2843,6 +2843,7 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/emmintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/enqcmdintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/f16cintrin.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/float.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/fma4intrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/fmaintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/fxsrintrin.h
@@ -2851,7 +2852,10 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/htmxlintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/ia32intrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/immintrin.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/intrin.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/inttypes.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/invpcidintrin.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/iso646.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/lwpintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/lzcntintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/mm3dnow.h
@@ -2891,7 +2895,9 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/shaintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/smmintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/tbmintrin.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/tgmath.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/tmmintrin.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/unwind.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/vadefs.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/vaesintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/vecintrin.h