aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2012-08-23 21:04:16 +0000
committerBrooks Davis <brooks@FreeBSD.org>2012-08-23 21:04:16 +0000
commit780c634d261cb2efbeb42ba6a8fe12120472bd6c (patch)
tree7df2d78dd5cce11b656c34c4f47edf838f4c4a0a /devel/llvm-devel
parenta7d95c343a88911dd365cad1bfac0a06a04198dc (diff)
downloadports-780c634d261cb2efbeb42ba6a8fe12120472bd6c.tar.gz
ports-780c634d261cb2efbeb42ba6a8fe12120472bd6c.zip
Notes
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo4
-rw-r--r--devel/llvm-devel/files/patch-lib_Target_Mips_MipsTargetMachine.cpp17
-rw-r--r--devel/llvm-devel/pkg-plist16
4 files changed, 30 insertions, 9 deletions
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index 6d7c115cd43f..b56ed88183e0 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 160283
+SVN_REV= 162438
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 7c2d76eac2e3..67be972248ec 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (llvm-3.2.r160283.tar.bz2) = 3dfae804e7765bfacfb4347ada59e174fa9f4a272ee86b17ae6882e5f3e56ca7
-SIZE (llvm-3.2.r160283.tar.bz2) = 8961712
+SHA256 (llvm-3.2.r162438.tar.bz2) = 6e5bd1121b6af1e89ace5f799febeec8278fa2e24fce6f69f5d840a42ac75617
+SIZE (llvm-3.2.r162438.tar.bz2) = 8851337
diff --git a/devel/llvm-devel/files/patch-lib_Target_Mips_MipsTargetMachine.cpp b/devel/llvm-devel/files/patch-lib_Target_Mips_MipsTargetMachine.cpp
new file mode 100644
index 000000000000..f924b1ec3599
--- /dev/null
+++ b/devel/llvm-devel/files/patch-lib_Target_Mips_MipsTargetMachine.cpp
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- lib/Target/Mips/MipsTargetMachine.cpp.orig
++++ lib/Target/Mips/MipsTargetMachine.cpp
+@@ -54,6 +54,11 @@
+ FrameLowering(MipsFrameLowering::create(*this, Subtarget)),
+ TLInfo(*this), TSInfo(*this), JITInfo(),
+ ELFWriterInfo(false, isLittle) {
++
++ // The system as doesn't understand CFI on FreeBSD
++#if defined(__FreeBSD__)
++ setMCUseCFI(false);
++#endif
+ }
+
+ void MipsebTargetMachine::anchor() { }
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index ee88c6b991d3..0a5a98a92812 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -295,7 +295,6 @@ include/llvm/IntrinsicsHexagon.td
include/llvm/IntrinsicsMips.td
include/llvm/IntrinsicsNVVM.td
include/llvm/IntrinsicsPowerPC.td
-include/llvm/IntrinsicsR600.td
include/llvm/IntrinsicsX86.td
include/llvm/IntrinsicsXCore.td
include/llvm/LLVMContext.h
@@ -319,6 +318,7 @@ include/llvm/MC/MCDwarf.h
include/llvm/MC/MCELFObjectWriter.h
include/llvm/MC/MCELFSymbolFlags.h
include/llvm/MC/MCExpr.h
+include/llvm/MC/MCFixedLenDisassembler.h
include/llvm/MC/MCFixup.h
include/llvm/MC/MCFixupKindInfo.h
include/llvm/MC/MCInst.h
@@ -409,6 +409,7 @@ include/llvm/Support/Endian.h
include/llvm/Support/Errno.h
include/llvm/Support/ErrorHandling.h
include/llvm/Support/FEnv.h
+include/llvm/Support/FileOutputBuffer.h
include/llvm/Support/FileSystem.h
include/llvm/Support/FileUtilities.h
include/llvm/Support/Format.h
@@ -423,6 +424,7 @@ include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
include/llvm/Support/IntegersSubset.h
include/llvm/Support/IntegersSubsetMapping.h
+include/llvm/Support/LEB128.h
include/llvm/Support/LICENSE.TXT
include/llvm/Support/LeakDetector.h
include/llvm/Support/Locale.h
@@ -532,6 +534,7 @@ include/llvm/Transforms/Utils/ValueMapper.h
include/llvm/Transforms/Vectorize.h
include/llvm/Type.h
include/llvm/TypeBuilder.h
+include/llvm/TypeFinder.h
include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
@@ -540,9 +543,6 @@ lib/BugpointPasses.so
lib/LLVMHello.so
lib/libLLVM-%%LLVM_RELEASE%%svn.so
lib/libLLVM-%%LLVM_RELEASE%%svn.so.0
-lib/libLLVMAMDGPUCodeGen.a
-lib/libLLVMAMDGPUDesc.a
-lib/libLLVMAMDGPUInfo.a
lib/libLLVMARMAsmParser.a
lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
@@ -629,6 +629,7 @@ lib/libLTO.a
lib/libLTO.so
lib/libprofile_rt.a
lib/libprofile_rt.so
+%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
%%PORTDOCS%%%%DOCSDIR%%/html/.buildinfo
%%PORTDOCS%%%%DOCSDIR%%/html/AliasAnalysis.html
%%PORTDOCS%%%%DOCSDIR%%/html/AliasAnalysis.txt
@@ -643,9 +644,11 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CMake.html
%%PORTDOCS%%%%DOCSDIR%%/html/CMake.txt
%%PORTDOCS%%%%DOCSDIR%%/html/CodeGenerator.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CodeGenerator.txt
%%PORTDOCS%%%%DOCSDIR%%/html/CodingStandards.html
%%PORTDOCS%%%%DOCSDIR%%/html/CodingStandards.txt
%%PORTDOCS%%%%DOCSDIR%%/html/CommandLine.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CommandLine.txt
%%PORTDOCS%%%%DOCSDIR%%/html/CompilerWriterInfo.html
%%PORTDOCS%%%%DOCSDIR%%/html/DebuggingJITedCode.html
%%PORTDOCS%%%%DOCSDIR%%/html/DeveloperPolicy.html
@@ -724,6 +727,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/doctools.js
%%PORTDOCS%%%%DOCSDIR%%/html/down-pressed.png
%%PORTDOCS%%%%DOCSDIR%%/html/down.png
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/html/file.png
%%PORTDOCS%%%%DOCSDIR%%/html/genindex.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
@@ -791,8 +795,8 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/userguides.html
%%PORTDOCS%%%%DOCSDIR%%/html/userguides.txt
%%PORTDOCS%%%%DOCSDIR%%/html/websupport.js
-%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
-%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
+%%PORTDOCS%%%%DOCSDIR%%/html/yaml2obj.html
+%%PORTDOCS%%%%DOCSDIR%%/html/yaml2obj.txt
@dirrm include/llvm/Transforms/Utils
@dirrm include/llvm/Transforms/IPO
@dirrm include/llvm/Transforms