aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2013-01-10 18:01:28 +0000
committerBrooks Davis <brooks@FreeBSD.org>2013-01-10 18:01:28 +0000
commitd10a7026cc0000f1aa2fa9a91b5258a63d95469b (patch)
tree23648fde33d443142cd56b9929ae0c3ec13b740c /devel/llvm-devel
parent3fbd06d67be099b793239917f54e8c631a314fa6 (diff)
downloadports-d10a7026cc0000f1aa2fa9a91b5258a63d95469b.tar.gz
ports-d10a7026cc0000f1aa2fa9a91b5258a63d95469b.zip
Notes
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile14
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo4
-rw-r--r--devel/llvm-devel/files/patch-lib_Target_Mips_MipsTargetMachine.cpp6
-rw-r--r--devel/llvm-devel/pkg-plist196
5 files changed, 149 insertions, 73 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index bf1a9e91c7dc..37f436d73d05 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= llvm
-DISTVERSION= 3.2.r${SVN_REV}
-PORTREVISON= 1
+DISTVERSION= 3.3.r${SVN_REV}
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -16,6 +15,7 @@ PKGNAMESUFFIX= -devel
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
+BUILD_DEPENDS+= sphinx-build:${PORTSDIR}/textproc/py-sphinx
.if defined(PACKAGE_BUILDING) || defined(MAINTAINER_MODE)
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
.endif
@@ -23,9 +23,7 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
.endif
-BUILD_DEPENDS+= sphinx-build:${PORTSDIR}/textproc/py-sphinx
-
-CONFLICTS= llvm-[23]* llvm-etoile-2*
+CONFLICTS= llvm-[23]* llvm29-* llvm31-*
GNU_CONFIGURE= yes
USE_GCC= 4.2+
@@ -50,7 +48,7 @@ ASSERTS_DESC= Enable assertions (thread unsafe)
LTOPLUGIN_DESC= Build LTO plugin (requires gold)
MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 llvm-as.1 \
- llvm-bcanalyzer.1 llvm-cov.1 llvm-config.1 llvm-diff.1 \
+ llvm-bcanalyzer.1 llvm-config.1 llvm-cov.1 llvm-diff.1 \
llvm-dis.1 llvm-extract.1 llvm-link.1 llvm-nm.1 \
llvm-prof.1 llvm-ranlib.1 llvm-stress.1 opt.1 tblgen.1
@@ -116,9 +114,9 @@ do-fetch:
http://llvm.org/svn/llvm-project/llvm/trunk ${WRKSRC}
cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
echo "SVN_REV= ${SVN_REV}" > ${MASTERDIR}/Makefile.svn_rev
-.if ${USER} == brooks
+.if ${USER} == brooks || ${USER} == bed22
scp ${DISTDIR}/${DISTNAME}.tar.bz2 \
- freefall.freebsd.org:public_distfiles/
+ brooks@freefall.freebsd.org:public_distfiles/
.endif
.endif
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index e724b017efd8..46c2c9d3bbfa 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 163622
+SVN_REV= 172076
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 92c7ed039e71..71698ef016c7 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (llvm-3.2.r163622.tar.bz2) = 12cdd4eb5d3ee236f531be7c297889a251463033504c465b6267aac22baab9f8
-SIZE (llvm-3.2.r163622.tar.bz2) = 8961570
+SHA256 (llvm-3.3.r172076.tar.bz2) = e6af04f790c94124c5b1abf93f3a24a07d6490bcfa4821e4e4425aa1e87085a2
+SIZE (llvm-3.3.r172076.tar.bz2) = 9587232
diff --git a/devel/llvm-devel/files/patch-lib_Target_Mips_MipsTargetMachine.cpp b/devel/llvm-devel/files/patch-lib_Target_Mips_MipsTargetMachine.cpp
index f924b1ec3599..38378f93744d 100644
--- a/devel/llvm-devel/files/patch-lib_Target_Mips_MipsTargetMachine.cpp
+++ b/devel/llvm-devel/files/patch-lib_Target_Mips_MipsTargetMachine.cpp
@@ -3,10 +3,10 @@ $FreeBSD$
--- lib/Target/Mips/MipsTargetMachine.cpp.orig
+++ lib/Target/Mips/MipsTargetMachine.cpp
-@@ -54,6 +54,11 @@
+@@ -55,6 +55,11 @@
+ InstrInfo(MipsInstrInfo::create(*this)),
FrameLowering(MipsFrameLowering::create(*this, Subtarget)),
- TLInfo(*this), TSInfo(*this), JITInfo(),
- ELFWriterInfo(false, isLittle) {
+ TLInfo(*this), TSInfo(*this), JITInfo() {
+
+ // The system as doesn't understand CFI on FreeBSD
+#if defined(__FreeBSD__)
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index ddc0d46122be..18ed554647b6 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -12,6 +12,7 @@ bin/llvm-dwarfdump
bin/llvm-extract
bin/llvm-link
bin/llvm-mc
+bin/llvm-mcmarkup
bin/llvm-nm
bin/llvm-objdump
bin/llvm-prof
@@ -20,6 +21,7 @@ bin/llvm-readobj
bin/llvm-rtdyld
bin/llvm-size
bin/llvm-stress
+bin/llvm-symbolizer
bin/llvm-tblgen
bin/macho-dump
bin/opt
@@ -28,7 +30,6 @@ include/llvm-c/BitReader.h
include/llvm-c/BitWriter.h
include/llvm-c/Core.h
include/llvm-c/Disassembler.h
-include/llvm-c/EnhancedDisassembly.h
include/llvm-c/ExecutionEngine.h
include/llvm-c/Initialization.h
include/llvm-c/LinkTimeOptimizer.h
@@ -65,6 +66,7 @@ include/llvm/ADT/IndexedMap.h
include/llvm/ADT/IntEqClasses.h
include/llvm/ADT/IntervalMap.h
include/llvm/ADT/IntrusiveRefCntPtr.h
+include/llvm/ADT/MapVector.h
include/llvm/ADT/NullablePtr.h
include/llvm/ADT/Optional.h
include/llvm/ADT/OwningPtr.h
@@ -107,11 +109,13 @@ include/llvm/Analysis/BlockFrequencyInfo.h
include/llvm/Analysis/BranchProbabilityInfo.h
include/llvm/Analysis/CFGPrinter.h
include/llvm/Analysis/CallGraph.h
+include/llvm/Analysis/CallGraphSCCPass.h
include/llvm/Analysis/CaptureTracking.h
include/llvm/Analysis/CodeMetrics.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
include/llvm/Analysis/DOTGraphTraitsPass.h
+include/llvm/Analysis/DependenceAnalysis.h
include/llvm/Analysis/DomPrinter.h
include/llvm/Analysis/DominanceFrontier.h
include/llvm/Analysis/DominatorInternals.h
@@ -128,7 +132,6 @@ include/llvm/Analysis/LibCallAliasAnalysis.h
include/llvm/Analysis/LibCallSemantics.h
include/llvm/Analysis/Lint.h
include/llvm/Analysis/Loads.h
-include/llvm/Analysis/LoopDependenceAnalysis.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopInfoImpl.h
include/llvm/Analysis/LoopIterator.h
@@ -145,6 +148,7 @@ include/llvm/Analysis/ProfileDataTypes.h
include/llvm/Analysis/ProfileInfo.h
include/llvm/Analysis/ProfileInfoLoader.h
include/llvm/Analysis/ProfileInfoTypes.h
+include/llvm/Analysis/PtrUseVisitor.h
include/llvm/Analysis/RegionInfo.h
include/llvm/Analysis/RegionIterator.h
include/llvm/Analysis/RegionPass.h
@@ -154,29 +158,28 @@ include/llvm/Analysis/ScalarEvolutionExpander.h
include/llvm/Analysis/ScalarEvolutionExpressions.h
include/llvm/Analysis/ScalarEvolutionNormalization.h
include/llvm/Analysis/SparsePropagation.h
+include/llvm/Analysis/TargetTransformInfo.h
include/llvm/Analysis/Trace.h
include/llvm/Analysis/ValueTracking.h
include/llvm/Analysis/Verifier.h
-include/llvm/Argument.h
include/llvm/Assembly/AssemblyAnnotationWriter.h
include/llvm/Assembly/Parser.h
include/llvm/Assembly/PrintModulePass.h
include/llvm/Assembly/Writer.h
include/llvm/Attributes.h
include/llvm/AutoUpgrade.h
-include/llvm/BasicBlock.h
include/llvm/Bitcode/Archive.h
include/llvm/Bitcode/BitCodes.h
include/llvm/Bitcode/BitstreamReader.h
include/llvm/Bitcode/BitstreamWriter.h
include/llvm/Bitcode/LLVMBitCodes.h
include/llvm/Bitcode/ReaderWriter.h
-include/llvm/CallGraphSCCPass.h
-include/llvm/CallingConv.h
include/llvm/CodeGen/Analysis.h
include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/CalcSpillWeights.h
include/llvm/CodeGen/CallingConvLower.h
+include/llvm/CodeGen/CommandFlags.h
+include/llvm/CodeGen/DAGCombine.h
include/llvm/CodeGen/DFAPacketizer.h
include/llvm/CodeGen/EdgeBundles.h
include/llvm/CodeGen/FastISel.h
@@ -194,7 +197,9 @@ include/llvm/CodeGen/LinkAllAsmWriterComponents.h
include/llvm/CodeGen/LinkAllCodegenComponents.h
include/llvm/CodeGen/LiveInterval.h
include/llvm/CodeGen/LiveIntervalAnalysis.h
+include/llvm/CodeGen/LiveIntervalUnion.h
include/llvm/CodeGen/LiveRangeEdit.h
+include/llvm/CodeGen/LiveRegMatrix.h
include/llvm/CodeGen/LiveStackAnalysis.h
include/llvm/CodeGen/LiveVariables.h
include/llvm/CodeGen/MachORelocation.h
@@ -214,12 +219,12 @@ include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineInstrBundle.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLoopInfo.h
-include/llvm/CodeGen/MachineLoopRanges.h
include/llvm/CodeGen/MachineMemOperand.h
include/llvm/CodeGen/MachineModuleInfo.h
include/llvm/CodeGen/MachineModuleInfoImpls.h
include/llvm/CodeGen/MachineOperand.h
include/llvm/CodeGen/MachinePassRegistry.h
+include/llvm/CodeGen/MachinePostDominators.h
include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/MachineSSAUpdater.h
@@ -241,6 +246,7 @@ include/llvm/CodeGen/ResourcePriorityQueue.h
include/llvm/CodeGen/RuntimeLibcalls.h
include/llvm/CodeGen/ScheduleDAG.h
include/llvm/CodeGen/ScheduleDAGInstrs.h
+include/llvm/CodeGen/ScheduleDFS.h
include/llvm/CodeGen/ScheduleHazardRecognizer.h
include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/ScoreboardHazardRecognizer.h
@@ -249,60 +255,81 @@ include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
include/llvm/CodeGen/SlotIndexes.h
include/llvm/CodeGen/TargetLoweringObjectFileImpl.h
+include/llvm/CodeGen/TargetSchedule.h
include/llvm/CodeGen/ValueTypes.h
include/llvm/CodeGen/ValueTypes.td
+include/llvm/CodeGen/VirtRegMap.h
include/llvm/Config/AsmParsers.def
include/llvm/Config/AsmPrinters.def
include/llvm/Config/Disassemblers.def
include/llvm/Config/Targets.def
include/llvm/Config/config.h
include/llvm/Config/llvm-config.h
-include/llvm/Constant.h
-include/llvm/Constants.h
include/llvm/DIBuilder.h
include/llvm/DebugInfo.h
include/llvm/DebugInfo/DIContext.h
-include/llvm/DefaultPasses.h
-include/llvm/DerivedTypes.h
include/llvm/ExecutionEngine/ExecutionEngine.h
include/llvm/ExecutionEngine/GenericValue.h
-include/llvm/ExecutionEngine/IntelJITEventsWrapper.h
include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
include/llvm/ExecutionEngine/JITEventListener.h
include/llvm/ExecutionEngine/JITMemoryManager.h
include/llvm/ExecutionEngine/MCJIT.h
include/llvm/ExecutionEngine/OProfileWrapper.h
+include/llvm/ExecutionEngine/ObjectBuffer.h
+include/llvm/ExecutionEngine/ObjectImage.h
include/llvm/ExecutionEngine/RuntimeDyld.h
-include/llvm/Function.h
+include/llvm/ExecutionEngine/SectionMemoryManager.h
include/llvm/GVMaterializer.h
-include/llvm/GlobalAlias.h
-include/llvm/GlobalValue.h
-include/llvm/GlobalVariable.h
-include/llvm/IRBuilder.h
+include/llvm/IR/Argument.h
+include/llvm/IR/Attributes.h
+include/llvm/IR/BasicBlock.h
+include/llvm/IR/CallingConv.h
+include/llvm/IR/Constant.h
+include/llvm/IR/Constants.h
+include/llvm/IR/DataLayout.h
+include/llvm/IR/DerivedTypes.h
+include/llvm/IR/Function.h
+include/llvm/IR/GlobalAlias.h
+include/llvm/IR/GlobalValue.h
+include/llvm/IR/GlobalVariable.h
+include/llvm/IR/IRBuilder.h
+include/llvm/IR/InlineAsm.h
+include/llvm/IR/InstrTypes.h
+include/llvm/IR/Instruction.def
+include/llvm/IR/Instruction.h
+include/llvm/IR/Instructions.h
+include/llvm/IR/IntrinsicInst.h
+include/llvm/IR/Intrinsics.gen
+include/llvm/IR/Intrinsics.h
+include/llvm/IR/Intrinsics.td
+include/llvm/IR/IntrinsicsARM.td
+include/llvm/IR/IntrinsicsHexagon.td
+include/llvm/IR/IntrinsicsMips.td
+include/llvm/IR/IntrinsicsNVVM.td
+include/llvm/IR/IntrinsicsPowerPC.td
+include/llvm/IR/IntrinsicsR600.td
+include/llvm/IR/IntrinsicsX86.td
+include/llvm/IR/IntrinsicsXCore.td
+include/llvm/IR/LLVMContext.h
+include/llvm/IR/MDBuilder.h
+include/llvm/IR/Metadata.h
+include/llvm/IR/Module.h
+include/llvm/IR/OperandTraits.h
+include/llvm/IR/Operator.h
+include/llvm/IR/SymbolTableListTraits.h
+include/llvm/IR/Type.h
+include/llvm/IR/TypeBuilder.h
+include/llvm/IR/TypeFinder.h
+include/llvm/IR/Use.h
+include/llvm/IR/User.h
+include/llvm/IR/Value.h
+include/llvm/IR/ValueSymbolTable.h
include/llvm/InitializePasses.h
-include/llvm/InlineAsm.h
-include/llvm/InstrTypes.h
-include/llvm/Instruction.def
-include/llvm/Instruction.h
-include/llvm/Instructions.h
-include/llvm/IntrinsicInst.h
-include/llvm/Intrinsics.gen
-include/llvm/Intrinsics.h
-include/llvm/Intrinsics.td
-include/llvm/IntrinsicsARM.td
-include/llvm/IntrinsicsCellSPU.td
-include/llvm/IntrinsicsHexagon.td
-include/llvm/IntrinsicsMips.td
-include/llvm/IntrinsicsNVVM.td
-include/llvm/IntrinsicsPowerPC.td
-include/llvm/IntrinsicsX86.td
-include/llvm/IntrinsicsXCore.td
-include/llvm/LLVMContext.h
+include/llvm/InstVisitor.h
include/llvm/LinkAllPasses.h
include/llvm/LinkAllVMCore.h
include/llvm/Linker.h
-include/llvm/MC/EDInstInfo.h
include/llvm/MC/MCAsmBackend.h
include/llvm/MC/MCAsmInfo.h
include/llvm/MC/MCAsmInfoCOFF.h
@@ -316,13 +343,16 @@ include/llvm/MC/MCContext.h
include/llvm/MC/MCDirectives.h
include/llvm/MC/MCDisassembler.h
include/llvm/MC/MCDwarf.h
+include/llvm/MC/MCELF.h
include/llvm/MC/MCELFObjectWriter.h
+include/llvm/MC/MCELFStreamer.h
include/llvm/MC/MCELFSymbolFlags.h
include/llvm/MC/MCExpr.h
include/llvm/MC/MCFixedLenDisassembler.h
include/llvm/MC/MCFixup.h
include/llvm/MC/MCFixupKindInfo.h
include/llvm/MC/MCInst.h
+include/llvm/MC/MCInstBuilder.h
include/llvm/MC/MCInstPrinter.h
include/llvm/MC/MCInstrAnalysis.h
include/llvm/MC/MCInstrDesc.h
@@ -350,7 +380,6 @@ include/llvm/MC/MCSectionMachO.h
include/llvm/MC/MCStreamer.h
include/llvm/MC/MCSubtargetInfo.h
include/llvm/MC/MCSymbol.h
-include/llvm/MC/MCTargetAsmLexer.h
include/llvm/MC/MCTargetAsmParser.h
include/llvm/MC/MCValue.h
include/llvm/MC/MCWin64EH.h
@@ -358,9 +387,6 @@ include/llvm/MC/MCWinCOFFObjectWriter.h
include/llvm/MC/MachineLocation.h
include/llvm/MC/SectionKind.h
include/llvm/MC/SubtargetFeature.h
-include/llvm/MDBuilder.h
-include/llvm/Metadata.h
-include/llvm/Module.h
include/llvm/Object/Archive.h
include/llvm/Object/Binary.h
include/llvm/Object/COFF.h
@@ -370,8 +396,13 @@ include/llvm/Object/MachO.h
include/llvm/Object/MachOFormat.h
include/llvm/Object/MachOObject.h
include/llvm/Object/ObjectFile.h
-include/llvm/OperandTraits.h
-include/llvm/Operator.h
+include/llvm/Object/RelocVisitor.h
+include/llvm/Option/Arg.h
+include/llvm/Option/ArgList.h
+include/llvm/Option/OptParser.td
+include/llvm/Option/OptSpecifier.h
+include/llvm/Option/OptTable.h
+include/llvm/Option/Option.h
include/llvm/Pass.h
include/llvm/PassAnalysisSupport.h
include/llvm/PassManager.h
@@ -381,6 +412,7 @@ include/llvm/PassSupport.h
include/llvm/Support/AIXDataTypesFix.h
include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
+include/llvm/Support/ArrayRecycler.h
include/llvm/Support/Atomic.h
include/llvm/Support/BlockFrequency.h
include/llvm/Support/BranchProbability.h
@@ -422,7 +454,6 @@ include/llvm/Support/Host.h
include/llvm/Support/IRReader.h
include/llvm/Support/IncludeFile.h
include/llvm/Support/InstIterator.h
-include/llvm/Support/InstVisitor.h
include/llvm/Support/IntegersSubset.h
include/llvm/Support/IntegersSubsetMapping.h
include/llvm/Support/LEB128.h
@@ -478,24 +509,21 @@ include/llvm/Support/Valgrind.h
include/llvm/Support/ValueHandle.h
include/llvm/Support/Win64EH.h
include/llvm/Support/YAMLParser.h
+include/llvm/Support/YAMLTraits.h
include/llvm/Support/circular_raw_ostream.h
include/llvm/Support/raw_os_ostream.h
include/llvm/Support/raw_ostream.h
include/llvm/Support/system_error.h
include/llvm/Support/type_traits.h
-include/llvm/SymbolTableListTraits.h
include/llvm/TableGen/Error.h
include/llvm/TableGen/Main.h
include/llvm/TableGen/Record.h
include/llvm/TableGen/StringMatcher.h
-include/llvm/TableGen/TableGenAction.h
include/llvm/TableGen/TableGenBackend.h
include/llvm/Target/Mangler.h
include/llvm/Target/Target.td
include/llvm/Target/TargetCallingConv.h
include/llvm/Target/TargetCallingConv.td
-include/llvm/Target/TargetData.h
-include/llvm/Target/TargetELFWriterInfo.h
include/llvm/Target/TargetFrameLowering.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetIntrinsicInfo.h
@@ -517,30 +545,24 @@ include/llvm/Transforms/IPO/InlinerPass.h
include/llvm/Transforms/IPO/PassManagerBuilder.h
include/llvm/Transforms/Instrumentation.h
include/llvm/Transforms/Scalar.h
-include/llvm/Transforms/Utils/AddrModeMatcher.h
include/llvm/Transforms/Utils/BasicBlockUtils.h
include/llvm/Transforms/Utils/BuildLibCalls.h
include/llvm/Transforms/Utils/BypassSlowDivision.h
include/llvm/Transforms/Utils/Cloning.h
include/llvm/Transforms/Utils/CmpInstAnalysis.h
include/llvm/Transforms/Utils/CodeExtractor.h
+include/llvm/Transforms/Utils/IntegerDivision.h
include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/ModuleUtils.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
include/llvm/Transforms/Utils/SSAUpdater.h
include/llvm/Transforms/Utils/SSAUpdaterImpl.h
include/llvm/Transforms/Utils/SimplifyIndVar.h
+include/llvm/Transforms/Utils/SimplifyLibCalls.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
include/llvm/Transforms/Utils/UnrollLoop.h
include/llvm/Transforms/Utils/ValueMapper.h
include/llvm/Transforms/Vectorize.h
-include/llvm/Type.h
-include/llvm/TypeBuilder.h
-include/llvm/TypeFinder.h
-include/llvm/Use.h
-include/llvm/User.h
-include/llvm/Value.h
-include/llvm/ValueSymbolTable.h
lib/BugpointPasses.so
lib/LLVMHello.so
lib/libLLVM-%%LLVM_RELEASE%%svn.so
@@ -557,9 +579,6 @@ lib/libLLVMAsmParser.a
lib/libLLVMAsmPrinter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
-lib/libLLVMCellSPUCodeGen.a
-lib/libLLVMCellSPUDesc.a
-lib/libLLVMCellSPUInfo.a
lib/libLLVMCodeGen.a
lib/libLLVMCore.a
lib/libLLVMCppBackendCodeGen.a
@@ -600,6 +619,7 @@ lib/libLLVMNVPTXCodeGen.a
lib/libLLVMNVPTXDesc.a
lib/libLLVMNVPTXInfo.a
lib/libLLVMObject.a
+lib/libLLVMOption.a
lib/libLLVMPowerPCAsmPrinter.a
lib/libLLVMPowerPCCodeGen.a
lib/libLLVMPowerPCDesc.a
@@ -622,8 +642,10 @@ lib/libLLVMX86Desc.a
lib/libLLVMX86Disassembler.a
lib/libLLVMX86Info.a
lib/libLLVMX86Utils.a
+lib/libLLVMXCoreAsmPrinter.a
lib/libLLVMXCoreCodeGen.a
lib/libLLVMXCoreDesc.a
+lib/libLLVMXCoreDisassembler.a
lib/libLLVMXCoreInfo.a
lib/libLLVMipa.a
lib/libLLVMipo.a
@@ -652,69 +674,121 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CommandLine.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandLine.txt
%%PORTDOCS%%%%DOCSDIR%%/html/CompilerWriterInfo.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CompilerWriterInfo.txt
%%PORTDOCS%%%%DOCSDIR%%/html/DebuggingJITedCode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/DebuggingJITedCode.txt
%%PORTDOCS%%%%DOCSDIR%%/html/DeveloperPolicy.html
%%PORTDOCS%%%%DOCSDIR%%/html/DeveloperPolicy.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/Dummy.html
%%PORTDOCS%%%%DOCSDIR%%/html/ExceptionHandling.html
%%PORTDOCS%%%%DOCSDIR%%/html/ExceptionHandling.txt
%%PORTDOCS%%%%DOCSDIR%%/html/ExtendingLLVM.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ExtendingLLVM.txt
%%PORTDOCS%%%%DOCSDIR%%/html/FAQ.html
%%PORTDOCS%%%%DOCSDIR%%/html/FAQ.txt
%%PORTDOCS%%%%DOCSDIR%%/html/FileCheck.html
%%PORTDOCS%%%%DOCSDIR%%/html/FileCheck.txt
-%%PORTDOCS%%%%DOCSDIR%%/html/GCCFEBuildInstrs.html
%%PORTDOCS%%%%DOCSDIR%%/html/GarbageCollection.html
+%%PORTDOCS%%%%DOCSDIR%%/html/GarbageCollection.txt
%%PORTDOCS%%%%DOCSDIR%%/html/GetElementPtr.html
%%PORTDOCS%%%%DOCSDIR%%/html/GetElementPtr.txt
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStarted.html
+%%PORTDOCS%%%%DOCSDIR%%/html/GettingStarted.txt
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStartedVS.html
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStartedVS.txt
%%PORTDOCS%%%%DOCSDIR%%/html/GoldPlugin.html
+%%PORTDOCS%%%%DOCSDIR%%/html/GoldPlugin.txt
%%PORTDOCS%%%%DOCSDIR%%/html/HowToAddABuilder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToAddABuilder.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToBuildOnARM.html
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToBuildOnARM.txt
%%PORTDOCS%%%%DOCSDIR%%/html/HowToReleaseLLVM.html
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToReleaseLLVM.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToSetUpLLVMStyleRTTI.html
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToSetUpLLVMStyleRTTI.txt
%%PORTDOCS%%%%DOCSDIR%%/html/HowToSubmitABug.html
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToSubmitABug.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToUseInstrMappings.html
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToUseInstrMappings.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LLVMBuild.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LLVMBuild.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl1.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl2.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl3.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl4.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl5-cfg.png
%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl5.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl6.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl6.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl7.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl8.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LangRef.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangRef.txt
%%PORTDOCS%%%%DOCSDIR%%/html/Lexicon.html
%%PORTDOCS%%%%DOCSDIR%%/html/Lexicon.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LinkTimeOptimization.html
%%PORTDOCS%%%%DOCSDIR%%/html/LinkTimeOptimization.txt
%%PORTDOCS%%%%DOCSDIR%%/html/MakefileGuide.html
%%PORTDOCS%%%%DOCSDIR%%/html/MakefileGuide.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/MarkedUpDisassembly.html
+%%PORTDOCS%%%%DOCSDIR%%/html/MarkedUpDisassembly.txt
%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl1.txt
%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl2.txt
%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl3.txt
%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl4.txt
%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl5.txt
%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl6.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl6.txt
%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl7.txt
%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl8.txt
%%PORTDOCS%%%%DOCSDIR%%/html/Packaging.html
%%PORTDOCS%%%%DOCSDIR%%/html/Packaging.txt
%%PORTDOCS%%%%DOCSDIR%%/html/Passes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Passes.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/Phabricator.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Phabricator.txt
%%PORTDOCS%%%%DOCSDIR%%/html/ProgrammersManual.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ProgrammersManual.txt
%%PORTDOCS%%%%DOCSDIR%%/html/Projects.html
%%PORTDOCS%%%%DOCSDIR%%/html/Projects.txt
%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes.txt
%%PORTDOCS%%%%DOCSDIR%%/html/SegmentedStacks.html
%%PORTDOCS%%%%DOCSDIR%%/html/SegmentedStacks.txt
%%PORTDOCS%%%%DOCSDIR%%/html/SourceLevelDebugging.html
+%%PORTDOCS%%%%DOCSDIR%%/html/SourceLevelDebugging.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/SphinxQuickstartTemplate.html
+%%PORTDOCS%%%%DOCSDIR%%/html/SphinxQuickstartTemplate.txt
%%PORTDOCS%%%%DOCSDIR%%/html/SystemLibrary.html
+%%PORTDOCS%%%%DOCSDIR%%/html/SystemLibrary.txt
%%PORTDOCS%%%%DOCSDIR%%/html/TableGenFundamentals.html
%%PORTDOCS%%%%DOCSDIR%%/html/TableGenFundamentals.txt
%%PORTDOCS%%%%DOCSDIR%%/html/TestSuiteMakefileGuide.html
+%%PORTDOCS%%%%DOCSDIR%%/html/TestSuiteMakefileGuide.txt
%%PORTDOCS%%%%DOCSDIR%%/html/TestingGuide.html
+%%PORTDOCS%%%%DOCSDIR%%/html/TestingGuide.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/Vectorizers.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Vectorizers.txt
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMBackend.html
+%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMBackend.txt
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMPass.html
+%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMPass.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/YamlIO.html
+%%PORTDOCS%%%%DOCSDIR%%/html/YamlIO.txt
%%PORTDOCS%%%%DOCSDIR%%/html/ajax-loader.gif
%%PORTDOCS%%%%DOCSDIR%%/html/basic.css
%%PORTDOCS%%%%DOCSDIR%%/html/bugpoint.html
@@ -732,11 +806,13 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/down.png
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/html/file.png
+%%PORTDOCS%%%%DOCSDIR%%/html/gcc-loops.png
%%PORTDOCS%%%%DOCSDIR%%/html/genindex.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.txt
%%PORTDOCS%%%%DOCSDIR%%/html/jquery.js
%%PORTDOCS%%%%DOCSDIR%%/html/lines.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/linpack-pc.png
%%PORTDOCS%%%%DOCSDIR%%/html/lit.html
%%PORTDOCS%%%%DOCSDIR%%/html/lit.txt
%%PORTDOCS%%%%DOCSDIR%%/html/llc.html
@@ -806,9 +882,11 @@ lib/libprofile_rt.so
@dirrm include/llvm/Target
@dirrm include/llvm/TableGen
@dirrm include/llvm/Support
+@dirrm include/llvm/Option
@dirrm include/llvm/Object
@dirrm include/llvm/MC/MCParser
@dirrm include/llvm/MC
+@dirrm include/llvm/IR
@dirrm include/llvm/ExecutionEngine
@dirrm include/llvm/DebugInfo
@dirrm include/llvm/Config