aboutsummaryrefslogtreecommitdiff
path: root/devel/love5/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 15:48:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 15:48:37 +0000
commitc86d5171b00b5a6792f8b454b41a9e546a901928 (patch)
treed3f566d33c1c277339a405fde6ea6675709da7fe /devel/love5/Makefile
parent68ed39eeefdb013edeec2f589b10d15aca013667 (diff)
downloadports-c86d5171b00b5a6792f8b454b41a9e546a901928.tar.gz
ports-c86d5171b00b5a6792f8b454b41a9e546a901928.zip
Notes
Diffstat (limited to 'devel/love5/Makefile')
-rw-r--r--devel/love5/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/love5/Makefile b/devel/love5/Makefile
index 1ae46acd36f8..503466f85c40 100644
--- a/devel/love5/Makefile
+++ b/devel/love5/Makefile
@@ -10,14 +10,15 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Open-source 2D game engine
-LIB_DEPENDS= IL:${PORTSDIR}/graphics/devil \
- physfs:${PORTSDIR}/devel/physfs \
- freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libIL.so:${PORTSDIR}/graphics/devil \
+ libphysfs.so:${PORTSDIR}/devel/physfs \
+ libfreetype.so:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
LATEST_LINK= love5
+
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
USE_SDL= sdl mixer
USE_GL= gl glu
USE_LUA= 5.1+
@@ -34,7 +35,6 @@ PLIST_FILES= bin/love5
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}5
PORTDOCS= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -45,9 +45,9 @@ post-patch:
.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in changes.txt readme.txt
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif