aboutsummaryrefslogtreecommitdiff
path: root/devel/lua50-posix
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2006-11-02 00:38:06 +0000
committerPhilip Paeps <philip@FreeBSD.org>2006-11-02 00:38:06 +0000
commitadb4c0b0550a6f4e2cea0aee65d3ea9282e4c5a2 (patch)
tree6a146557f118f3288f0207b658e29566705b34e7 /devel/lua50-posix
parent8824267a708f2c36abd992aa0d77034f88e30254 (diff)
downloadports-adb4c0b0550a6f4e2cea0aee65d3ea9282e4c5a2.tar.gz
ports-adb4c0b0550a6f4e2cea0aee65d3ea9282e4c5a2.zip
Notes
Diffstat (limited to 'devel/lua50-posix')
-rw-r--r--devel/lua50-posix/Makefile20
-rw-r--r--devel/lua50-posix/distinfo3
-rw-r--r--devel/lua50-posix/files/patch-Makefile30
-rw-r--r--devel/lua50-posix/files/patch-posix.lua8
4 files changed, 2 insertions, 59 deletions
diff --git a/devel/lua50-posix/Makefile b/devel/lua50-posix/Makefile
index 37ec1872664c..9979ebb26e84 100644
--- a/devel/lua50-posix/Makefile
+++ b/devel/lua50-posix/Makefile
@@ -5,24 +5,8 @@
# $FreeBSD$
#
-PORTNAME= posix
-PORTVERSION= 5.0
-CATEGORIES= devel
-MASTER_SITES= http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/5.0/
-PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
-DISTFILES= lposix.tar.gz
-
-MAINTAINER= andrew+ports@fubar.geek.nz
-COMMENT= A POSIX layer for Lua
-
USE_LUA= 5.0
-WRKSRC= ${WRKDIR}/posix
-
-PLIST_FILES= %%LUA_MODSHAREDIR%%/posix.lua \
- %%LUA_MODLIBDIR%%/lposix.so
-do-install:
- @${INSTALL_DATA} ${WRKSRC}/posix.lua ${LUA_MODSHAREDIR}
- @${INSTALL_PROGRAM} ${WRKSRC}/lposix.so ${LUA_MODLIBDIR}
+MASTERDIR= ${.CURDIR}/../lua-posix
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/lua50-posix/distinfo b/devel/lua50-posix/distinfo
deleted file mode 100644
index 87ec6b660a1a..000000000000
--- a/devel/lua50-posix/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (lposix.tar.gz) = f22871247e444412a901d179028a0d82
-SHA256 (lposix.tar.gz) = e5140e19df90069b579be7983506e2461b6678e9e80b82545b6ca8070fd318a3
-SIZE (lposix.tar.gz) = 9651
diff --git a/devel/lua50-posix/files/patch-Makefile b/devel/lua50-posix/files/patch-Makefile
deleted file mode 100644
index b0eb70640eb4..000000000000
--- a/devel/lua50-posix/files/patch-Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
---- Makefile.orig Wed Nov 5 21:26:49 2003
-+++ Makefile Mon Aug 7 00:38:38 2006
-@@ -1,13 +1,13 @@
- # makefile for POSIX library for Lua
-
- # change these to reflect your Lua installation
--LUA= /tmp/lhf/lua-5.0
--LUAINC= $(LUA)/include
--LUALIB= $(LUA)/lib
--LUABIN= $(LUA)/bin
-+LUA= ${PREFIX}
-+LUAINC= $(LUA_INCDIR)
-+LUALIB= $(LUA_LIBDIR)
-+LUABIN= $(LUA_BINDIR)
-
- # no need to change anything below here
--CFLAGS= -fPIC $(INCS) $(WARN) -O2 $G
-+CFLAGS+= -fPIC $(INCS) $(WARN) -O2 $G
- WARN= -pedantic -Wall
- INCS= -I$(LUAINC)
-
-@@ -21,7 +21,7 @@
- all: test
-
- test: $T
-- $(LUABIN)/lua -l$(MYNAME) test.lua
-+ LD_PRELOAD=${LUA_LIBDIR}/liblua.so:${LUA_LIBDIR}/liblualib.so $(LUABIN)/lua -l$(MYNAME) test.lua
-
- $T: $(OBJS)
- $(CC) -o $@ -shared $(OBJS)
diff --git a/devel/lua50-posix/files/patch-posix.lua b/devel/lua50-posix/files/patch-posix.lua
deleted file mode 100644
index 175746fb81df..000000000000
--- a/devel/lua50-posix/files/patch-posix.lua
+++ /dev/null
@@ -1,8 +0,0 @@
---- posix.lua.orig Tue Apr 11 23:59:52 2006
-+++ posix.lua Wed Apr 12 00:00:49 2006
-@@ -8,3 +8,5 @@
- end
-
- so"posix"
-+
-+return posix