aboutsummaryrefslogtreecommitdiff
path: root/devel/luabind
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-21 00:26:47 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-21 00:26:47 +0000
commitf035a7ab040fe42e7b5cf514ed86eaea662467f5 (patch)
treeaefa36b808c6e66a43e0c234b205bf5d629ee904 /devel/luabind
parent082ce1d493f589f67b1b654dd4da4a615c13c383 (diff)
downloadports-f035a7ab040fe42e7b5cf514ed86eaea662467f5.tar.gz
ports-f035a7ab040fe42e7b5cf514ed86eaea662467f5.zip
Notes
Diffstat (limited to 'devel/luabind')
-rw-r--r--devel/luabind/Makefile1
-rw-r--r--devel/luabind/files/patch-luabind-detail-policy.hpp12
2 files changed, 13 insertions, 0 deletions
diff --git a/devel/luabind/Makefile b/devel/luabind/Makefile
index cb8bff0014db..0774054143ec 100644
--- a/devel/luabind/Makefile
+++ b/devel/luabind/Makefile
@@ -32,6 +32,7 @@ PORTDOCS= *
post-patch:
${MKDIR} ${WRKSRC}/lib
+ @${FIND} ${WRKSRC}/luabind -name "*.orig" -delete
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/libluabind.a ${PREFIX}/lib
diff --git a/devel/luabind/files/patch-luabind-detail-policy.hpp b/devel/luabind/files/patch-luabind-detail-policy.hpp
new file mode 100644
index 000000000000..92ce710bb738
--- /dev/null
+++ b/devel/luabind/files/patch-luabind-detail-policy.hpp
@@ -0,0 +1,12 @@
+--- luabind/detail/policy.hpp.orig 2005-12-22 02:09:47.000000000 +0300
++++ luabind/detail/policy.hpp 2009-03-20 18:52:45.000000000 +0300
+@@ -1276,7 +1276,8 @@
+
+ namespace luabind { namespace
+ {
+-#if defined(__BORLANDC__) || (BOOST_VERSION >= 103400 && defined(__GNUC__))
++#if defined(__GNUC__) && \
++ (__GNUC__ * 100 + __GNUC_MINOR__ <= 400 || BOOST_VERSION <= 103401)
+ static inline boost::arg<0> return_value()
+ {
+ return boost::arg<0>();