aboutsummaryrefslogtreecommitdiff
path: root/devel/make++/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-22 13:23:17 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-22 13:23:17 +0000
commit8a9a2f1b7348c9f06c1086a2a5eb33fa1e624d03 (patch)
tree474f1c1b2a37b12b85105c7bac1e1854e756bf4b /devel/make++/Makefile
parentf3dd99f344035243121aa0afea28e17df2964866 (diff)
downloadports-8a9a2f1b7348c9f06c1086a2a5eb33fa1e624d03.tar.gz
ports-8a9a2f1b7348c9f06c1086a2a5eb33fa1e624d03.zip
Notes
Diffstat (limited to 'devel/make++/Makefile')
-rw-r--r--devel/make++/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/devel/make++/Makefile b/devel/make++/Makefile
new file mode 100644
index 000000000000..dfb0b414021e
--- /dev/null
+++ b/devel/make++/Makefile
@@ -0,0 +1,44 @@
+# ex:ts=8
+# New ports collection makefile for: make++
+# Date created: Fab 21, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= make++
+PORTVERSION= 1.10
+CATEGORIES= devel
+MASTER_SITES= http://lnc.usc.edu/~holt/makepp/
+DISTNAME= ${PORTNAME:S/+/p/g}-${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+
+USE_PERL5= yes
+
+do-build:
+ @${PERL} -pi -e "s|\@htmldir\@|${PREFIX}/share/makepp/html|g ; \
+ s|\@datadir\@|${PREFIX}/share/makepp|g" ${WRKSRC}/makepp
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/makepp ${PREFIX}/bin
+
+ @${MKDIR} ${PREFIX}/share/makepp
+ @${MKDIR} ${PREFIX}/share/makepp/Signature
+
+ ${INSTALL_SCRIPT} ${WRKSRC}/recursive_makepp ${PREFIX}/share/makepp
+
+.for module in FileInfo FileInfo_makepp MakeEvent Glob Makefile Makesubs Rule Signature TextSubs Signature/exact_match Signature/target_newer Signature/c_compilation_md5 Signature/md5
+ ${INSTALL_SCRIPT} ${WRKSRC}/${module}.pm ${PREFIX}/share/makepp/${module}.pm
+.endfor
+
+.for include in c_compilation_md5 infer_objects makepp_builtin_rules makepp_default_makefile
+ ${INSTALL_DATA} ${WRKSRC}/${include}.mk ${PREFIX}/share/makepp
+.endfor
+
+ @${MKDIR} ${PREFIX}/share/makepp/html
+ ${CP} ${WRKSRC}/doc/*.html ${PREFIX}/share/makepp/html
+
+.include <bsd.port.mk>