aboutsummaryrefslogtreecommitdiff
path: root/devel/mico
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-07 16:02:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-07 16:02:51 +0000
commit969c6806da8a46b538050c1c3f2d68cdcf5ceb10 (patch)
treeebd0bdb253a5c8718b5da3cd353b0df34cada4f2 /devel/mico
parent1ecfc1c1c9c0f9d1e05d7d30b4cd98a9bda9e474 (diff)
downloadports-969c6806da8a46b538050c1c3f2d68cdcf5ceb10.tar.gz
ports-969c6806da8a46b538050c1c3f2d68cdcf5ceb10.zip
Notes
Diffstat (limited to 'devel/mico')
-rw-r--r--devel/mico/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index 59350f1918d8..e18c419532c7 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mico
PORTVERSION= 2.3.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20${PORTVERSION}/
@@ -45,4 +45,12 @@ post-patch:
@${REINPLACE_CMD} 's/ministl//' ${WRKSRC}/include/Makefile
@${REINPLACE_CMD} 's/^main()/int &/' ${WRKSRC}/configure
+post-install:
+.for f in eventd idl imr iordump ird mico-cpp micod mkdepend nsadmin nsd propertyd timed
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
+.endfor
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/lib/*.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/lib/*.so
+
.include <bsd.port.mk>