aboutsummaryrefslogtreecommitdiff
path: root/devel/mongo-c-driver
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2013-07-05 19:43:36 +0000
committerWesley Shields <wxs@FreeBSD.org>2013-07-05 19:43:36 +0000
commit14f11a7a297ce9f27665f62f57b486343f02bdbc (patch)
treec87ca0f54ae6a4923ecccbca0782854e91162ca1 /devel/mongo-c-driver
parentde1aabf2c5583ced8e38b8bb913db8818c86f692 (diff)
downloadports-14f11a7a297ce9f27665f62f57b486343f02bdbc.tar.gz
ports-14f11a7a297ce9f27665f62f57b486343f02bdbc.zip
Notes
Diffstat (limited to 'devel/mongo-c-driver')
-rw-r--r--devel/mongo-c-driver/Makefile36
-rw-r--r--devel/mongo-c-driver/distinfo2
-rw-r--r--devel/mongo-c-driver/files/patch-env-c54
-rw-r--r--devel/mongo-c-driver/pkg-descr7
4 files changed, 99 insertions, 0 deletions
diff --git a/devel/mongo-c-driver/Makefile b/devel/mongo-c-driver/Makefile
new file mode 100644
index 000000000000..bbc507ae0073
--- /dev/null
+++ b/devel/mongo-c-driver/Makefile
@@ -0,0 +1,36 @@
+# Created by: "Waitman Gobble" <uzimac@da3m0n8t3r.com>
+# $FreeBSD$
+
+PORTNAME= mongo-c-driver
+PORTVERSION= 0.7.1
+CATEGORIES= devel
+MASTER_SITES= GH
+PKGNAMESUFFIX= -devel
+DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${PORTVERSION}-0-g${GH_COMMIT}
+
+MAINTAINER= wxs@FreeBSD.org
+COMMENT= C Driver for MongoDB
+
+USE_GITHUB= yes
+GH_ACCOUNT= mongodb
+GH_PROJECT= mongo-c-driver
+GH_TAGNAME= v0.7.1
+GH_COMMIT= g98826a
+
+WRKSRC= ${WRKDIR}/mongodb-mongo-c-driver-17ff925
+USE_GMAKE= yes
+
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/mongo.h \
+ include/bson.h \
+ lib/libmongoc.a \
+ lib/libmongoc.so.0.7 \
+ lib/libmongoc.so.0.7.1 \
+ lib/libmongoc.so \
+ lib/libbson.a \
+ lib/libbson.so.0.7.1 \
+ lib/libbson.so.0.7 \
+ lib/libbson.so
+
+.include <bsd.port.mk>
diff --git a/devel/mongo-c-driver/distinfo b/devel/mongo-c-driver/distinfo
new file mode 100644
index 000000000000..d8fcc41edb13
--- /dev/null
+++ b/devel/mongo-c-driver/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mongodb-mongo-c-driver-0.7.1-0-gg98826a.tar.gz) = 6670b50bb4232cc617a114d1320ea97abc55f9570b4ebf53e1e6c22671ffc328
+SIZE (mongodb-mongo-c-driver-0.7.1-0-gg98826a.tar.gz) = 108537
diff --git a/devel/mongo-c-driver/files/patch-env-c b/devel/mongo-c-driver/files/patch-env-c
new file mode 100644
index 000000000000..773f6df5f188
--- /dev/null
+++ b/devel/mongo-c-driver/files/patch-env-c
@@ -0,0 +1,54 @@
+--- src/env.c.orig 2013-01-26 10:53:37.000000000 -0800
++++ src/env.c 2013-01-26 10:20:49.000000000 -0800
+@@ -1,3 +1,7 @@
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ #if !defined(MONGO_ENV_STANDARD) && (defined(_WIN32) || defined(_WIN64))
+
+ /* env_win32.c */
+@@ -34,6 +38,7 @@
+ # define NI_MAXSERV 32
+ #endif
+
++
+ int mongo_env_close_socket( int socket ) {
+ return closesocket( socket );
+ }
+@@ -179,7 +184,7 @@
+ }
+
+
+-#elif !defined(MONGO_ENV_STANDARD) && (defined(__APPLE__) || defined(__linux) || defined(__unix) || defined(__posix))
++#elif !defined(MONGO_ENV_STANDARD) && (defined(__APPLE__) || defined(__linux) || defined(__unix) || defined(__posix) || defined(BSD))
+
+ /* env_posix.c */
+
+@@ -227,7 +232,7 @@
+
+ int mongo_env_write_socket( mongo *conn, const void *buf, size_t len ) {
+ const char *cbuf = buf;
+-#ifdef __APPLE__
++#if defined (__APPLE__) || defined(BSD)
+ int flags = 0;
+ #else
+ int flags = MSG_NOSIGNAL;
+@@ -357,7 +362,7 @@
+ conn->sock = 0;
+ continue;
+ }
+-#if __APPLE__
++#if __APPLE__
+ {
+ int flag = 1;
+ setsockopt( conn->sock, SOL_SOCKET, SO_NOSIGPIPE,
+@@ -448,7 +453,7 @@
+ #ifdef _WIN32
+ int flags = 0;
+ #else
+-#ifdef __APPLE__
++#ifdef __APPLE__ || BSD
+ int flags = 0;
+ #else
+ int flags = MSG_NOSIGNAL;
diff --git a/devel/mongo-c-driver/pkg-descr b/devel/mongo-c-driver/pkg-descr
new file mode 100644
index 000000000000..5429f2c3bc70
--- /dev/null
+++ b/devel/mongo-c-driver/pkg-descr
@@ -0,0 +1,7 @@
+Official Mongo C Driver (Development Version)
+
+Mongo (from "humongous") is a high-performance, open source,
+schema-free, document-oriented database. A common name in the
+"NOSQL" community.
+
+WWW: http://www.mongodb.org/