aboutsummaryrefslogtreecommitdiff
path: root/devel/monotone
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-10-25 06:13:15 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-10-25 06:13:15 +0000
commit9601043a1b7a6eea8fbbf3a03b05e34516e06262 (patch)
treeaf63265bb7fcacfc0aba8bd71c0ff64cd55626b2 /devel/monotone
parentecc9483b4ade917540551b11c48555f4b9c589a7 (diff)
downloadports-9601043a1b7a6eea8fbbf3a03b05e34516e06262.tar.gz
ports-9601043a1b7a6eea8fbbf3a03b05e34516e06262.zip
Notes
Diffstat (limited to 'devel/monotone')
-rw-r--r--devel/monotone/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/devel/monotone/Makefile b/devel/monotone/Makefile
index 19fec46df4c8..9c8defae67c2 100644
--- a/devel/monotone/Makefile
+++ b/devel/monotone/Makefile
@@ -7,7 +7,7 @@
PORTNAME= monotone
PORTVERSION= 0.23
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.venge.net/monotone/downloads/ \
http://norton.kettering.edu/freebsd/
@@ -15,9 +15,12 @@ MASTER_SITES= http://www.venge.net/monotone/downloads/ \
MAINTAINER= lapo@lapo.it
COMMENT= A distributed version control system with digital signatures
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
boost_regex.2:${PORTSDIR}/devel/boost
+OPTIONS= LUA_PORT "Use Lua port instead of the included one" on \
+ SQLITE_PORT "Use SQLite3 port instead of the included one" on
+
USE_REINPLACE= yes
USE_ICONV= yes
.if !defined(WITHOUT_NLS)
@@ -26,7 +29,8 @@ USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
+ MAKEINFO="makeinfo --no-split"
PLIST_FILES= bin/monotone
INFO= monotone
@@ -38,21 +42,25 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_FILES+= share/locale/fr/LC_MESSAGES/monotone.mo \
share/locale/ja/LC_MESSAGES/monotone.mo
.endif
-.if defined(WITH_LUA_PORT)
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_LUA_PORT)
LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua
CONFIGURE_ARGS+= --with-bundled-lua=no
.endif
-.if defined(WITH_SQLITE_PORT)
+.if !defined(WITHOUT_SQLITE_PORT)
LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
CONFIGURE_ARGS+= --with-bundled-sqlite=no
.endif
-.include <bsd.port.pre.mk>
-
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on FreeBSD 4.x"
.endif
+post-extract:
+ @${RM} -f ${WRKSRC}/monotone.info*
+
post-patch:
@${REINPLACE_CMD} -e 's|\($$(CXX) -Wall\)|\1 ${CXXFLAGS}|' \
${WRKSRC}/Makefile.in