aboutsummaryrefslogtreecommitdiff
path: root/devel/msp430-libc/Makefile
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2002-11-07 09:03:28 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2002-11-07 09:03:28 +0000
commit060ab004f2cbe69c0646f497f1727e7b68f02c3f (patch)
tree7dc45c4c8d6cce1391252685260c32ab55efa1f0 /devel/msp430-libc/Makefile
parentfd4b78651c6b5522b4a18ef9dc681b6944066788 (diff)
downloadports-060ab004f2cbe69c0646f497f1727e7b68f02c3f.tar.gz
ports-060ab004f2cbe69c0646f497f1727e7b68f02c3f.zip
Notes
Diffstat (limited to 'devel/msp430-libc/Makefile')
-rw-r--r--devel/msp430-libc/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/msp430-libc/Makefile b/devel/msp430-libc/Makefile
new file mode 100644
index 000000000000..6fbab1f7fbe9
--- /dev/null
+++ b/devel/msp430-libc/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: msp430-libc
+# Date created: 15 October 2002
+# Whom: Lev Serebryakov <lev@serebryakov.spb.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libc
+PORTVERSION= 0.1.20021016
+CATEGORIES= devel
+MASTER_SITES= http://lev.serebryakov.spb.ru/download/msp430/
+PKGNAMEPREFIX= msp430-
+
+MAINTAINER= lev@serebryakov.spb.ru
+
+BUILD_DEPENDS= ${PKGNAMEPREFIX}gcc:${PORTSDIR}/devel/${PKGNAMEPREFIX}gcc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}/src
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
+
+PLIST_SUB+= LIBC_TARG=${PKGNAMEPREFIX:S/-$//}
+
+post-configure:
+ ${REINPLACE_CMD} "s|prefix = /usr/local/msp430|prefix = ${PREFIX}|" ${WRKSRC}/Makefile
+
+post-install:
+ @${MKDIR} ${PREFIX}/${PKGNAMEPREFIX:S/-$//}/share/mspgcc
+ @tar --exclude CVS -C ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME} -cf - examples doc | \
+ tar -xf - -C ${PREFIX}/${PKGNAMEPREFIX:S/-$//}/share/mspgcc
+
+.include <bsd.port.mk>