aboutsummaryrefslogtreecommitdiff
path: root/devel/notcurses/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-06-12 12:17:08 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-06-12 12:17:08 +0000
commit34e680331a3fbbd813099f63b66750a9dd0258f9 (patch)
tree51049f19a7a32523b1f7bc6d4a15c81070031017 /devel/notcurses/Makefile
parentf177208d8a5d9b4a796bdb1b68da9308a4a79cce (diff)
downloadports-34e680331a3fbbd813099f63b66750a9dd0258f9.tar.gz
ports-34e680331a3fbbd813099f63b66750a9dd0258f9.zip
Notes
Diffstat (limited to 'devel/notcurses/Makefile')
-rw-r--r--devel/notcurses/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/devel/notcurses/Makefile b/devel/notcurses/Makefile
index 247bb5bc7294..d7ce64775884 100644
--- a/devel/notcurses/Makefile
+++ b/devel/notcurses/Makefile
@@ -2,7 +2,7 @@
PORTNAME= notcurses
DISTVERSIONPREFIX= v
-DISTVERSION= ${ABIVERSION}.4.3
+DISTVERSION= ${ABIVERSION}.5.0
CATEGORIES= devel
MAINTAINER= nickblack@linux.com
@@ -13,13 +13,17 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
libqrcodegen.so:graphics/qr-code-generator
+BUILD_DEPENDS= ${LOCALBASE}/include/doctest/doctest.h:devel/doctest
-USES= cmake compiler:c++17-lang localbase ncurses:port pkgconfig python:run shebangfix
-SHEBANG_FILES= src/pydemo/notcurses-pydemo
+USES= cmake compiler:c++17-lang localbase \
+ ncurses:port pkgconfig python:run shebangfix
USE_GITHUB= yes
+SHEBANG_FILES= src/pydemo/notcurses-pydemo
GH_ACCOUNT= dankamongmen
USE_LDCONFIG= yes
+LDFLAGS+= -lc
+
CMAKE_OFF= USE_PANDOC USE_TESTS USE_PYTHON
ABIVERSION= 1
@@ -30,4 +34,11 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= *
+.include <bsd.port.options.mk>
+
+# necessary until 1.5.1 for getrandom() in qrcode demo
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 1200000
+IGNORE+=requires getrandom(2) introduced in FreeBSD 12
+.endif
+
.include <bsd.port.mk>