aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-camomile-examples
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-19 09:55:25 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-19 09:55:25 +0000
commit3c05155a1a641a12432e3516f9108a61cf9d52f9 (patch)
tree5e48139caff46fbda79e598d90171d950ba2b001 /devel/ocaml-camomile-examples
parent56983a2a1b362c0150adc022b85bc350a9407bde (diff)
Support staging
Notes
Notes: svn path=/head/; revision=345054
Diffstat (limited to 'devel/ocaml-camomile-examples')
-rw-r--r--devel/ocaml-camomile-examples/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/ocaml-camomile-examples/Makefile b/devel/ocaml-camomile-examples/Makefile
index 31f8e00e4770..54bb6b864e6e 100644
--- a/devel/ocaml-camomile-examples/Makefile
+++ b/devel/ocaml-camomile-examples/Makefile
@@ -17,12 +17,11 @@ NO_BUILD= yes
USE_BZIP2= yes
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
-NO_STAGE= yes
do-install:
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${TAR} -cf- -C ${WRKSRC} . | \
- ${TAR} -xf- -C ${EXAMPLESDIR}
- @${FIND} ${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
- @${FIND} ${EXAMPLESDIR} -exec ${CHOWN} ${SHAREOWN} {} \;
+ ${TAR} -xf- -C ${STAGEDIR}${EXAMPLESDIR}
+ @${FIND} ${STAGEDIR}${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ @${FIND} ${STAGEDIR}${EXAMPLESDIR} -exec ${CHOWN} ${SHAREOWN} {} \;
.include <bsd.port.mk>