aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-cfg
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 06:57:18 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 06:57:18 +0000
commit9f01081b2b228a8f618f461a0010da6dbb24120a (patch)
tree08273b11461b38b7e8d92d961b14479689a033d8 /devel/ocaml-cfg
parent1e0c74a04598a4561e4d2bd460888c23ee9ba0ca (diff)
downloadports-9f01081b2b228a8f618f461a0010da6dbb24120a.tar.gz
ports-9f01081b2b228a8f618f461a0010da6dbb24120a.zip
Notes
Diffstat (limited to 'devel/ocaml-cfg')
-rw-r--r--devel/ocaml-cfg/Makefile67
-rw-r--r--devel/ocaml-cfg/distinfo3
-rw-r--r--devel/ocaml-cfg/pkg-descr5
3 files changed, 75 insertions, 0 deletions
diff --git a/devel/ocaml-cfg/Makefile b/devel/ocaml-cfg/Makefile
new file mode 100644
index 000000000000..efa975bc9b7c
--- /dev/null
+++ b/devel/ocaml-cfg/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: cfg
+# Date created: 2006-08-15
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= cfg
+PORTVERSION= 1.7.3
+CATEGORIES= devel
+MASTER_SITES= http://www.ocaml.info/ocaml_sources/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Library for manipulation of context-free grammars
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+USE_OCAML_WASH= yes
+
+DOCS= README
+DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
+EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
+
+# XXX: exists untill it will be committed to bsd.port.mk
+COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
+ 2>&1) && \
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
+ ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
+ ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${TARGETDIR}/,," >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
+ @${FIND} ${EXAMPLESDIR}/ ! -type d | \
+ ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
+ ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR}/ ! -type d | \
+ ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
+ ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+# XXX: temporary workaround for non-standard PREFIX
+ @${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null || true" \
+ >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/share/examples/ocaml 2>/dev/null||true" \
+ >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-cfg/distinfo b/devel/ocaml-cfg/distinfo
new file mode 100644
index 000000000000..75f6360bb90a
--- /dev/null
+++ b/devel/ocaml-cfg/distinfo
@@ -0,0 +1,3 @@
+MD5 (cfg-1.7.3.tar.bz2) = 7bca7c11eb2901b1f2076b6828de0d3d
+SHA256 (cfg-1.7.3.tar.bz2) = 6d450b370aed75146deb836b4233acf7b5d493e550a69fdae249bc14b2713e3f
+SIZE (cfg-1.7.3.tar.bz2) = 24235
diff --git a/devel/ocaml-cfg/pkg-descr b/devel/ocaml-cfg/pkg-descr
new file mode 100644
index 000000000000..754d83af91f1
--- /dev/null
+++ b/devel/ocaml-cfg/pkg-descr
@@ -0,0 +1,5 @@
+This OCaml-library consists of a set of modules which implement functions
+for manipulating context-free grammars (CFGs) in a purely functional way.
+
+Author: Markus Mottl <markus.mottl@gmail.com>
+WWW: http://www.ocaml.info/home/ocaml_sources.html