aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-cppo
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2011-12-26 15:35:06 +0000
committerEitan Adler <eadler@FreeBSD.org>2011-12-26 15:35:06 +0000
commitc7dc6be60e60670beae37c37fd5b3cfd7d9049e7 (patch)
treeb642321b4c58d2a82c43e7e33dfb248a26d499f7 /devel/ocaml-cppo
parent786f4aba13b6a9eeff765d85016a0410c09749b5 (diff)
downloadports-c7dc6be60e60670beae37c37fd5b3cfd7d9049e7.tar.gz
ports-c7dc6be60e60670beae37c37fd5b3cfd7d9049e7.zip
Notes
Diffstat (limited to 'devel/ocaml-cppo')
-rw-r--r--devel/ocaml-cppo/Makefile25
-rw-r--r--devel/ocaml-cppo/distinfo2
-rw-r--r--devel/ocaml-cppo/pkg-descr13
-rw-r--r--devel/ocaml-cppo/pkg-plist1
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/ocaml-cppo/Makefile b/devel/ocaml-cppo/Makefile
new file mode 100644
index 000000000000..b20af09e19bb
--- /dev/null
+++ b/devel/ocaml-cppo/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: cppo
+# Date created: 2011-12-26
+# Whom: Michael Grunewald
+#
+# $FreeBSD$
+#
+
+PORTNAME= cppo
+PORTVERSION= 0.9.2
+CATEGORIES= devel
+MASTER_SITES= http://martin.jambon.free.fr/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= michael.grunewald@laposte.net
+COMMENT= A simple preprocessor for OCaml
+
+USE_GZIP= yes
+USE_GMAKE= yes
+USE_OCAML= yes
+MAKE_JOBS_UNSAFE= yes
+
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-cppo/distinfo b/devel/ocaml-cppo/distinfo
new file mode 100644
index 000000000000..29197d4ea60f
--- /dev/null
+++ b/devel/ocaml-cppo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cppo-0.9.2.tar.gz) = ee4693b16e82e0d7f9b955dc6d935c518958fdd87b8e9402cc54a52e6e03897f
+SIZE (cppo-0.9.2.tar.gz) = 20234
diff --git a/devel/ocaml-cppo/pkg-descr b/devel/ocaml-cppo/pkg-descr
new file mode 100644
index 000000000000..2b98ee608c53
--- /dev/null
+++ b/devel/ocaml-cppo/pkg-descr
@@ -0,0 +1,13 @@
+Cppo is an equivalent of the C preprocessor targeted at the OCaml language
+
+The main purpose of cppo is to provide a lightweight tool for simple
+macro substitution (#define) and file inclusion (#include) for the
+occasional case when this is useful in OCaml. Processing specific
+sections of files by calling external programs is also possible via
+#ext directives.
+
+The implementation of cppo relies on the standard library of OCaml and
+on the standard parsing tools Ocamllex and Ocamlyacc, which contribute
+to the robustness of cppo across OCaml versions.
+
+WWW: http://martin.jambon.free.fr/cppo.html
diff --git a/devel/ocaml-cppo/pkg-plist b/devel/ocaml-cppo/pkg-plist
new file mode 100644
index 000000000000..854b89ab4f9b
--- /dev/null
+++ b/devel/ocaml-cppo/pkg-plist
@@ -0,0 +1 @@
+bin/cppo